]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
- doesn't build with non java-sun
[packages/subversion.git] / subversion.spec
1 # TODO:
2 # - fix java build with java-gcj-compat and s/java-sun/jdk/
3 # - remove net_client_only and add db bcond (then without apache and
4 #   without db => net_client_only - spec will be more simpler, I think)
5 # - finish ruby
6 #
7 # Conditional build:
8 %bcond_with     net_client_only         # build only net client
9 %bcond_without  neon                    # use serf instead of neon
10 %bcond_without  python                  # build without python bindings (broken)
11 %bcond_without  perl                    # build without perl bindings
12 %bcond_without  ruby                    # build without ruby bindings
13 %bcond_without  apache                  # build without apache support (webdav, etc)
14 %bcond_without  javahl                  # build without javahl support (Java high-level bindings)
15 %bcond_without  tests                   # don't perform "make check"
16 #
17 %ifnarch i586 i686 pentium3 pentium4 athlon %{x8664}
18 %undefine       with_javahl
19 %endif
20 #
21 %{!?with_net_client_only:%include       /usr/lib/rpm/macros.perl}
22 %define apxs    /usr/sbin/apxs
23 %define pdir    SVN
24 %define pnam    _Core
25 #
26 %if %{with neon}
27 %define webdavlib       neon
28 %else
29 %define webdavlib       serf
30 %endif
31 #
32 Summary:        A Concurrent Versioning system similar to but better than CVS
33 Summary(pl.UTF-8):      System kontroli wersji podobny, ale lepszy, niż CVS
34 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
35 Name:           subversion
36 Version:        1.6.0
37 Release:        0.1
38 License:        Apache/BSD-like
39 Group:          Development/Version Control
40 Source0:        http://subversion.tigris.org/downloads/%{name}-%{version}-rc3.tar.bz2
41 # Source0-md5:  58473cb07611fd7567b6ce99461009e1
42 Source1:        %{name}-dav_svn.conf
43 Source2:        %{name}-authz_svn.conf
44 Source3:        %{name}-svnserve.init
45 Source4:        %{name}-svnserve.sysconfig
46 # current subversion tarball has correct *.swg files
47 # but after regeneration these are broken again, so
48 # we still need this script
49 Source5:        %{name}-convert-typemaps-to-ifdef.py
50 Patch0:         %{name}-home_etc.patch
51 Patch1:         %{name}-DESTDIR.patch
52 Patch2:         %{name}-ruby-datadir-path.patch
53 URL:            http://subversion.tigris.org/
54 %if %{with net_client_only}
55 %global apache_modules_api 0
56 %else
57 %{?with_apache:BuildRequires:   apache-devel >= 2.2.0-8}
58 BuildRequires:  automake
59 BuildRequires:  db-devel >= 4.1.25
60 BuildRequires:  rpmbuild(macros) >= 1.268
61 %if %{with perl}
62 BuildRequires:  perl-devel >= 1:5.8.0
63 BuildRequires:  rpm-perlprov >= 4.1-13
64 BuildRequires:  swig-perl >= 1.3.24
65 %endif
66 %{?with_javahl:BuildRequires:   java-sun}
67 %endif
68 BuildRequires:  apr-devel >= 1:1.0.0
69 BuildRequires:  apr-util-devel >= 1:1.2.8-3
70 BuildRequires:  autoconf >= 2.59
71 BuildRequires:  bison
72 BuildRequires:  cyrus-sasl-devel
73 BuildRequires:  expat-devel
74 BuildRequires:  gettext-devel
75 BuildRequires:  gnome-keyring-devel
76 BuildRequires:  kde4-kdelibs-devel
77 BuildRequires:  libtool >= 1.4-9
78 BuildRequires:  sed >= 4.0
79 BuildRequires:  texinfo
80 BuildRequires:  which
81 %if %{with neon}
82 BuildRequires:  neon-devel >= 0.26.0
83 %else
84 BuildRequires:  serf-devel
85 %endif
86 BuildRequires:  python >= 2.2
87 BuildRequires:  python-modules >= 2.2
88 %if %{with python}
89 BuildRequires:  python-devel >= 2.2
90 BuildRequires:  swig-python >= 1.3.24
91 %endif
92 %if %{with ruby}
93 BuildRequires:  ruby-devel
94 BuildRequires:  swig-ruby >= 1.3.24
95 %endif
96 Requires:       %{name}-libs = %{version}-%{release}
97 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
98
99 %define         _libexecdir             %{_libdir}/svn
100 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
101 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
102
103 %description
104 The goal of the Subversion project is to build a version control
105 system that is a compelling replacement for CVS in the open source
106 community.
107
108 Our goals are:
109 - All current CVS features.
110 - Directories, renames, and file meta-data are versioned.
111 - Symbolic links, etc, are supported
112 - Commits are truly atomic.
113 - Branching and tagging are cheap (constant time) operations
114 - Repeated merges are handled gracefully
115 - Support for plug-in client side diff programs
116 - Natively client/server
117 - Client/server protocol sends diffs in both directions
118 - Costs are proportional to change size, not project size
119 - Internationalization
120 - Progressive multi-lingual support
121
122 %description -l pl.UTF-8
123 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
124 zamiennika dla CVS.
125
126 Cele projektu to:
127 - Wszystkie aktualne możliwości CVS.
128 - Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
129 - Obsługa dowiązań symbolicznych itp.
130 - Commity są w pełni atomowe.
131 - Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
132 - Dobra obsługa powtarzanego łączenia (merge).
133 - Obsługa wtyczek diff po stronie klienta.
134 - Natywny klient/serwer.
135 - Klient/Serwer przesyłają diffy w obu kierunkach.
136 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
137 - Internacjonalizacja.
138 - Postępujące wsparcie dla wielu języków.
139
140 %description -l pt_BR.UTF-8
141 O objetivo do projeto Subversion é construir um sistema de controle de
142 versões que seja um substituto para o CVS (Concurrent Versioning
143 System) na comunidade opensource, fornecendo grandes melhorias.
144
145 %package libs
146 Summary:        Subversion libraries and modules
147 Summary(pl.UTF-8):      Biblioteka subversion oraz ładowalne moduły
148 Group:          Libraries
149 %{?with_neon:Requires:  neon >= 0.26.0}
150 Obsoletes:      libsubversion0
151
152 %description libs
153 Subversion libraries and modules.
154
155 %description libs -l pl.UTF-8
156 Biblioteka subversion oraz ładowalne moduły.
157
158 %package devel
159 Summary:        Header files and develpment documentation for subversion
160 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumetacja do subversion
161 Summary(pt_BR.UTF-8):   Arquivos de desenvolvimento para o Subversion
162 Group:          Development/Libraries
163 Requires:       %{name}-libs = %{version}-%{release}
164 Requires:       apr-util-devel >= 1:1.0.0
165 %{?with_neon:Requires:  neon-devel >= 0.26.0}
166 Obsoletes:      libsubversion0-devel
167
168 %description devel
169 Header files and develpment documentation for subversion.
170
171 %description devel -l pl.UTF-8
172 Pliki nagłówkowe i dokumetacja do subversion.
173
174 %description devel -l pt_BR.UTF-8
175 Este pacote provê os arquivos necessários para desenvolvedores
176 interagirem com o Subversion.
177
178 %package static
179 Summary:        Static subversion library
180 Summary(pl.UTF-8):      Biblioteka statyczna subversion
181 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
182 Group:          Development/Libraries
183 Requires:       %{name}-devel = %{version}
184 Obsoletes:      libsubversion0-static-devel
185
186 %description static
187 Static subversion library.
188
189 %description static -l pl.UTF-8
190 Biblioteka statyczna subversion.
191
192 %description static -l pt_BR.UTF-8
193 Este pacote provê um cliente estático do subversion.
194
195 %package svnserve
196 Summary:        Subversion svnserve
197 Summary(pl.UTF-8):      Subversion svnserve
198 Group:          Networking/Daemons
199 Requires(post,preun):   /sbin/chkconfig
200 Requires(postun):       /usr/sbin/groupdel
201 Requires(postun):       /usr/sbin/userdel
202 Requires(pre):  /bin/id
203 Requires(pre):  /usr/bin/getgid
204 Requires(pre):  /usr/lib/rpm/user_group.sh
205 Requires(pre):  /usr/sbin/groupadd
206 Requires(pre):  /usr/sbin/useradd
207 Requires(pre):  /usr/sbin/usermod
208 Requires:       %{name} = %{version}-%{release}
209 Requires:       rc-scripts
210 Provides:       group(svn)
211 Provides:       user(svn)
212
213 %description svnserve
214 Subversion svnserve server.
215
216 %description svnserve -l pl.UTF-8
217 Serwer subversion svnserve.
218
219 %package tools
220 Summary:        Subversion tools and scripts
221 Summary(pl.UTF-8):      Narzędzia oraz skrypty dla subversion
222 Summary(pt_BR.UTF-8):   Módulos python para acessar os recursos do Subversion
223 Group:          Applications
224 %pyrequires_eq  python
225 Requires:       %{name} = %{version}-%{release}
226 Requires:       python-rcsparse >= 0.1-0.20031026.0
227 Requires:       python-subversion = %{version}
228
229 %description tools
230 Subversion tools and scripts.
231
232 %description tools -l pl.UTF-8
233 Narzędzia oraz skrypty dla subversion.
234
235 %package -n bash-completion-subversion
236 Summary:        bash completion for subversion
237 Summary(pl.UTF-8):      Dopełnienia basha dla subversion
238 Group:          Applications/Shells
239 Requires:       %{name} = %{version}-%{release}
240 Requires:       bash-completion
241 Conflicts:      %{name}-tools <= 1.1.0-0.rc6.1
242
243 %description -n bash-completion-subversion
244 Bash completion for subversion.
245
246 %description -n bash-completion-subversion -l pl.UTF-8
247 Dopełnienia basha dla subversion.
248
249 %package -n java-subversion
250 Summary:        Subversion Java bindings
251 Summary(pl.UTF-8):      Dowiązania do Subversion dla Javy
252 Group:          Development/Languages/Java
253 Requires:       %{name}-libs = %{version}-%{release}
254
255 %description -n java-subversion
256 This is a set of Java classes which provide the functionality of
257 subversion-libs, the Subversion libraries. It is useful if you want
258 to, for example, write a Java class that manipulates a Subversion
259 repository or working copy. See the 'subversion' package for more
260 information.
261
262 %description -n java-subversion -l pl.UTF-8
263 Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
264 subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
265 pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
266 roboczą. Więcej informacji w pakiecie subversion.
267
268 %package -n python-subversion
269 Summary:        Subversion Python bindings
270 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
271 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
272 Group:          Development/Languages/Python
273 %pyrequires_eq  python
274 Requires:       %{name}-libs = %{version}-%{release}
275 Obsoletes:      subversion-python
276
277 %description -n python-subversion
278 Subversion Python bindings.
279
280 %description -n python-subversion -l pl.UTF-8
281 Dowiązania do Subversion dla Pythona.
282
283 %description -n python-subversion -l pt_BR.UTF-8
284 Módulos Python para acessar os recursos do Subversion.
285
286 %package -n perl-subversion
287 Summary:        Subversion Perl bindings
288 Summary(pl.UTF-8):      Dowiązania do Subversion dla Perla
289 Summary(pt_BR.UTF-8):   Módulos Perl para acessar os recursos do Subversion
290 Group:          Development/Languages/Perl
291 Requires:       %{name}-libs = %{version}-%{release}
292 Obsoletes:      subversion-perl
293
294 %description -n perl-subversion
295 Subversion Perl bindings.
296
297 %description -n perl-subversion -l pl.UTF-8
298 Dowiązania do Subversion dla Perla.
299
300 %description -n perl-subversion -l pt_BR.UTF-8
301 Módulos Perl para acessar os recursos do Subversion.
302
303 %package -n ruby-subversion
304 Summary:        Subversion Ruby bindings
305 Summary(pl.UTF-8):      Dowiązania do Subversion dla języka Ruby
306 Summary(pt_BR.UTF-8):   Módulos Ruby para acessar os recursos do Subversion
307 Group:          Development/Languages
308 Requires:       %{name}-libs = %{version}-%{release}
309 Obsoletes:      subversion-ruby
310
311 %description -n ruby-subversion
312 Subversion Ruby bindings.
313
314 %description -n ruby-subversion -l pl.UTF-8
315 Dowiązania do Subversion dla języka Ruby.
316
317 %description -n ruby-subversion -l pt_BR.UTF-8
318 Módulos Ruby para acessar os recursos do Subversion.
319
320 %package -n apache-mod_dav_svn
321 Summary:        Apache module: Subversion Server
322 Summary(pl.UTF-8):      Moduł apache: Serwer Subversion
323 Group:          Networking/Daemons
324 Requires:       %{name} = %{version}-%{release}
325 Requires:       apache(modules-api) = %apache_modules_api
326 Requires:       apache-mod_dav
327
328 %description -n apache-mod_dav_svn
329 Apache module: Subversion Server.
330
331 %description -n apache-mod_dav_svn -l pl.UTF-8
332 Moduł apache: Serwer Subversion.
333
334 %package -n apache-mod_authz_svn
335 Summary:        Apache module: Subversion Server - path-based authorization
336 Summary(pl.UTF-8):      Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
337 Group:          Networking/Daemons
338 Requires:       apache(modules-api) = %apache_modules_api
339 Requires:       apache-mod_dav_svn = %{version}-%{release}
340
341 %description -n apache-mod_authz_svn
342 Apache module: Subversion Server - path-based authorization.
343
344 %description -n apache-mod_authz_svn -l pl.UTF-8
345 Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
346
347 %package -n gnome-keyring-subversion
348 Summary:        Subversion module for Gnome Keyring
349 Summary(pl.UTF-8):      Moduł subversion dla zarządcy kluczy Gnome
350 Group:          X11/Applications
351
352 %description -n gnome-keyring-subversion
353 Subversion module for Gnome Keyring.
354
355 %description -n gnome-keyring-subversion -l pl.UTF-8
356 Moduł subversion dla zarządcy kluczy Gnome.
357
358 %package -n kde4-kwallet-subversion
359 Summary:        Subversion module for KDE Wallet
360 Summary(pl.UTF-8):      Moduł subversion dla Portfela KDE
361 Group:          X11/Applications
362
363 %description -n kde4-kwallet-subversion
364 Subversion module for KDE Wallet.
365
366 %description -n kde4-kwallet-subversion -l pl.UTF-8
367 Moduł subversion dla Portfela KDE.
368
369 %prep
370 %setup -q -n %{name}-%{version}-rc3
371 rm -rf apr apr-util neon
372 %patch0 -p0
373 %patch1 -p1
374 %patch2 -p0
375
376 sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
377
378 # serf.m4 macro is broken and ignores --without serf
379 %{?with_neon:sed -i -e 's#serf_found="yes"#serf_found="no"#g' build/ac-macros/serf.m4}
380
381 %build
382 rm subversion/bindings/swig/proxy/*.swg
383 cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
384 cp -f /usr/share/automake/config.sub ac-helpers
385 chmod +x ./autogen.sh && ./autogen.sh
386
387 %configure \
388         --with-editor=vi \
389         --with-zlib=%{_libdir} \
390 %if %{with net_client_only}
391         --without-apache \
392         --without-swig \
393         --without-apxs \
394         --without-berkeley-db \
395 %else
396         --disable-runtime-module-search \
397         --disable-mod-activation \
398 %if %{with apache}
399         --with-apxs=%{_sbindir}/apxs \
400 %else
401         --without-apache \
402         --without-apxs \
403         --with-berkeley-db=%{_includedir}/db4:%{_libdir} \
404 %endif
405 %if !%{with python} && !%{with perl} && !%{with ruby}
406         --without-swig \
407 %endif
408         --%{?with_javahl:en}%{!?with_javahl:dis}able-javahl \
409 %endif
410         --with-jdk="%{java_home}" \
411 %if %{with neon}
412         --without-serf \
413         --with-neon=%{_prefix} \
414         --disable-neon-version-check \
415 %else
416         --with-serf=%{_prefix} \
417         --without-neon \
418 %endif
419         --with-apr=%{_bindir}/apr-1-config \
420         --with-apr-util=%{_bindir}/apu-1-config \
421         --with-kwallet \
422         --with-gnome-keyring
423
424 %{__make} -j1
425
426 %if !%{with net_client_only}
427 # python
428 %if %{with python}
429 %{__make} swig-py \
430         swig_pydir=%{py_sitedir}/libsvn \
431         swig_pydir_extra=%{py_sitedir}/svn
432 %endif
433 # perl
434 %if %{with perl}
435 %{__make} -j1 swig-pl-lib
436 odir=$(pwd)
437 cd subversion/bindings/swig/perl/native
438 %{__perl} Makefile.PL INSTALLDIRS=vendor
439 %{__make} -j1
440 cd $odir
441 %endif
442 %if %{with javahl}
443 %{__make} -j1 javahl \
444         javahl_javadir="%{_javadir}"
445 %endif
446 # ruby
447 %if %{with ruby}
448 %{__make} swig-rb
449 %endif
450 %endif
451
452 %if %{with tests}
453 %{__make} check
454 %if %{with python}
455 %{__make} check-swig-py
456 %endif
457 %if %{with perl}
458 %{__make} check-swig-pl
459 %endif
460 %if %{with ruby}
461 %{__make} check-swig-rb
462 %endif
463 %endif
464
465 %install
466 rm -rf $RPM_BUILD_ROOT
467 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
468         $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
469         $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
470         $RPM_BUILD_ROOT/home/services/subversion{,/repos}
471
472 %{__make} install -j1 \
473 %if %{with javahl}
474         install-javahl \
475         javahl_javadir="%{_javadir}" \
476 %endif
477 %if !%{with net_client_only}
478 %if %{with python}
479         install-swig-py \
480 %endif
481 %if %{with ruby}
482         install-swig-rb install-swig-rb-doc \
483 %endif
484 %endif
485         APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
486         DESTDIR=$RPM_BUILD_ROOT \
487         swig_pydir=%{py_sitedir}/libsvn \
488         swig_pydir_extra=%{py_sitedir}/svn
489
490 %if !%{with net_client_only} && %{with perl}
491 %{__make} install-swig-pl-lib \
492         DESTDIR=$RPM_BUILD_ROOT
493 %{__make} -C subversion/bindings/swig/perl/native install \
494         DESTDIR=$RPM_BUILD_ROOT \
495         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
496         LIBDIR=$RPM_BUILD_ROOT%{_libdir}
497 %endif
498
499 %if %{with apache}
500 install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
501 install %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
502 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
503 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
504 %endif
505
506 %if !%{with net_client_only}
507 install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
508 %if %{with python}
509 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
510 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
511 find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
512 install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
513 %endif
514 %endif
515
516 install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
517 install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
518
519 %find_lang %{name}
520
521 rm $RPM_BUILD_ROOT%{_libdir}/libsvn{javahl,_swig}*.{la,a}
522 rm $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/*/*/svn/ext/*.la
523
524 %clean
525 rm -rf $RPM_BUILD_ROOT
526
527 %pre svnserve
528 %groupadd -g 86 svn
529 %useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
530
531 %post   libs -p /sbin/ldconfig
532 %postun libs -p /sbin/ldconfig
533
534 %post   devel -p /sbin/postshell
535 -/usr/sbin/fix-info-dir -c %{_infodir}
536
537 %postun devel -p /sbin/postshell
538 -/usr/sbin/fix-info-dir -c %{_infodir}
539
540 %post   -n perl-subversion -p /sbin/ldconfig
541 %postun -n perl-subversion -p /sbin/ldconfig
542
543 %post   -n python-subversion -p /sbin/ldconfig
544 %postun -n python-subversion -p /sbin/ldconfig
545
546 %post svnserve
547 /sbin/chkconfig --add svnserve
548 %service svnserve restart "svnserve daemon"
549
550 %preun svnserve
551 if [ "$1" = "0" ]; then
552         %service svnserve stop
553         /sbin/chkconfig --del svnserve
554 fi
555
556 %postun svnserve
557 if [ "$1" = "0" ]; then
558         %userremove svn
559         %groupremove svn
560 fi
561
562 %post -n apache-mod_dav_svn
563 %service -q httpd restart
564
565 %preun -n apache-mod_dav_svn
566 if [ "$1" = "0" ]; then
567         %service -q httpd restart
568 fi
569
570 %files
571 %defattr(644,root,root,755)
572 %doc BUGS CHANGES COPYING INSTALL README
573 %doc doc/*/*.html
574 %doc tools/hook-scripts/*.{pl,py,example}
575 %doc tools/hook-scripts/mailer/*.{py,example}
576 %doc tools/xslt/*
577 %attr(755,root,root) %{_bindir}/svn
578 %attr(755,root,root) %{_bindir}/svnadmin
579 %attr(755,root,root) %{_bindir}/svndumpfilter
580 %attr(755,root,root) %{_bindir}/svnlook
581 %attr(755,root,root) %{_bindir}/svnsync
582 %attr(755,root,root) %{_bindir}/svnversion
583 %{_mandir}/man1/svn.1*
584 %{_mandir}/man1/svnadmin.1*
585 %{_mandir}/man1/svndumpfilter.1*
586 %{_mandir}/man1/svnlook.1*
587 %{_mandir}/man1/svnsync.1*
588 %{_mandir}/man1/svnversion.1*
589
590 %files libs -f %{name}.lang
591 %defattr(644,root,root,755)
592 %attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
593 %attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
594 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
595 %attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
596 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
597 %attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
598 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
599 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
600 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
601 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
602 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
603 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
604 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
605 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
606 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
607 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
608 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
609 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
610 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so.*.*.*
611 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_%{webdavlib}-1.so.0
612 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
613 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
614 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
615 %attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
616 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
617 %attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
618 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
619 %attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
620
621 %files devel
622 %defattr(644,root,root,755)
623 %attr(755,root,root) %{_libdir}/libsvn_client-1.so
624 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so
625 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so
626 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so
627 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
628 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
629 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
630 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so
631 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
632 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so
633 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
634 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so
635 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so
636 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so
637 %{_libdir}/libsvn_client-1.la
638 %{_libdir}/libsvn_delta-1.la
639 %{_libdir}/libsvn_diff-1.la
640 %{_libdir}/libsvn_fs-1.la
641 %{_libdir}/libsvn_fs_base-1.la
642 %{_libdir}/libsvn_fs_fs-1.la
643 %{_libdir}/libsvn_fs_util-1.la
644 %{_libdir}/libsvn_ra-1.la
645 %{_libdir}/libsvn_ra_local-1.la
646 %{_libdir}/libsvn_ra_%{webdavlib}-1.la
647 %{_libdir}/libsvn_ra_svn-1.la
648 %{_libdir}/libsvn_repos-1.la
649 %{_libdir}/libsvn_subr-1.la
650 %{_libdir}/libsvn_wc-1.la
651 %{_includedir}/%{name}-1
652 %{_examplesdir}/%{name}-%{version}
653
654 %files static
655 %defattr(644,root,root,755)
656 %{_libdir}/libsvn_client-1.a
657 %{_libdir}/libsvn_delta-1.a
658 %{_libdir}/libsvn_diff-1.a
659 %{_libdir}/libsvn_fs-1.a
660 %{_libdir}/libsvn_fs_base-1.a
661 %{_libdir}/libsvn_fs_fs-1.a
662 %{_libdir}/libsvn_fs_util-1.a
663 %{_libdir}/libsvn_ra-1.a
664 %{_libdir}/libsvn_ra_local-1.a
665 %{_libdir}/libsvn_ra_%{webdavlib}-1.a
666 %{_libdir}/libsvn_ra_svn-1.a
667 %{_libdir}/libsvn_repos-1.a
668 %{_libdir}/libsvn_subr-1.a
669 %{_libdir}/libsvn_wc-1.a
670
671 %files -n gnome-keyring-subversion
672 %defattr(644,root,root,755)
673 %attr(755,root,root) %{_libdir}/libsvn_auth_gnome_keyring-1.so.*.*.*
674 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_gnome_keyring-1.so.0
675
676 %files -n kde4-kwallet-subversion
677 %defattr(644,root,root,755)
678 %attr(755,root,root) %{_libdir}/libsvn_auth_kwallet-1.so.*.*.*
679 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
680
681 %if !%{with net_client_only}
682 %files svnserve
683 %defattr(644,root,root,755)
684 %attr(755,root,root) %{_bindir}/svnserve
685 %{_mandir}/man5/svnserve.conf.5*
686 %{_mandir}/man8/svnserve.8*
687 %dir %attr(750,svn,svn) /home/services/subversion
688 %dir %attr(750,svn,svn) /home/services/subversion/repos
689 %if %{with apache}
690 %attr(754,root,root) /etc/rc.d/init.d/svnserve
691 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
692 %endif
693
694 %files tools
695 %defattr(644,root,root,755)
696 %attr(755,root,root) %{_bindir}/svn-hot-backup
697
698 %files -n bash-completion-subversion
699 %defattr(644,root,root,755)
700 /etc/bash_completion.d/%{name}
701
702 %if %{with javahl}
703 %files -n java-subversion
704 %defattr(644,root,root,755)
705 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
706 %attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
707 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
708 %{_javadir}/svn-javahl.jar
709 %endif
710
711 %if %{with python}
712 %files -n python-subversion
713 %defattr(644,root,root,755)
714 %doc tools/backup/*.py tools/examples/*.py
715 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
716 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
717 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
718 %dir %{py_sitedir}/libsvn
719 %{py_sitedir}/libsvn/*.py[co]
720 %dir %{py_sitedir}/svn
721 %{py_sitedir}/svn/*.py[co]
722 %attr(755,root,root) %{py_sitedir}/libsvn/*.so
723 %{_examplesdir}/python-%{name}-%{version}
724 %endif
725
726 %if %{with perl}
727 %files -n perl-subversion
728 %defattr(644,root,root,755)
729 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
730 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
731 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
732 %{perl_vendorarch}/SVN
733 %dir %{perl_vendorarch}/auto/SVN
734 %dir %{perl_vendorarch}/auto/SVN/*
735 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
736 %{perl_vendorarch}/auto/SVN/*/*.bs
737 %{_mandir}/man3/*.3pm*
738 %endif
739
740 %if %{with ruby}
741 %files -n ruby-subversion
742 %defattr(644,root,root,755)
743 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
744 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
745 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
746 %dir %{_libdir}/ruby/site_ruby/[0-9].[0-9]
747 %dir %{_libdir}/ruby/site_ruby/*/svn
748 %{_libdir}/ruby/site_ruby/*/svn/*.rb
749 %dir %{_libdir}/ruby/site_ruby/*/*-*
750 %dir %{_libdir}/ruby/site_ruby/*/*-*/svn/ext
751 %attr(755,root,root) %{_libdir}/ruby/site_ruby/*/*-*/svn/ext/*.so
752 %{_datadir}/ri/*.*/system/OptionParser
753 %{_datadir}/ri/*.*/system/Svn
754 %{_datadir}/ri/*.*/system/Time
755 %{_datadir}/ri/*.*/system/Uconv
756 %{_datadir}/ri/*.*/system/*.rid
757 %{_datadir}/ri/*.*/system/Kernel/*
758 %endif
759
760 %if %{with apache}
761 %files -n apache-mod_dav_svn
762 %defattr(644,root,root,755)
763 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
764 %attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
765
766 %files -n apache-mod_authz_svn
767 %defattr(644,root,root,755)
768 %doc subversion/mod_authz_svn/INSTALL
769 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
770 %attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
771 %endif
772
773 %endif # net_client_only
This page took 0.084791 seconds and 3 git commands to generate.