]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
- make --without ruby to work
[packages/subversion.git] / subversion.spec
1 # TODO:
2 # - finish ruby
3 # - http://subversion.tigris.org/issues/show_bug.cgi?id=2753
4 #
5 # Conditional build:
6 %bcond_with     net_client_only         # build only net client
7 %bcond_without  neon                    # use serf instead of neon
8 %bcond_without  swig                    # disable bindings generation with Swig
9 %bcond_without  python                  # build without python bindings (broken)
10 %bcond_without  perl                    # build without perl bindings
11 %bcond_without  ruby                    # build without ruby bindings
12 %bcond_without  apache                  # build without Apache support (webdav, etc)
13 %bcond_without  javahl                  # build without javahl support (Java high-level bindings)
14 %bcond_without  tests                   # don't perform "make check"
15 %bcond_without  kwallet                 # build without kde4 wallet support
16 %bcond_without  kde                     # build without kde4 support (alias for kwallet)
17 %bcond_without  gnome                   # build without gnome keyring support
18 %bcond_without  db                              # disable Subversion Berkeley DB based filesystem library
19
20 %if %{with net_client_only}
21 %undefine       with_apache
22 %undefine       with_db
23 %undefine       with_swig
24 %undefine       with_javahl
25 %endif
26
27 %if %{without swig}
28 %undefine       with_perl
29 %undefine       with_python
30 %undefine       with_ruby
31 %endif
32
33 %if %{without kde}
34 %undefine       with_kwallet
35 %endif
36
37 %if %{without python} && %{without perl} && %{without ruby}
38 %define         without_swig    1
39 %endif
40
41 %define apxs    /usr/sbin/apxs
42 %define pdir    SVN
43 %define pnam    _Core
44
45 %if %{with neon}
46 %define webdavlib       neon
47 %else
48 %define webdavlib       serf
49 %endif
50 %{!?with_perl:%include  /usr/lib/rpm/macros.perl}
51 Summary:        A Concurrent Versioning system similar to but better than CVS
52 Summary(pl.UTF-8):      System kontroli wersji podobny, ale lepszy, niż CVS
53 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
54 Name:           subversion
55 Version:        1.6.16
56 Release:        1
57 License:        Apache/BSD-like
58 Group:          Development/Version Control
59 Source0:        http://subversion.tigris.org/downloads/%{name}-%{version}.tar.bz2
60 # Source0-md5:  32f25a6724559fe8691d1f57a63f636e
61 Source1:        %{name}-dav_svn.conf
62 Source2:        %{name}-authz_svn.conf
63 Source3:        %{name}-svnserve.init
64 Source4:        %{name}-svnserve.sysconfig
65 # current subversion tarball has correct *.swg files
66 # but after regeneration these are broken again, so
67 # we still need this script
68 Source5:        %{name}-convert-typemaps-to-ifdef.py
69 Patch0:         %{name}-home_etc.patch
70 Patch1:         %{name}-DESTDIR.patch
71 Patch2:         %{name}-ruby-datadir-path.patch
72 Patch3:         %{name}-tests.patch
73 URL:            http://subversion.apache.org/
74 %{?with_apache:BuildRequires:   apache-devel >= 2.2.0-8}
75 BuildRequires:  autoconf
76 BuildRequires:  automake
77 BuildRequires:  db-devel >= 4.1.25
78 BuildRequires:  libtool
79 BuildRequires:  rpmbuild(macros) >= 1.583
80 %if %{with perl}
81 BuildRequires:  perl-devel >= 1:5.8.0
82 BuildRequires:  rpm-perlprov >= 4.1-13
83 BuildRequires:  swig-perl >= 1.3.24
84 %endif
85 %if %{with python}
86 BuildRequires:  python-ctypesgen
87 BuildRequires:  python-devel >= 1:2.5
88 BuildRequires:  swig-python >= 1.3.24
89 %endif
90 %if %{with ruby}
91 BuildRequires:  ruby-devel
92 BuildRequires:  ruby-rubygems
93 BuildRequires:  swig-ruby >= 1.3.24
94 %endif
95 %if %{with javahl}
96 BuildRequires:  jdk
97 %endif
98 BuildRequires:  cyrus-sasl-devel
99 BuildRequires:  apr-devel >= 1:1.0.0
100 BuildRequires:  apr-util-devel >= 1:1.2.8-3
101 BuildRequires:  autoconf >= 2.59
102 BuildRequires:  bison
103 BuildRequires:  expat-devel
104 BuildRequires:  gettext-devel
105 %{?with_kwallet:BuildRequires:  kde4-kdelibs-devel}
106 %{?with_gnome:BuildRequires:    libgnome-keyring-devel}
107 BuildRequires:  libtool >= 1.4-9
108 BuildRequires:  pkgconfig
109 BuildRequires:  rpm-pythonprov
110 BuildRequires:  sed >= 4.0
111 BuildRequires:  sqlite3-devel >= 3.6.11
112 BuildRequires:  texinfo
113 BuildRequires:  which
114 %if %{with neon}
115 BuildRequires:  neon-devel >= 0.26.0
116 %else
117 BuildRequires:  serf-devel
118 %endif
119 Requires:       %{name}-libs = %{version}-%{release}
120 %requires_ge    sqlite3
121 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
122
123 %define         _libexecdir             %{_libdir}/svn
124 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
125 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
126
127 %define         skip_post_check_so      libsvn_swig_py-1.so.* libsvn_swig_perl-1.so.*
128
129 %description
130 The goal of the Subversion project is to build a version control
131 system that is a compelling replacement for CVS in the open source
132 community.
133
134 Our goals are:
135 - All current CVS features.
136 - Directories, renames, and file meta-data are versioned.
137 - Symbolic links, etc, are supported
138 - Commits are truly atomic.
139 - Branching and tagging are cheap (constant time) operations
140 - Repeated merges are handled gracefully
141 - Support for plug-in client side diff programs
142 - Natively client/server
143 - Client/server protocol sends diffs in both directions
144 - Costs are proportional to change size, not project size
145 - Internationalization
146 - Progressive multi-lingual support
147
148 %description -l pl.UTF-8
149 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
150 zamiennika dla CVS.
151
152 Cele projektu to:
153 - Wszystkie aktualne możliwości CVS.
154 - Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
155 - Obsługa dowiązań symbolicznych itp.
156 - Commity są w pełni atomowe.
157 - Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
158 - Dobra obsługa powtarzanego łączenia (merge).
159 - Obsługa wtyczek diff po stronie klienta.
160 - Natywny klient/serwer.
161 - Klient/Serwer przesyłają diffy w obu kierunkach.
162 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
163 - Internacjonalizacja.
164 - Postępujące wsparcie dla wielu języków.
165
166 %description -l pt_BR.UTF-8
167 O objetivo do projeto Subversion é construir um sistema de controle de
168 versões que seja um substituto para o CVS (Concurrent Versioning
169 System) na comunidade opensource, fornecendo grandes melhorias.
170
171 %package libs
172 Summary:        Subversion libraries and modules
173 Summary(pl.UTF-8):      Biblioteka subversion oraz ładowalne moduły
174 Group:          Libraries
175 %{?with_neon:Requires:  neon >= 0.26.0}
176 Obsoletes:      libsubversion0
177
178 %description libs
179 Subversion libraries and modules.
180
181 %description libs -l pl.UTF-8
182 Biblioteka subversion oraz ładowalne moduły.
183
184 %package devel
185 Summary:        Header files and develpment documentation for subversion
186 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumetacja do subversion
187 Summary(pt_BR.UTF-8):   Arquivos de desenvolvimento para o Subversion
188 Group:          Development/Libraries
189 Requires:       %{name}-libs = %{version}-%{release}
190 Requires:       apr-util-devel >= 1:1.0.0
191 %{?with_neon:Requires:  neon-devel >= 0.26.0}
192 Obsoletes:      libsubversion0-devel
193
194 %description devel
195 Header files and develpment documentation for subversion.
196
197 %description devel -l pl.UTF-8
198 Pliki nagłówkowe i dokumetacja do subversion.
199
200 %description devel -l pt_BR.UTF-8
201 Este pacote provê os arquivos necessários para desenvolvedores
202 interagirem com o Subversion.
203
204 %package static
205 Summary:        Static subversion library
206 Summary(pl.UTF-8):      Biblioteka statyczna subversion
207 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
208 Group:          Development/Libraries
209 Requires:       %{name}-devel = %{version}
210 Obsoletes:      libsubversion0-static-devel
211
212 %description static
213 Static subversion library.
214
215 %description static -l pl.UTF-8
216 Biblioteka statyczna subversion.
217
218 %description static -l pt_BR.UTF-8
219 Este pacote provê um cliente estático do subversion.
220
221 %package svnserve
222 Summary:        Subversion svnserve
223 Summary(pl.UTF-8):      Subversion svnserve
224 Group:          Networking/Daemons
225 Requires(post,preun):   /sbin/chkconfig
226 Requires(postun):       /usr/sbin/groupdel
227 Requires(postun):       /usr/sbin/userdel
228 Requires(pre):  /bin/id
229 Requires(pre):  /usr/bin/getgid
230 Requires(pre):  /usr/lib/rpm/user_group.sh
231 Requires(pre):  /usr/sbin/groupadd
232 Requires(pre):  /usr/sbin/useradd
233 Requires(pre):  /usr/sbin/usermod
234 Requires:       %{name} = %{version}-%{release}
235 Requires:       rc-scripts
236 Provides:       group(svn)
237 Provides:       user(svn)
238
239 %description svnserve
240 Subversion svnserve server.
241
242 %description svnserve -l pl.UTF-8
243 Serwer subversion svnserve.
244
245 %package tools
246 Summary:        Subversion tools and scripts
247 Summary(pl.UTF-8):      Narzędzia oraz skrypty dla subversion
248 Summary(pt_BR.UTF-8):   Módulos python para acessar os recursos do Subversion
249 Group:          Applications
250 %pyrequires_eq  python
251 Requires:       %{name} = %{version}-%{release}
252 Requires:       python-subversion = %{version}
253
254 %description tools
255 Subversion tools and scripts.
256
257 %description tools -l pl.UTF-8
258 Narzędzia oraz skrypty dla subversion.
259
260 %package -n bash-completion-subversion
261 Summary:        bash completion for subversion
262 Summary(pl.UTF-8):      Dopełnienia basha dla subversion
263 Group:          Applications/Shells
264 Requires:       %{name} = %{version}-%{release}
265 Requires:       bash-completion
266 Conflicts:      %{name}-tools <= 1.1.0-0.rc6.1
267
268 %description -n bash-completion-subversion
269 Bash completion for subversion.
270
271 %description -n bash-completion-subversion -l pl.UTF-8
272 Dopełnienia basha dla subversion.
273
274 %package -n java-subversion
275 Summary:        Subversion Java bindings
276 Summary(pl.UTF-8):      Dowiązania do Subversion dla Javy
277 Group:          Development/Languages/Java
278 Requires:       %{name}-libs = %{version}-%{release}
279
280 %description -n java-subversion
281 This is a set of Java classes which provide the functionality of
282 subversion-libs, the Subversion libraries. It is useful if you want
283 to, for example, write a Java class that manipulates a Subversion
284 repository or working copy. See the 'subversion' package for more
285 information.
286
287 %description -n java-subversion -l pl.UTF-8
288 Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
289 subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
290 pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
291 roboczą. Więcej informacji w pakiecie subversion.
292
293 %package -n python-subversion
294 Summary:        Subversion Python bindings
295 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
296 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
297 Group:          Development/Languages/Python
298 %pyrequires_eq  python
299 Requires:       %{name}-libs = %{version}-%{release}
300 Obsoletes:      subversion-python
301
302 %description -n python-subversion
303 Subversion Python bindings.
304
305 %description -n python-subversion -l pl.UTF-8
306 Dowiązania do Subversion dla Pythona.
307
308 %description -n python-subversion -l pt_BR.UTF-8
309 Módulos Python para acessar os recursos do Subversion.
310
311 %package -n python-csvn
312 Summary:        CTypes Subversion Python bindings
313 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
314 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
315 Group:          Development/Languages/Python
316 %pyrequires_eq  python
317 Requires:       %{name}-libs = %{version}-%{release}
318
319 %description -n python-csvn
320 Subversion CTypes Python bindings.
321
322 %description -n python-csvn -l pl.UTF-8
323 Dowiązania do Subversion dla Pythona używające CTypes.
324
325 %description -n python-csvn -l pt_BR.UTF-8
326 Módulos Python para acessar os recursos do Subversion.
327
328 %package -n perl-subversion
329 Summary:        Subversion Perl bindings
330 Summary(pl.UTF-8):      Dowiązania do Subversion dla Perla
331 Summary(pt_BR.UTF-8):   Módulos Perl para acessar os recursos do Subversion
332 Group:          Development/Languages/Perl
333 Requires:       %{name}-libs = %{version}-%{release}
334 Obsoletes:      subversion-perl
335
336 %description -n perl-subversion
337 Subversion Perl bindings.
338
339 %description -n perl-subversion -l pl.UTF-8
340 Dowiązania do Subversion dla Perla.
341
342 %description -n perl-subversion -l pt_BR.UTF-8
343 Módulos Perl para acessar os recursos do Subversion.
344
345 %package -n ruby-subversion
346 Summary:        Subversion Ruby bindings
347 Summary(pl.UTF-8):      Dowiązania do Subversion dla języka Ruby
348 Summary(pt_BR.UTF-8):   Módulos Ruby para acessar os recursos do Subversion
349 Group:          Development/Languages
350 Requires:       %{name}-libs = %{version}-%{release}
351 Obsoletes:      subversion-ruby
352
353 %description -n ruby-subversion
354 Subversion Ruby bindings.
355
356 %description -n ruby-subversion -l pl.UTF-8
357 Dowiązania do Subversion dla języka Ruby.
358
359 %description -n ruby-subversion -l pt_BR.UTF-8
360 Módulos Ruby para acessar os recursos do Subversion.
361
362 %package -n apache-mod_dav_svn
363 Summary:        Apache module: Subversion Server
364 Summary(pl.UTF-8):      Moduł apache: Serwer Subversion
365 Group:          Networking/Daemons
366 Requires:       %{name} = %{version}-%{release}
367 Requires:       apache(modules-api) = %apache_modules_api
368 Requires:       apache-mod_dav
369
370 %description -n apache-mod_dav_svn
371 Apache module: Subversion Server.
372
373 %description -n apache-mod_dav_svn -l pl.UTF-8
374 Moduł apache: Serwer Subversion.
375
376 %package -n apache-mod_authz_svn
377 Summary:        Apache module: Subversion Server - path-based authorization
378 Summary(pl.UTF-8):      Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
379 Group:          Networking/Daemons
380 Requires:       apache(modules-api) = %apache_modules_api
381 Requires:       apache-mod_dav_svn = %{version}-%{release}
382
383 %description -n apache-mod_authz_svn
384 Apache module: Subversion Server - path-based authorization.
385
386 %description -n apache-mod_authz_svn -l pl.UTF-8
387 Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
388
389 %package -n gnome-keyring-subversion
390 Summary:        GNOME Keyring authentication provider for Subversion
391 Summary(pl.UTF-8):      Moduł uwierzytelniający GNOME Keyring dla Subversion
392 Group:          X11/Applications
393
394 %description -n gnome-keyring-subversion
395 Authentication provider module for Subversion which allows SVN client
396 to authenticate using GNOME Keyring.
397
398 %description -n gnome-keyring-subversion -l pl.UTF-8
399 Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
400 uwierzytelniać się przy użyciu mechanizmu GNOME Keyring.
401
402 %package -n kde4-kwallet-subversion
403 Summary:        KDE Wallet authentication provider for Subversion
404 Summary(pl.UTF-8):      Moduł uwierzytelniający dla Subversion wykorzystujący Portfel KDE
405 Group:          X11/Applications
406
407 %description -n kde4-kwallet-subversion
408 Authentication provider module for Subversion which allows SVN client
409 to authenticate using KDE Wallet.
410
411 %description -n kde4-kwallet-subversion -l pl.UTF-8
412 Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
413 uwierzytelniać się przy użyciu Portfela KDE.
414
415 %prep
416 %setup -q
417 %patch0 -p0
418 %patch1 -p1
419 %patch2 -p0
420 %patch3 -p1
421
422 sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
423
424 # serf.m4 macro is broken and ignores --without serf
425 %{?with_neon:sed -i -e 's#serf_found="yes"#serf_found="no"#g' build/ac-macros/serf.m4}
426
427 %build
428 # disabled regeneration - subversion 1.6.13 is not ready for swig 2.0.x
429 #%{__rm} subversion/bindings/swig/proxy/*.swg
430 #cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
431 chmod +x ./autogen.sh && ./autogen.sh
432 %{__libtoolize}
433 %configure \
434         --with-editor=vi \
435         --with-zlib=%{_libdir} \
436         --disable-runtime-module-search \
437         --disable-mod-activation \
438 %if %{with db}
439         --with-berkeley-db="db.h:%{_includedir}:%{_libdir}:db" \
440 %else
441         --without-berkeley-db \
442 %endif
443 %if %{with apache}
444         --with-apxs=%{_sbindir}/apxs \
445 %else
446         --without-apache \
447         --without-apxs \
448 %endif
449 %if %{without swig}
450         --without-swig \
451 %endif
452 %if %{without ruby}
453         ac_cv_path_RUBY=none \
454 %endif
455         %{?with_python:--with-ctypesgen=%{_bindir}/ctypesgen.py} \
456         --%{?with_javahl:en}%{!?with_javahl:dis}able-javahl \
457         --with-jdk="%{java_home}" \
458         --without-jikes \
459 %if %{with neon}
460         --without-serf \
461         --with-neon=%{_prefix} \
462         --disable-neon-version-check \
463 %else
464         --with-serf=%{_prefix} \
465         --without-neon \
466 %endif
467         --with-apr=%{_bindir}/apr-1-config \
468         --with-apr-util=%{_bindir}/apu-1-config \
469 %if %{with kwallet}
470         --with-kwallet \
471 %endif
472 %if %{with gnome}
473         --with-gnome-keyring
474 %endif
475
476 %{__make} -j1
477
478 # python
479 %if %{with python}
480 # ctypes bindings
481 %{__make} ctypes-python
482 # swig bindings
483 %{__make} swig-py \
484         swig_pydir=%{py_sitedir}/libsvn \
485         swig_pydir_extra=%{py_sitedir}/svn
486 %endif
487 # perl
488 %if %{with perl}
489 %{__make} -j1 swig-pl-lib
490 odir=$(pwd)
491 cd subversion/bindings/swig/perl/native
492 %{__perl} Makefile.PL INSTALLDIRS=vendor
493 %{__make} -j1
494 cd $odir
495 %endif
496 %if %{with javahl}
497 %{__make} -j1 javahl \
498         javahl_javadir="%{_javadir}"
499 %endif
500 # ruby
501 %if %{with ruby}
502 %{__make} swig-rb
503 %endif
504
505 %if %{with tests}
506 %{__make} check
507 %if %{with python}
508 %{__make} check-ctypes-python
509 %{__make} check-swig-py
510 %endif
511 %if %{with perl}
512 %{__make} check-swig-pl
513 %endif
514 %if %{with ruby}
515 # disabled, see https://bugs.launchpad.net/pld-linux/+bug/734340
516 #%{__make} check-swig-rb
517 %endif
518 %endif
519
520 %install
521 rm -rf $RPM_BUILD_ROOT
522 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
523         $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
524         $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
525         $RPM_BUILD_ROOT%{_sysconfdir}/%{name} \
526         $RPM_BUILD_ROOT/home/services/subversion{,/repos}
527
528 %{__make} install -j1 \
529 %if %{with javahl}
530         install-javahl \
531         javahl_javadir="%{_javadir}" \
532 %endif
533 %if %{with python}
534         install-swig-py \
535         install-ctypes-python \
536 %endif
537 %if %{with ruby}
538         install-swig-rb install-swig-rb-doc \
539 %endif
540         APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
541         DESTDIR=$RPM_BUILD_ROOT \
542         swig_pydir=%{py_sitedir}/libsvn \
543         swig_pydir_extra=%{py_sitedir}/svn
544
545 %if %{with perl}
546 %{__make} install-swig-pl-lib \
547         DESTDIR=$RPM_BUILD_ROOT
548 %{__make} -C subversion/bindings/swig/perl/native install \
549         DESTDIR=$RPM_BUILD_ROOT \
550         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
551         LIBDIR=$RPM_BUILD_ROOT%{_libdir}
552 %endif
553
554 %if %{with apache}
555 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
556 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
557 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
558 install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
559 %endif
560
561 %if %{without net_client_only}
562 install -p tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
563 %endif
564 %if %{with python}
565 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
566 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
567 %py_postclean
568 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/libsvn/*.la
569 install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
570 %endif
571
572 cp -p tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
573 cp -p tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
574
575 %{?with_javahl:%{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvnjavahl*.{la,a}}
576 %if %{with swig}
577 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvn_swig*.{la,a}
578 %if %{with ruby}
579 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/*/*/svn/ext/*.la
580 %endif
581 %endif
582 %if %{with gnome} || %{with kwallet}
583 # dlopened by soname (libsvn_auth_*-1.so.0)
584 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvn_auth_*-1.{so,la,a}
585 %endif
586
587 %find_lang %{name}
588
589 %clean
590 rm -rf $RPM_BUILD_ROOT
591
592 %pre svnserve
593 %groupadd -g 86 svn
594 %useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
595
596 %post   libs -p /sbin/ldconfig
597 %postun libs -p /sbin/ldconfig
598
599 %post   devel -p /sbin/postshell
600 -/usr/sbin/fix-info-dir -c %{_infodir}
601
602 %postun devel -p /sbin/postshell
603 -/usr/sbin/fix-info-dir -c %{_infodir}
604
605 %post   -n java-subversion -p /sbin/ldconfig
606 %postun -n java-subversion -p /sbin/ldconfig
607
608 %post   -n perl-subversion -p /sbin/ldconfig
609 %postun -n perl-subversion -p /sbin/ldconfig
610
611 %post   -n python-subversion -p /sbin/ldconfig
612 %postun -n python-subversion -p /sbin/ldconfig
613
614 %post   -n ruby-subversion -p /sbin/ldconfig
615 %postun -n ruby-subversion -p /sbin/ldconfig
616
617 %post   -n gnome-keyring-subversion -p /sbin/ldconfig
618 %postun -n gnome-keyring-subversion -p /sbin/ldconfig
619
620 %post   -n kde4-kwallet-subversion -p /sbin/ldconfig
621 %postun -n kde4-kwallet-subversion -p /sbin/ldconfig
622
623 %post svnserve
624 /sbin/chkconfig --add svnserve
625 %service svnserve restart "svnserve daemon"
626
627 %preun svnserve
628 if [ "$1" = "0" ]; then
629         %service svnserve stop
630         /sbin/chkconfig --del svnserve
631 fi
632
633 %postun svnserve
634 if [ "$1" = "0" ]; then
635         %userremove svn
636         %groupremove svn
637 fi
638
639 %post -n apache-mod_dav_svn
640 %service -q httpd restart
641
642 %postun -n apache-mod_dav_svn
643 if [ "$1" = "0" ]; then
644         %service -q httpd restart
645 fi
646
647 %post -n apache-mod_authz_svn
648 %service -q httpd restart
649
650 %postun -n apache-mod_authz_svn
651 if [ "$1" = "0" ]; then
652         %service -q httpd restart
653 fi
654
655 %files
656 %defattr(644,root,root,755)
657 %doc BUGS CHANGES COPYING INSTALL README
658 %doc doc/*/*.html
659 %doc tools/hook-scripts/*.{pl,py,example}
660 %doc tools/hook-scripts/mailer/*.{py,example}
661 %doc tools/xslt/*
662 %attr(755,root,root) %{_bindir}/svn
663 %attr(755,root,root) %{_bindir}/svnadmin
664 %attr(755,root,root) %{_bindir}/svndumpfilter
665 %attr(755,root,root) %{_bindir}/svnlook
666 %attr(755,root,root) %{_bindir}/svnsync
667 %attr(755,root,root) %{_bindir}/svnversion
668 %{_mandir}/man1/svn.1*
669 %{_mandir}/man1/svnadmin.1*
670 %{_mandir}/man1/svndumpfilter.1*
671 %{_mandir}/man1/svnlook.1*
672 %{_mandir}/man1/svnsync.1*
673 %{_mandir}/man1/svnversion.1*
674
675 %files libs -f %{name}.lang
676 %defattr(644,root,root,755)
677 %dir %{_sysconfdir}/%{name}
678 %attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
679 %attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
680 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
681 %attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
682 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
683 %attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
684 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
685 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
686 %if %{without net_client_only}
687 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
688 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
689 %endif
690 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
691 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
692 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
693 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
694 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
695 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
696 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
697 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
698 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so.*.*.*
699 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_%{webdavlib}-1.so.0
700 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
701 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
702 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
703 %attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
704 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
705 %attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
706 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
707 %attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
708
709 %files devel
710 %defattr(644,root,root,755)
711 %attr(755,root,root) %{_libdir}/libsvn_client-1.so
712 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so
713 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so
714 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so
715 %if %{without net_client_only}
716 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
717 %endif
718 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
719 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
720 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so
721 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
722 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so
723 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
724 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so
725 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so
726 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so
727 %{_libdir}/libsvn_client-1.la
728 %{_libdir}/libsvn_delta-1.la
729 %{_libdir}/libsvn_diff-1.la
730 %{_libdir}/libsvn_fs-1.la
731 %if %{without net_client_only}
732 %{_libdir}/libsvn_fs_base-1.la
733 %endif
734 %{_libdir}/libsvn_fs_fs-1.la
735 %{_libdir}/libsvn_fs_util-1.la
736 %{_libdir}/libsvn_ra-1.la
737 %{_libdir}/libsvn_ra_local-1.la
738 %{_libdir}/libsvn_ra_%{webdavlib}-1.la
739 %{_libdir}/libsvn_ra_svn-1.la
740 %{_libdir}/libsvn_repos-1.la
741 %{_libdir}/libsvn_subr-1.la
742 %{_libdir}/libsvn_wc-1.la
743 %{_includedir}/%{name}-1
744 %{_examplesdir}/%{name}-%{version}
745
746 %files static
747 %defattr(644,root,root,755)
748 %{_libdir}/libsvn_client-1.a
749 %{_libdir}/libsvn_delta-1.a
750 %{_libdir}/libsvn_diff-1.a
751 %{_libdir}/libsvn_fs-1.a
752 %if %{without net_client_only}
753 %{_libdir}/libsvn_fs_base-1.a
754 %endif
755 %{_libdir}/libsvn_fs_fs-1.a
756 %{_libdir}/libsvn_fs_util-1.a
757 %{_libdir}/libsvn_ra-1.a
758 %{_libdir}/libsvn_ra_local-1.a
759 %{_libdir}/libsvn_ra_%{webdavlib}-1.a
760 %{_libdir}/libsvn_ra_svn-1.a
761 %{_libdir}/libsvn_repos-1.a
762 %{_libdir}/libsvn_subr-1.a
763 %{_libdir}/libsvn_wc-1.a
764
765 %if %{with gnome}
766 %files -n gnome-keyring-subversion
767 %defattr(644,root,root,755)
768 %attr(755,root,root) %{_libdir}/libsvn_auth_gnome_keyring-1.so.*.*.*
769 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_gnome_keyring-1.so.0
770 %endif
771
772 %if %{with kwallet}
773 %files -n kde4-kwallet-subversion
774 %defattr(644,root,root,755)
775 %attr(755,root,root) %{_libdir}/libsvn_auth_kwallet-1.so.*.*.*
776 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
777 %endif
778
779 %if %{without net_client_only}
780 %files svnserve
781 %defattr(644,root,root,755)
782 %attr(755,root,root) %{_bindir}/svnserve
783 %{_mandir}/man5/svnserve.conf.5*
784 %{_mandir}/man8/svnserve.8*
785 %dir %attr(750,svn,svn) /home/services/subversion
786 %dir %attr(750,svn,svn) /home/services/subversion/repos
787 %if %{with apache}
788 %attr(754,root,root) /etc/rc.d/init.d/svnserve
789 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
790 %endif
791
792 %files tools
793 %defattr(644,root,root,755)
794 %attr(755,root,root) %{_bindir}/svn-hot-backup
795
796 %files -n bash-completion-subversion
797 %defattr(644,root,root,755)
798 /etc/bash_completion.d/%{name}
799
800 %if %{with javahl}
801 %files -n java-subversion
802 %defattr(644,root,root,755)
803 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
804 %attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
805 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
806 %{_javadir}/svn-javahl.jar
807 %endif
808
809 %if %{with python}
810 %files -n python-subversion
811 %defattr(644,root,root,755)
812 %doc tools/backup/*.py tools/examples/*.py
813 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
814 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
815 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
816 %dir %{py_sitedir}/libsvn
817 %attr(755,root,root) %{py_sitedir}/libsvn/_*.so
818 %{py_sitedir}/libsvn/*.py[co]
819 %dir %{py_sitedir}/svn
820 %{py_sitedir}/svn/*.py[co]
821 %{_examplesdir}/python-%{name}-%{version}
822
823 %files -n python-csvn
824 %defattr(644,root,root,755)
825 %doc subversion/bindings/ctypes-python/{README,TODO}
826 %doc subversion/bindings/ctypes-python/examples/*.py
827 %dir %{py_sitescriptdir}/csvn
828 %{py_sitescriptdir}/csvn/*.py[co]
829 %dir %{py_sitescriptdir}/csvn/core
830 %{py_sitescriptdir}/csvn/core/*.py[co]
831 %dir %{py_sitescriptdir}/csvn/ext
832 %{py_sitescriptdir}/csvn/ext/*.py[co]
833 %{py_sitescriptdir}/svn_ctypes_python_bindings-0.1-py*.egg-info
834 %endif
835
836 %if %{with perl}
837 %files -n perl-subversion
838 %defattr(644,root,root,755)
839 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
840 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
841 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
842 %{perl_vendorarch}/SVN
843 %dir %{perl_vendorarch}/auto/SVN
844 %dir %{perl_vendorarch}/auto/SVN/*
845 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
846 %{perl_vendorarch}/auto/SVN/*/*.bs
847 %{_mandir}/man3/*.3pm*
848 %endif
849
850 %if %{with ruby}
851 %files -n ruby-subversion
852 %defattr(644,root,root,755)
853 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
854 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
855 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
856 %dir %{ruby_sitelibdir}/svn
857 %{ruby_sitelibdir}/svn/*.rb
858 %dir %{ruby_sitearchdir}/svn
859 %dir %{ruby_sitearchdir}/svn/ext
860 %attr(755,root,root) %{ruby_sitearchdir}/svn/ext/*.so
861 %{ruby_ridir}/Svn
862 %endif
863
864 %if %{with apache}
865 %files -n apache-mod_dav_svn
866 %defattr(644,root,root,755)
867 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
868 %attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
869
870 %files -n apache-mod_authz_svn
871 %defattr(644,root,root,755)
872 %doc subversion/mod_authz_svn/INSTALL
873 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
874 %attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
875 %endif
876
877 %endif # net_client_only
This page took 0.104283 seconds and 3 git commands to generate.