]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
- update
[packages/subversion.git] / subversion.spec
1 # TODO:
2 # - remove net_client_only and add db bcond (then without apache and
3 #   without db => net_client_only - spec will be more simpler, I think)
4 #
5 # Conditional build:
6 %bcond_with     net_client_only                 # build only net client
7 %bcond_without  python                          # build without python bindings
8 %bcond_without  perl                            # build without perl bindings
9 %bcond_without  apache                          # build without apache support (webdav, etc)
10 #
11 %{!?with_net_client_only:%include       /usr/lib/rpm/macros.perl}
12 %define apxs    /usr/sbin/apxs
13 %define pdir    SVN
14 %define pnam    _Core
15 Summary:        A Concurrent Versioning system similar to but better than CVS
16 Summary(pl.UTF-8):      System kontroli wersji podobny, ale lepszy, niż CVS
17 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
18 Name:           subversion
19 Version:        1.4.4
20 Release:        4
21 License:        Apache/BSD Style
22 Group:          Development/Version Control
23 Source0:        http://subversion.tigris.org/downloads/%{name}-%{version}.tar.gz
24 # Source0-md5:  702655defa418bab8f683f6268b4fd30
25 Source1:        %{name}-dav_svn.conf
26 Source2:        %{name}-authz_svn.conf
27 Source3:        %{name}-svnserve.init
28 Source4:        %{name}-svnserve.sysconfig
29 Source5:        %{name}-convert-typemaps-to-ifdef.py
30 Patch0:         %{name}-home_etc.patch
31 Patch1:         %{name}-DESTDIR.patch
32 Patch2:         %{name}-neon.patch
33 Patch3:         %{name}-python_bindings.patch
34 URL:            http://subversion.tigris.org/
35 %if %{with net_client_only}
36 %global apache_modules_api 0
37 %else
38 %{?with_apache:BuildRequires:   apache-devel >= 2.2.0-8}
39 BuildRequires:  automake
40 BuildRequires:  db-devel >= 4.1.25
41 BuildRequires:  rpmbuild(macros) >= 1.268
42 %if %{with perl}
43 BuildRequires:  perl-devel >= 1:5.8.0
44 BuildRequires:  rpm-perlprov >= 4.1-13
45 BuildRequires:  swig-perl >= 1.3.24
46 %endif
47 %endif
48 BuildRequires:  apr-devel >= 1:1.0.0
49 BuildRequires:  apr-util-devel >= 1:1.2.8-3
50 BuildRequires:  autoconf >= 2.59
51 BuildRequires:  bison
52 BuildRequires:  expat-devel
53 BuildRequires:  gettext-devel
54 BuildRequires:  libtool >= 1.4-9
55 BuildRequires:  neon-devel >= 0.26.0
56 BuildRequires:  python >= 2.2
57 BuildRequires:  python-modules >= 2.2
58 %if %{with python}
59 BuildRequires:  python-devel >= 2.2
60 BuildRequires:  sed >= 4.0
61 BuildRequires:  swig-python >= 1.3.24
62 %endif
63 BuildRequires:  texinfo
64 BuildRequires:  which
65 # update -neon patch before messing with this BC
66 BuildConflicts: neon-devel > 0.26.3
67 Requires:       %{name}-libs = %{version}-%{release}
68 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
69
70 %define         _apachelibdir   %(%{apxs} -q LIBEXECDIR 2>/dev/null)
71 %define         _libexecdir             %{_libdir}/svn
72
73 %description
74 The goal of the Subversion project is to build a version control
75 system that is a compelling replacement for CVS in the open source
76 community.
77
78 Our goals are:
79 - All current CVS features.
80 - Directories, renames, and file meta-data are versioned.
81 - Symbolic links, etc, are supported
82 - Commits are truly atomic.
83 - Branching and tagging are cheap (constant time) operations
84 - Repeated merges are handled gracefully
85 - Support for plug-in client side diff programs
86 - Natively client/server
87 - Client/server protocol sends diffs in both directions
88 - Costs are proportional to change size, not project size
89 - Internationalization
90 - Progressive multi-lingual support
91
92 %description -l pl.UTF-8
93 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
94 zamiennika dla CVS.
95
96 Cele projektu to:
97 - Wszystkie aktualne możliwości CVS.
98 - Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
99 - Obsługa dowiązań symbolicznych itp.
100 - Commity są w pełni atomowe.
101 - Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
102 - Dobra obsługa powtarzanego łączenia (merge).
103 - Obsługa wtyczek diff po stronie klienta.
104 - Natywny klient/serwer.
105 - Klient/Serwer przesyłają diffy w obu kierunkach.
106 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
107 - Internacjonalizacja.
108 - Postępujące wsparcie dla wielu języków.
109
110 %description -l pt_BR.UTF-8
111 O objetivo do projeto Subversion é construir um sistema de controle de
112 versões que seja um substituto para o CVS (Concurrent Versioning
113 System) na comunidade opensource, fornecendo grandes melhorias.
114
115 %package libs
116 Summary:        Subversion libraries and modules
117 Summary(pl.UTF-8):      Biblioteka subversion oraz ładowalne moduły
118 Group:          Libraries
119 Requires:       neon >= 0.26.0
120 Obsoletes:      libsubversion0
121
122 %description libs
123 Subversion libraries and modules.
124
125 %description libs -l pl.UTF-8
126 Biblioteka subversion oraz ładowalne moduły.
127
128 %package devel
129 Summary:        Header files and develpment documentation for subversion
130 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumetacja do subversion
131 Summary(pt_BR.UTF-8):   Arquivos de desenvolvimento para o Subversion
132 Group:          Development/Libraries
133 Requires:       %{name}-libs = %{version}-%{release}
134 Requires:       apr-util-devel >= 1:1.0.0
135 Requires:       neon-devel >= 0.26.0
136 Obsoletes:      libsubversion0-devel
137
138 %description devel
139 Header files and develpment documentation for subversion.
140
141 %description devel -l pl.UTF-8
142 Pliki nagłówkowe i dokumetacja do subversion.
143
144 %description devel -l pt_BR.UTF-8
145 Este pacote provê os arquivos necessários para desenvolvedores
146 interagirem com o Subversion.
147
148 %package static
149 Summary:        Static subversion library
150 Summary(pl.UTF-8):      Biblioteka statyczna subversion
151 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
152 Group:          Development/Libraries
153 Requires:       %{name}-devel = %{version}
154 Obsoletes:      libsubversion0-static-devel
155
156 %description static
157 Static subversion library.
158
159 %description static -l pl.UTF-8
160 Biblioteka statyczna subversion.
161
162 %description static -l pt_BR.UTF-8
163 Este pacote provê um cliente estático do subversion.
164
165 %package svnserve
166 Summary:        Subversion svnserve
167 Summary(pl.UTF-8):      Subversion svnserve
168 Group:          Networking/Daemons
169 Requires(post,preun):   /sbin/chkconfig
170 Requires:       %{name} = %{version}-%{release}
171 Requires:       rc-scripts
172
173 %description svnserve
174 Subversion svnserve server.
175
176 %description svnserve -l pl.UTF-8
177 Serwer subversion svnserve.
178
179 %package tools
180 Summary:        Subversion tools and scripts
181 Summary(pl.UTF-8):      Narzędzia oraz skrypty dla subversion
182 Summary(pt_BR.UTF-8):   Módulos python para acessar os recursos do Subversion
183 Group:          Applications
184 %pyrequires_eq  python
185 Requires:       %{name} = %{version}-%{release}
186 Requires:       python-rcsparse >= 0.1-0.20031026.0
187 Requires:       python-subversion = %{version}
188
189 %description tools
190 Subversion tools and scripts.
191
192 %description tools -l pl.UTF-8
193 Narzędzia oraz skrypty dla subversion.
194
195 %package -n bash-completion-subversion
196 Summary:        bash completion for subversion
197 Summary(pl.UTF-8):      Dopełnienia basha dla subversion
198 Group:          Applications/Shells
199 Requires:       %{name} = %{version}-%{release}
200 Requires:       bash-completion
201 Conflicts:      %{name}-tools <= 1.1.0-0.rc6.1
202
203 %description -n bash-completion-subversion
204 Bash completion for subversion.
205
206 %description -n bash-completion-subversion -l pl.UTF-8
207 Dopełnienia basha dla subversion.
208
209 %package -n python-subversion
210 Summary:        Subversion python bindings
211 Summary(pl.UTF-8):      Dowiązania do subversion dla pythona
212 Summary(pt_BR.UTF-8):   Módulos python para acessar os recursos do Subversion
213 Group:          Development/Languages/Python
214 %pyrequires_eq  python
215 Requires:       %{name}-libs = %{version}-%{release}
216 Obsoletes:      subversion-python
217
218 %description -n python-subversion
219 Subversion python bindings.
220
221 %description -n python-subversion -l pl.UTF-8
222 Dowiązania do subversion dla pythona.
223
224 %description -n python-subversion -l pt_BR.UTF-8
225 Módulos python para acessar os recursos do Subversion.
226
227 %package -n perl-subversion
228 Summary:        Subversion perl bindings
229 Summary(pl.UTF-8):      Dowiązania do subversion dla perla
230 Summary(pt_BR.UTF-8):   Módulos perl para acessar os recursos do Subversion
231 Group:          Development/Languages/Perl
232 Requires:       %{name}-libs = %{version}-%{release}
233 Obsoletes:      subversion-perl
234
235 %description -n perl-subversion
236 Subversion perl bindings.
237
238 %description -n perl-subversion -l pl.UTF-8
239 Dowiązania do subversion dla perl.
240
241 %description -n perl-subversion -l pt_BR.UTF-8
242 Módulos perl para acessar os recursos do Subversion.
243
244 %package -n apache-mod_dav_svn
245 Summary:        Apache module: Subversion Server
246 Summary(pl.UTF-8):      Moduł apache: Serwer Subversion
247 Group:          Networking/Daemons
248 Requires:       %{name} = %{version}-%{release}
249 Requires:       apache(modules-api) = %apache_modules_api
250 Requires:       apache-mod_dav
251
252 %description -n apache-mod_dav_svn
253 Apache module: Subversion Server.
254
255 %description -n apache-mod_dav_svn -l pl.UTF-8
256 Moduł apache: Serwer Subversion.
257
258 %package -n apache-mod_authz_svn
259 Summary:        Apache module: Subversion Server - path-based authorization
260 Summary(pl.UTF-8):      Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
261 Group:          Networking/Daemons
262 Requires:       apache(modules-api) = %apache_modules_api
263 Requires:       apache-mod_dav_svn = %{version}-%{release}
264
265 %description -n apache-mod_authz_svn
266 Apache module: Subversion Server - path-based authorization.
267
268 %description -n apache-mod_authz_svn -l pl.UTF-8
269 Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
270
271 %prep
272 %setup -q
273 rm -rf apr apr-util neon
274 %patch0 -p0
275 %patch1 -p1
276 %patch2 -p1
277 %patch3 -p1
278
279 %build
280 rm subversion/bindings/swig/proxy/*.swg 
281 cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
282 cp -f /usr/share/automake/config.sub ac-helpers
283 chmod +x ./autogen.sh && ./autogen.sh
284
285 # don't enable dso - currently it's broken
286 %configure \
287         --with-editor=vi \
288         --with-zlib \
289         --with-python=%{_bindir}/python \
290         --with-perl5=%{_bindir}/perl \
291 %if %{with net_client_only}
292         --without-apache \
293         --without-swig \
294         --without-apxs \
295         --without-berkeley-db \
296 %else
297         --disable-dso \
298         --disable-mod-activation \
299 %if %{with apache}
300         --with-apxs=%{_sbindir}/apxs \
301 %else
302         --without-apache \
303         --without-apxs \
304         --with-berkeley-db=%{_includedir}/db4:%{_libdir} \
305 %endif
306 %if !%{with python} && !%{with perl}
307         --without-swig \
308 %endif
309 %endif
310         --with-neon=%{_prefix} \
311         --disable-neon-version-check \
312         --with-apr=%{_bindir}/apr-1-config \
313         --with-apr-util=%{_bindir}/apu-1-config
314
315 %{__make} -j1
316
317 %if !%{with net_client_only}
318 # python
319 %if %{with python}
320 %{__make} swig-py \
321         swig_pydir=%{py_sitedir}/libsvn \
322         swig_pydir_extra=%{py_sitedir}/svn
323 %endif
324 # perl
325 %if %{with perl}
326 %{__make} swig-pl-lib
327 odir=$(pwd)
328 cd subversion/bindings/swig/perl/native
329 %{__perl} Makefile.PL INSTALLDIRS=vendor
330 %{__make}
331 cd $odir
332 %endif
333 %endif
334
335 %install
336 rm -rf $RPM_BUILD_ROOT
337 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
338         $RPM_BUILD_ROOT{%{_sysconfdir}/httpd/httpd.conf,%{_apachelibdir},%{_infodir}} \
339         $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
340         $RPM_BUILD_ROOT/home/services/subversion{,/repos}
341
342 %{__make} install -j1 \
343 %if !%{with net_client_only} && %{with python}
344         install-swig-py \
345 %endif
346         APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
347         DESTDIR=$RPM_BUILD_ROOT \
348         swig_pydir=%{py_sitedir}/libsvn \
349         swig_pydir_extra=%{py_sitedir}/svn
350
351 %if !%{with net_client_only} && %{with perl}
352 %{__make} install-swig-pl-lib \
353         DESTDIR=$RPM_BUILD_ROOT
354 odir=$(pwd)
355 cd subversion/bindings/swig/perl/native
356 %{__make} install \
357         DESTDIR=$RPM_BUILD_ROOT \
358         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
359         LIBDIR=$RPM_BUILD_ROOT%{_libdir}
360 cd $odir
361 %endif
362
363 %if %{with apache}
364 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/65_mod_dav_svn.conf
365 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/66_mod_authz_svn.conf
366 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
367 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
368 %endif
369
370 %if !%{with net_client_only}
371 install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
372 %if %{with python}
373 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
374 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
375 find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
376 install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
377 %endif
378 %endif
379
380 install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
381 install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
382
383 %find_lang %{name}
384
385 rm -f $RPM_BUILD_ROOT%{_libdir}/lib*swig*.la
386
387 %clean
388 rm -rf $RPM_BUILD_ROOT
389
390 %post devel
391 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
392
393 %postun devel
394 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
395
396 %post   libs -p /sbin/ldconfig
397 %postun libs -p /sbin/ldconfig
398 %post   -n python-subversion -p /sbin/ldconfig
399 %postun -n perl-subversion -p /sbin/ldconfig
400
401 %post svnserve
402 /sbin/chkconfig --add svnserve
403 %service svnserve restart "svnserve daemon"
404
405 %preun svnserve
406 if [ "$1" = "0" ]; then
407         %service svnserve stop
408         /sbin/chkconfig --del svnserve
409 fi
410
411 %post -n apache-mod_dav_svn
412 %service -q httpd restart
413
414 %preun -n apache-mod_dav_svn
415 if [ "$1" = "0" ]; then
416         %service -q httpd restart
417 fi
418
419 %files
420 %defattr(644,root,root,755)
421 %doc BUGS CHANGES COPYING INSTALL README
422 %doc doc/*/*.html
423 %doc tools/hook-scripts/*.{pl,py,example}
424 %doc tools/hook-scripts/mailer/*.{py,example}
425 %doc tools/xslt/*
426 %attr(755,root,root) %{_bindir}/svn*
427 %exclude %{_bindir}/svnserve
428 %if !%{with net_client_only}
429 %exclude %{_bindir}/svn-hot-backup
430 %endif
431 %{_mandir}/man1/*
432 %{_mandir}/man5/*
433 %{_mandir}/man8/*
434 %exclude %{_mandir}/man?/svnserve*
435
436 %files libs -f %{name}.lang
437 %defattr(644,root,root,755)
438 %attr(755,root,root) %{_libdir}/lib*.so.*
439 %if %{with perl} || %{with python}
440 %exclude %{_libdir}/lib*_swig_*.so.*
441 %endif
442
443 %files devel
444 %defattr(644,root,root,755)
445 %{_includedir}/%{name}*
446 %attr(755,root,root) %{_libdir}/lib*.so
447 %{_libdir}/lib*.la
448 %if %{with perl} || %{with python}
449 %exclude %{_libdir}/lib*_swig_*.so
450 %endif
451 %{_examplesdir}/%{name}-%{version}
452
453 %files static
454 %defattr(644,root,root,755)
455 %{_libdir}/lib*.a
456
457 %if !%{with net_client_only}
458 %files svnserve
459 %defattr(644,root,root,755)
460 %attr(755,root,root) %{_bindir}/svnserve
461 %{_mandir}/man?/svnserve*
462 %dir /home/services/subversion
463 %dir /home/services/subversion/repos
464 %if %{with apache}
465 %attr(754,root,root) /etc/rc.d/init.d/svnserve
466 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
467 %endif
468
469 %files tools
470 %defattr(644,root,root,755)
471 %attr(755,root,root) %{_bindir}/svn-hot-backup
472
473 %files -n bash-completion-subversion
474 %defattr(644,root,root,755)
475 /etc/bash_completion.d/%{name}
476
477 %if %{with python}
478 %files -n python-subversion
479 %defattr(644,root,root,755)
480 %doc tools/backup/*.py tools/examples/*.py
481 %dir %{py_sitedir}/svn
482 %dir %{py_sitedir}/libsvn
483 %{py_sitedir}/svn/*.py[co]
484 %{py_sitedir}/libsvn/*.py[co]
485 %attr(755,root,root) %{py_sitedir}/libsvn/*.so
486 %{_examplesdir}/python-%{name}-%{version}
487 %attr(755,root,root) %{_libdir}/lib*_swig_py*.so*
488 %endif
489
490 %if %{with perl}
491 %files -n perl-subversion
492 %defattr(644,root,root,755)
493 %{perl_vendorarch}/SVN
494 %dir %{perl_vendorarch}/auto/SVN
495 %dir %{perl_vendorarch}/auto/SVN/*
496 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
497 %{perl_vendorarch}/auto/SVN/*/*.bs
498 %{_mandir}/man3/*.3pm*
499 %attr(755,root,root) %{_libdir}/lib*_swig_perl*.so*
500 %endif
501
502 %if %{with apache}
503 %files -n apache-mod_dav_svn
504 %defattr(644,root,root,755)
505 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd/httpd.conf/*_mod_dav_svn.conf
506 %attr(755,root,root) %{_apachelibdir}/mod_dav_svn.so
507
508 %files -n apache-mod_authz_svn
509 %defattr(644,root,root,755)
510 %doc subversion/mod_authz_svn/INSTALL
511 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd/httpd.conf/*_mod_authz_svn.conf
512 %attr(755,root,root) %{_apachelibdir}/mod_authz_svn.so
513 %endif
514
515 %endif # net_client_only
This page took 0.057315 seconds and 3 git commands to generate.