]> git.pld-linux.org Git - packages/star.git/blob - star.spec
- release .3
[packages/star.git] / star.spec
1 #
2 # Conditional build:
3 %bcond_without  selinux # disable SELinux support
4 #
5 Summary:        A very fast, POSIX compliant tape archiver
6 Summary(pl):    Szybki, zgodny z POSIX program do archiwizacji
7 Name:           star
8 Version:        1.5
9 %define bver    a58
10 Release:        0.%{bver}.3
11 License:        CDDL v1.0
12 Group:          Applications/File
13 Source0:        ftp://ftp.berlios.de/pub/star/alpha/%{name}-%{version}%{bver}.tar.bz2
14 # Source0-md5:  b3c367f0cda2a41dd055edff674e104c
15 # based on http://www.nsa.gov/selinux/patches/star-selinux.patch.gz
16 Patch0:         %{name}-selinux.patch
17 Patch1:         %{name}-no-kernel-headers.patch
18 Patch2:         %{name}-strtod.patch
19 Patch3:         %{name}-unamep.patch
20 Patch4:         %{name}-gcc34.patch
21 URL:            http://www.fokus.gmd.de/research/cc/glone/employees/joerg.schilling/private/star.html
22 BuildRequires:  acl-devel
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 %{?with_selinux:BuildRequires:  libselinux-devel}
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Star is a very fast, POSIX-compliant tar archiver. It reads and writes
30 POSIX compliant tar archives as well as non-POSIX GNU tar archives.
31 Star is the first free POSIX.1-200x compliant tar implementation. It
32 saves many files together into a single tape or disk archive, and can
33 restore individual files from the archive.
34
35 It includes a FIFO for speed, a pattern matcher, multivolume support,
36 the ability to archive sparse files, automatic archive format
37 detection, automatic byte order recognition, automatic archive
38 compression / decompression, remote archives, and special features
39 that allow star to be used for full backups. This package contains the
40 getfacl and setfacl utilities needed for manipulating access control
41 lists.
42
43 It includes the only known platform independant "rmt" server program
44 that hides Linux incompatibilities. The "rmt" server from the star
45 package implements all Sun/GNU/Schily/BSD enhancements and allows any
46 "rmt" client from any OS to contact any OS as server.
47
48 %description -l pl
49 Star jest szybkim, zgodnym z POSIX archiwizerem tar. Potrafi czytaæ i
50 zapisywaæ archiwa tar zgodne z POSIX, a tak¿e nie-posiksowe archiwa
51 GNU. Star jest pierwsz± wolnodostêpn± implementacj± tara zgodn± z
52 norm± POSIX.1-200x. Zapisuje ³±cznie wiele plików na jednej ta¶mie lub
53 dysku i mo¿e odtwarzaæ z archiwum pojedyncze pliki.
54
55 Ma kolejkê FIFO (dla przyspieszenia operacji), dopasowywanie wzorców,
56 obs³ugê archiwów wieloczê¶ciowych, mo¿liwo¶æ archiwizacji plików
57 rzadkich, automatyczne wykrywanie formatu archiwów i kolejno¶ci bajtów
58 w s³owie, automatyczn± kompresjê i dekompresjê, obs³ugê zdalnych
59 archiwów oraz dodatkowe mo¿liwo¶ci umo¿liwiaj±ce wykonywanie pe³nych
60 kopii zapasowych. Ten pakiet zawiera narzêdzia getfacl i setfacl
61 potrzebne do modyfikacji list kontroli dostêpu (ACL).
62
63 Pakiet zawiera te¿ niezale¿ny od platformy serwer rmt, który ma
64 zaimplementowane wszystkie rozszerzenia Sun/GNU/Schily/BSD i pozwala
65 na dostêp klientem rmt z dowolnego systemu operacyjnego.
66
67 %prep
68 %setup -q
69 %{?with_selinux:%patch0 -p1}
70 %patch1 -p1
71 %patch2 -p1
72 %patch3 -p1
73 %patch4 -p1
74
75 # new ac doesn't like comments in the same line as #undef
76 %{__perl} -pi -e 's@/\*.*\*/@@g' conf/xconfig.h.in
77 # kill annoying beep and sleep
78 %{__perl} -pi -e 's/^__gmake_warn.*//' RULES/mk-gmake.id
79
80 %build
81 cd conf
82 cp -f /usr/share/automake/config.* .
83 %{__autoconf}
84 cd ..
85 %{__make} \
86         COPTOPT="%{rpmcflags}" \
87         CC="%{__cc}" \
88         LDCC="%{__cc}"
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92
93 %{__make} install \
94         INS_BASE=$RPM_BUILD_ROOT%{_prefix} \
95         MANDIR=/share/man
96
97 echo '.so star.1' > $RPM_BUILD_ROOT%{_mandir}/man1/ustar.1
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %files
103 %defattr(644,root,root,755)
104 %doc AN-%{version}%{bver} CDDL.* Changelog README README.{ACL,largefiles,linux,otherbugs,pax,posix-2001} STARvsGNUTAR STATUS.alpha TODO
105 %attr(755,root,root) %{_bindir}/gnutar
106 %attr(755,root,root) %{_bindir}/scpio
107 %attr(755,root,root) %{_bindir}/spax
108 %attr(755,root,root) %{_bindir}/star
109 %attr(755,root,root) %{_bindir}/suntar
110 %attr(755,root,root) %{_bindir}/ustar
111 %attr(755,root,root) %{_bindir}/smt
112 %attr(755,root,root) %{_sbindir}/rmt
113 %{_mandir}/man1/gnutar.1*
114 %{_mandir}/man1/scpio.1*
115 %{_mandir}/man1/spax.1*
116 %{_mandir}/man1/star.1*
117 %{_mandir}/man1/suntar.1*
118 %{_mandir}/man1/ustar.1*
119 %{_mandir}/man1/smt.1*
120 %{_mandir}/man1/rmt.1*
121 %{_mandir}/man5/star.5*
This page took 0.101482 seconds and 3 git commands to generate.