]> git.pld-linux.org Git - packages/star.git/blob - star.spec
8de24029913740762cd9a4624db49364022a78d0
[packages/star.git] / star.spec
1 #
2 # Conditional build:
3 %bcond_without  selinux # disable SELinux support
4 #
5 Summary:        A very fast, POSIX compliant tape archiver
6 Summary(pl):    Szybki, zgodny z POSIX program do archiwizacji
7 Name:           star
8 Version:        1.5
9 %define bver    a58
10 Release:        0.%{bver}.6
11 License:        CDDL v1.0
12 Group:          Applications/File
13 Source0:        ftp://ftp.berlios.de/pub/star/alpha/%{name}-%{version}%{bver}.tar.bz2
14 # Source0-md5:  b3c367f0cda2a41dd055edff674e104c
15 # based on http://www.nsa.gov/selinux/patches/star-selinux.patch.gz
16 Patch0:         %{name}-selinux.patch
17 Patch1:         %{name}-no-kernel-headers.patch
18 Patch2:         %{name}-strtod.patch
19 Patch3:         %{name}-unamep.patch
20 Patch4:         %{name}-gcc34.patch
21 URL:            http://www.fokus.gmd.de/research/cc/glone/employees/joerg.schilling/private/star.html
22 BuildRequires:  acl-devel
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 %{?with_selinux:BuildRequires:  libselinux-devel}
26 BuildRequires:  perl-base
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Star is a very fast, POSIX-compliant tar archiver. It reads and writes
31 POSIX compliant tar archives as well as non-POSIX GNU tar archives.
32 Star is the first free POSIX.1-200x compliant tar implementation. It
33 saves many files together into a single tape or disk archive, and can
34 restore individual files from the archive.
35
36 It includes a FIFO for speed, a pattern matcher, multivolume support,
37 the ability to archive sparse files, automatic archive format
38 detection, automatic byte order recognition, automatic archive
39 compression / decompression, remote archives, and special features
40 that allow star to be used for full backups. This package contains the
41 getfacl and setfacl utilities needed for manipulating access control
42 lists.
43
44 It includes the only known platform independant "rmt" server program
45 that hides Linux incompatibilities. The "rmt" server from the star
46 package implements all Sun/GNU/Schily/BSD enhancements and allows any
47 "rmt" client from any OS to contact any OS as server.
48
49 %description -l pl
50 Star jest szybkim, zgodnym z POSIX archiwizerem tar. Potrafi czytaæ i
51 zapisywaæ archiwa tar zgodne z POSIX, a tak¿e nie-posiksowe archiwa
52 GNU. Star jest pierwsz± wolnodostêpn± implementacj± tara zgodn± z
53 norm± POSIX.1-200x. Zapisuje ³±cznie wiele plików na jednej ta¶mie lub
54 dysku i mo¿e odtwarzaæ z archiwum pojedyncze pliki.
55
56 Ma kolejkê FIFO (dla przyspieszenia operacji), dopasowywanie wzorców,
57 obs³ugê archiwów wieloczê¶ciowych, mo¿liwo¶æ archiwizacji plików
58 rzadkich, automatyczne wykrywanie formatu archiwów i kolejno¶ci bajtów
59 w s³owie, automatyczn± kompresjê i dekompresjê, obs³ugê zdalnych
60 archiwów oraz dodatkowe mo¿liwo¶ci umo¿liwiaj±ce wykonywanie pe³nych
61 kopii zapasowych. Ten pakiet zawiera narzêdzia getfacl i setfacl
62 potrzebne do modyfikacji list kontroli dostêpu (ACL).
63
64 Pakiet zawiera te¿ niezale¿ny od platformy serwer rmt, który ma
65 zaimplementowane wszystkie rozszerzenia Sun/GNU/Schily/BSD i pozwala
66 na dostêp klientem rmt z dowolnego systemu operacyjnego.
67
68 %prep
69 %setup -q
70 %{?with_selinux:%patch0 -p1}
71 %patch1 -p1
72 %patch2 -p1
73 %patch3 -p1
74 %patch4 -p1
75
76 # new ac doesn't like comments in the same line as #undef
77 %{__perl} -pi -e 's@/\*.*\*/@@g' conf/xconfig.h.in
78 # kill annoying beep and sleep
79 %{__perl} -pi -e 's/^__gmake_warn.*//' RULES/mk-gmake.id
80
81 %build
82 cd conf
83 cp -f /usr/share/automake/config.* .
84 %{__autoconf}
85 cd ..
86 %{__make} \
87         COPTOPT="%{rpmcflags}" \
88         CC="%{__cc}" \
89         LDCC="%{__cc}"
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93
94 %{__make} install \
95         INS_BASE=$RPM_BUILD_ROOT%{_prefix} \
96         MANDIR=/share/man
97
98 # unwanted here (command conflict with tar and mt-st)
99 rm -f $RPM_BUILD_ROOT%{_bindir}/{mt,tar}
100
101 echo '.so star.1' > $RPM_BUILD_ROOT%{_mandir}/man1/ustar.1
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %files
107 %defattr(644,root,root,755)
108 %doc AN-%{version}%{bver} CDDL.* Changelog README README.{ACL,largefiles,linux,otherbugs,pax,posix-2001} STARvsGNUTAR STATUS.alpha TODO
109 %attr(755,root,root) %{_bindir}/gnutar
110 %attr(755,root,root) %{_bindir}/scpio
111 %attr(755,root,root) %{_bindir}/smt
112 %attr(755,root,root) %{_bindir}/spax
113 %attr(755,root,root) %{_bindir}/star
114 %attr(755,root,root) %{_bindir}/star_fat
115 %attr(755,root,root) %{_bindir}/star_sym
116 %attr(755,root,root) %{_bindir}/suntar
117 %attr(755,root,root) %{_bindir}/tartest
118 %attr(755,root,root) %{_bindir}/ustar
119 %attr(755,root,root) %{_sbindir}/rmt
120 %{_mandir}/man1/gnutar.1*
121 %{_mandir}/man1/scpio.1*
122 %{_mandir}/man1/spax.1*
123 %{_mandir}/man1/star.1*
124 %{_mandir}/man1/suntar.1*
125 %{_mandir}/man1/tartest.1*
126 %{_mandir}/man1/ustar.1*
127 %{_mandir}/man1/smt.1*
128 %{_mandir}/man1/rmt.1*
129 %{_mandir}/man5/star.5*
This page took 0.051302 seconds and 2 git commands to generate.