]> git.pld-linux.org Git - SPECS.git/blob - star.spec
SPECS updated Tue 30 Apr 15:06:09 CEST 2024
[SPECS.git] / star.spec
1 #
2 # Conditional build:
3 %bcond_without  selinux # disable SELinux support
4 #
5 Summary:        A very fast, POSIX compliant tape archiver
6 Summary(pl.UTF-8):      Szybki, zgodny z POSIX program do archiwizacji
7 Name:           star
8 Version:        1.5.2
9 Release:        1
10 License:        CDDL v1.0
11 Group:          Applications/File
12 Source0:        ftp://ftp.berlios.de/pub/star/%{name}-%{version}.tar.bz2
13 # Source0-md5:  5c15cedb52e26b02b95c82de08c5fcc1
14 # based on http://www.nsa.gov/selinux/patches/star-selinux.patch.gz
15 Patch0:         %{name}-selinux.patch
16 Patch1:         %{name}-ac26.patch
17 Patch2:         %{name}-strtod.patch
18 URL:            http://cdrecord.berlios.de/old/private/star.html
19 BuildRequires:  acl-devel
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 %{?with_selinux:BuildRequires:  libselinux-devel}
23 BuildRequires:  perl-base
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Star is a very fast, POSIX-compliant tar archiver. It reads and writes
28 POSIX compliant tar archives as well as non-POSIX GNU tar archives.
29 Star is the first free POSIX.1-200x compliant tar implementation. It
30 saves many files together into a single tape or disk archive, and can
31 restore individual files from the archive.
32
33 It includes a FIFO for speed, a pattern matcher, multivolume support,
34 the ability to archive sparse files, automatic archive format
35 detection, automatic byte order recognition, automatic archive
36 compression / decompression, remote archives, and special features
37 that allow star to be used for full backups. This package contains the
38 getfacl and setfacl utilities needed for manipulating access control
39 lists.
40
41 It includes the only known platform independant "rmt" server program
42 that hides Linux incompatibilities. The "rmt" server from the star
43 package implements all Sun/GNU/Schily/BSD enhancements and allows any
44 "rmt" client from any OS to contact any OS as server.
45
46 %description -l pl.UTF-8
47 Star jest szybkim, zgodnym z POSIX archiwizerem tar. Potrafi czytać i
48 zapisywać archiwa tar zgodne z POSIX, a także nie-posiksowe archiwa
49 GNU. Star jest pierwszą wolnodostępną implementacją tara zgodną z
50 normą POSIX.1-200x. Zapisuje łącznie wiele plików na jednej taśmie lub
51 dysku i może odtwarzać z archiwum pojedyncze pliki.
52
53 Ma kolejkę FIFO (dla przyspieszenia operacji), dopasowywanie wzorców,
54 obsługę archiwów wieloczęściowych, możliwość archiwizacji plików
55 rzadkich, automatyczne wykrywanie formatu archiwów i kolejności bajtów
56 w słowie, automatyczną kompresję i dekompresję, obsługę zdalnych
57 archiwów oraz dodatkowe możliwości umożliwiające wykonywanie pełnych
58 kopii zapasowych. Ten pakiet zawiera narzędzia getfacl i setfacl
59 potrzebne do modyfikacji list kontroli dostępu (ACL).
60
61 Pakiet zawiera też niezależny od platformy serwer rmt, który ma
62 zaimplementowane wszystkie rozszerzenia Sun/GNU/Schily/BSD i pozwala
63 na dostęp klientem rmt z dowolnego systemu operacyjnego.
64
65 %prep
66 %setup -q
67 %{?with_selinux:%patch0 -p1}
68 %patch1 -p1
69 %patch2 -p1
70
71 # new ac doesn't like comments in the same line as #undef
72 %{__perl} -pi -e 's@/\*.*\*/@@g' autoconf/xconfig.h.in
73 # kill annoying beep and sleep
74 %{__perl} -pi -e 's/^__gmake_warn.*//' RULES/mk-gmake.id
75
76 %build
77 cd autoconf
78 ./autoconf
79 cd ..
80 %{__make} \
81         COPTOPT="%{rpmcflags}" \
82         COPTGPROF="" \
83         CC="%{__cc}" \
84         LDCC="%{__cc}"
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 install -d $RPM_BUILD_ROOT%{_sysconfdir}/default
89
90 %{__make} -j1 install \
91         INS_BASE=$RPM_BUILD_ROOT%{_prefix} \
92         INS_RBASE=$RPM_BUILD_ROOT
93
94 install rmt/rmt.dfl $RPM_BUILD_ROOT%{_sysconfdir}/default/rmt
95 install star/star.dfl $RPM_BUILD_ROOT%{_sysconfdir}/default/star
96
97 # unwanted here (command conflict with tar and mt-st)
98 %{__rm} $RPM_BUILD_ROOT%{_bindir}/{mt,tar}
99 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/mt.1
100
101 # cleanup unpackaged stuff
102 %{__rm} -r $RPM_BUILD_ROOT{%{_includedir},%{_prefix}/lib,%{_datadir}/doc}
103 %{__rm} -r $RPM_BUILD_ROOT%{_mandir}/{man3,man5/make*.5*}
104
105 echo '.so star.1' > $RPM_BUILD_ROOT%{_mandir}/man1/ustar.1
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %files
111 %defattr(644,root,root,755)
112 %doc AN-%{version} CDDL.* Changelog READMEs/README.linux STATUS.alpha TODO
113 %doc star/README* star/STARvsGNUTAR
114 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/default/rmt
115 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/default/star
116 %attr(755,root,root) %{_bindir}/gnutar
117 %attr(755,root,root) %{_bindir}/scpio
118 %attr(755,root,root) %{_bindir}/smt
119 %attr(755,root,root) %{_bindir}/spax
120 %attr(755,root,root) %{_bindir}/star
121 %attr(755,root,root) %{_bindir}/star_sym
122 %attr(755,root,root) %{_bindir}/suntar
123 %attr(755,root,root) %{_bindir}/tartest
124 %attr(755,root,root) %{_bindir}/ustar
125 %attr(755,root,root) %{_sbindir}/rmt
126 %{_mandir}/man1/gnutar.1*
127 %{_mandir}/man1/match.1*
128 %{_mandir}/man1/scpio.1*
129 %{_mandir}/man1/spax.1*
130 %{_mandir}/man1/star.1*
131 %{_mandir}/man1/suntar.1*
132 %{_mandir}/man1/tartest.1*
133 %{_mandir}/man1/ustar.1*
134 %{_mandir}/man1/smt.1*
135 %{_mandir}/man1/rmt.1*
136 %{_mandir}/man5/star.5*
This page took 1.218121 seconds and 3 git commands to generate.