]> git.pld-linux.org Git - SPECS.git/blob - squirrel.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / squirrel.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static libraries
4 #
5 Summary:        High level imperative/OO programming language
6 Summary(pl.UTF-8):      Wysokopoziomowy imperatywny/zorientowany obiektowo język programowania
7 Name:           squirrel
8 Version:        2.2.5
9 Release:        1
10 License:        Zlib
11 Group:          Development/Tools
12 Source0:        http://downloads.sourceforge.net/squirrel/%{name}_%{version}_stable.tar.gz
13 # Source0-md5:  35f97d933d46e2b5d54e0c0f2eccfa4a
14 Patch0:         %{name}-autotools.patch
15 Patch1:         %{name}-mem.patch
16 URL:            http://squirrel-lang.org/
17 BuildRequires:  autoconf >= 2.59
18 BuildRequires:  automake
19 BuildRequires:  libstdc++-devel
20 BuildRequires:  libtool >= 2:1.5
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Squirrel is a high level imperative/OO programming language, designed
25 to be a powerful scripting tool that fits in the size, memory
26 bandwidth, and real-time requirements of applications like games.
27
28 %description -l pl.UTF-8
29 Squirrel to wysokopoziomowy, imperatywny, zorientowany obiektowo język
30 programowania, zaprojektowany jako potężne narzędzie do skryptów,
31 nadający się pod względem rozmiaru, wykorzystania pamięci i wymagań
32 czasu rzeczywistego do takich zastosowań, jak gry.
33
34 %package devel
35 Summary:        Development files needed to use Squirrel libraries
36 Summary(pl.UTF-8):      Pliki programistyczne potrzebne do korzystania z bibliotek Squirrela
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}-%{release}
39
40 %description devel
41 Development files needed to use Squirrel libraries.
42
43 %description devel -l pl.UTF-8
44 Pliki programistyczne potrzebne do korzystania z bibliotek Squirrela.
45
46 %package static
47 Summary:        Static Squirrel libraries
48 Summary(pl.UTF-8):      Statyczne biblioteki Squirrela
49 Group:          Development/Libraries
50 Requires:       %{name}-devel = %{version}-%{release}
51
52 %description static
53 Static Squirrel libraries.
54
55 %description static -l pl.UTF-8
56 Statyczne biblioteki Squirrela.
57
58 %prep
59 %setup -q -c
60 cd SQUIRREL2
61 %patch0 -p1
62 %patch1 -p1
63
64 # fix extension for autotools
65 %{__mv} sq/sq.c sq/sq.cpp
66
67 %build
68 cd SQUIRREL2
69 %{__libtoolize}
70 %{__aclocal}
71 %{__autoconf}
72 %{__autoheader}
73 %{__automake}
74 %configure
75         %{!?with_static_libs:--disable-static}
76 %{__make}
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80
81 %{__make} -C SQUIRREL2 install \
82         DESTDIR=$RPM_BUILD_ROOT
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %post   -p /sbin/ldconfig
88 %postun -p /sbin/ldconfig
89
90 %files
91 %defattr(644,root,root,755)
92 %doc SQUIRREL2/{README,HISTORY,COPYRIGHT}
93 %attr(755,root,root) %{_bindir}/sq
94 %attr(755,root,root) %{_libdir}/libsqstdlib-%{version}.so
95 %attr(755,root,root) %{_libdir}/libsquirrel-%{version}.so
96
97 %files devel
98 %defattr(644,root,root,755)
99 %doc SQUIRREL2/doc/*.pdf
100 %attr(755,root,root) %{_libdir}/libsqstdlib.so
101 %attr(755,root,root) %{_libdir}/libsquirrel.so
102 %{_libdir}/libsqstdlib.la
103 %{_libdir}/libsquirrel.la
104 %{_includedir}/squirrel
105 %{_pkgconfigdir}/squirrel.pc
106
107 %if %{with static_libs}
108 %files static
109 %defattr(644,root,root,755)
110 %{_libdir}/libsquirrel.a
111 %{_libdir}/libsqstdlib.a
112 %endif
This page took 0.798895 seconds and 3 git commands to generate.