]> git.pld-linux.org Git - SPECS.git/blob - sptk.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / sptk.spec
1 #
2 # Conditional build:
3 %bcond_with     examples        # build examples (fails at the moment)
4 %bcond_without  excel           # excel support
5 %bcond_without  odbc            # ODBC support
6 %bcond_without  pgsql           # PostgreSQL support
7 %bcond_without  sqlite3         # SQLite3 support
8 %bcond_without  static_libs     # static libraries
9 #
10 Summary:        C++ user interface toolkit for X with database and Excel support
11 Summary(pl.UTF-8):      Toolkit C++ dla X ze wsparciem dla bazy danych i Excela
12 Name:           sptk
13 Version:        3.5.8.8
14 Release:        0.1
15 License:        BSD
16 Group:          Libraries
17 Source0:        http://www.sptk.net/%{name}-%{version}.tbz2
18 # Source0-md5:  7ea3fac6735f508592b3bb46e855d597
19 URL:            http://www.sptk.net/
20 BuildRequires:  aspell-devel
21 BuildRequires:  autoconf >= 2.59
22 BuildRequires:  automake
23 BuildRequires:  fltk-devel
24 BuildRequires:  libtool
25 %{?with_pgsql:BuildRequires:    postgresql-devel}
26 %{?with_sqlite3:BuildRequires:  sqlite3-devel}
27 %{?with_odbc:BuildRequires:     unixODBC-devel}
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Simple Powerful Toolkit is C++ user interface for X with database and
32 Excel support.
33
34 %description -l pl.UTF-8
35 SPTK jest toolkitem C++ dla X ze wsparciem dla bazy danych i Excela.
36
37 %package devel
38 Summary:        Header files for SPTK library
39 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SPTK
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42
43 %description devel
44 Header files for SPTK library.
45
46 %description devel -l pl.UTF-8
47 Pliki nagłówkowe biblioteki SPTK.
48
49 %package static
50 Summary:        Static SPTK library
51 Summary(pl.UTF-8):      Statyczna biblioteka SPTK
52 Group:          Development/Libraries
53 Requires:       %{name}-devel = %{version}-%{release}
54
55 %description static
56 Static SPTK library.
57
58 %description static -l pl.UTF-8
59 Statyczna biblioteka SPTK.
60
61 %package examples
62 Summary:        Examples for Simple Powerful Toolkit
63 Summary(pl.UTF-8):      Przykłady do SPTK
64 Group:          Development/Libraries
65 Requires:       %{name}-devel = %{version}-%{release}
66
67 %description examples
68 Examples for Simple Powerful Toolkit.
69
70 %description examples -l pl.UTF-8
71 Przykłady dla SPTK.
72
73 %prep
74 %setup -q
75
76 %build
77 %{__libtoolize}
78 %{__aclocal}
79 %{__autoconf}
80 %{__automake}
81 %configure \
82         --enable-examples=%{?with_examples:yes}%{!?with_examples:no} \
83         --enable-odbc=%{?with_odbc:yes}%{!?with_odbc:no} \
84         --enable-postgresql=%{?with_pgsql:yes}%{!?with_pgsql:no} \
85         --enable-sqlite3=%{?with_sqlite3:yes}%{!?with_sqlite3:no} \
86         --enable-static=%{?with_static_libs:yes}%{!?with_static_libs:no} \
87         --enable-debug=%{?debug:yes}%{!?debug:no}
88
89 %{__make}
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93
94 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
95
96 %{__make} install \
97         DESTDIR=$RPM_BUILD_ROOT
98
99 cp -Rf examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %post   -p /sbin/ldconfig
105 %postun -p /sbin/ldconfig
106
107 %files
108 %defattr(644,root,root,755)
109 %doc AUTHORS ChangeLog NEWS README
110 #%attr(755,root,root) %{_bindir}/*
111 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
112 %{_datadir}/%{name}
113
114 %files devel
115 %defattr(644,root,root,755)
116 %attr(755,root,root) %{_libdir}/lib*.so
117 %{_libdir}/lib*.la
118 %{_includedir}/*
119
120 %if %{with static_libs}
121 %files static
122 %defattr(644,root,root,755)
123 %{_libdir}/lib*.a
124 %endif
125
126 %files examples
127 %defattr(644,root,root,755)
128 %{_examplesdir}/%{name}-%{version}
This page took 0.478653 seconds and 3 git commands to generate.