]> git.pld-linux.org Git - SPECS.git/blob - spice-vdagent.spec
SPECS updated Tue 30 Apr 15:13:02 CEST 2024
[SPECS.git] / spice-vdagent.spec
1 # TODO:
2 # - gtk4 as an option?
3 # - package gdm files
4 #
5 # Conditional build:
6 %bcond_with     systemd # use systemd instead of ConsoleKit for session tracking
7 #
8 Summary:        Linux guest agent for SPICE
9 Summary(pl.UTF-8):      Agent gościa linuksowego dla SPICE
10 Name:           spice-vdagent
11 Version:        0.22.1
12 Release:        0.1
13 License:        GPL v3+
14 Group:          X11/Applications
15 Source0:        https://www.spice-space.org/download/releases/%{name}-%{version}.tar.bz2
16 # Source0-md5:  bcc98e716c170f58ebf44c49fdda3a2e
17 Patch0:         %{name}-tmpfile.patch
18 URL:            https://www.spice-space.org/
19 BuildRequires:  alsa-lib-devel >= 1.0.22
20 BuildRequires:  autoconf >= 2.59
21 BuildRequires:  automake
22 BuildRequires:  dbus-devel
23 BuildRequires:  glib2-devel >= 1:2.68
24 BuildRequires:  gtk+3-devel >= 3.22
25 BuildRequires:  libdrm-devel
26 BuildRequires:  pkgconfig
27 BuildRequires:  rpmbuild(macros) >= 1.682
28 BuildRequires:  spice-protocol >= 0.14.3
29 %{?with_systemd:BuildRequires:  systemd-devel >= 1:209}
30 BuildRequires:  udev-devel
31 BuildRequires:  xorg-lib-libX11-devel
32 BuildRequires:  xorg-lib-libXfixes-devel
33 BuildRequires:  xorg-lib-libXinerama-devel
34 BuildRequires:  xorg-lib-libXrandr-devel >= 1.3
35 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.10
36 Requires:       alsa-lib >= 1.0.22
37 Requires:       glib2 >= 1:2.68
38 Requires:       gtk+3 >= 3.22
39 Requires:       systemd-units >= 1:209
40 Requires:       xorg-lib-libXrandr >= 1.3
41 Requires:       xorg-lib-libpciaccess >= 0.10
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 The SPICE agent for Linux consists of 2 parts, a daemon spice-vdagentd
46 and a per X-session process spice-vdagent. The daemon gets
47 automatically started in Spice guests through a udev rule. The per
48 X-session gets automatically started in desktop environments which
49 honor /etc/xdg/autostart, and under gdm.
50
51 %description -l pl.UTF-8
52 Agent SPICE dla Linuksa składa się z 2 części: demona spice-vdagentd
53 oraz procesu dla sesji X spice-vdagent. Demon uruchamia się
54 automatycznie na gościach Spice poprzez regułę udeva. Proces dla sesji
55 X jest uruchamiany automatycznie w środowiskach graficznych
56 honorujących /etc/xdg/autostart oraz pod GDM-em.
57
58 %prep
59 %setup -q
60 %patch0 -p1
61
62 %build
63 %{__aclocal}
64 %{__autoconf}
65 %{__autoheader}
66 %{__automake}
67 %configure \
68         --disable-silent-rules \
69         --with-init-script=systemd+redhat \
70         --with-session-info=%{?with_systemd:systemd}%{!?with_systemd:console-kit}
71 %{__make}
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75
76 %{__make} install \
77         DESTDIR=$RPM_BUILD_ROOT
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %post
83 /sbin/chkconfig --add %{name}
84 %service %{name} restart
85
86 %preun
87 if [ "$1" = "0" ]; then
88         %service -q %{name} stop
89         /sbin/chkconfig --del %{name}
90 fi
91
92 %files
93 %defattr(644,root,root,755)
94 %doc CHANGELOG.md README.md
95 %attr(755,root,root) %{_bindir}/spice-vdagent
96 %attr(755,root,root) %{_sbindir}/spice-vdagentd
97 # TODO: PLDify
98 %attr(754,root,root) /etc/rc.d/init.d/spice-vdagentd
99 /etc/xdg/autostart/spice-vdagent.desktop
100 %{systemdunitdir}/spice-vdagentd.service
101 %{systemdunitdir}/spice-vdagentd.socket
102 %{systemduserunitdir}/spice-vdagent.service
103 /lib/udev/rules.d/70-spice-vdagentd.rules
104 %{systemdtmpfilesdir}/spice-vdagentd.conf
105 %{_mandir}/man1/spice-vdagent.1*
106 %{_mandir}/man1/spice-vdagentd.1*
107 # TODO: gdm
108 #%{_datadir}/gdm/autostart/LoginWindow/spice-vdagent.desktop
109 #%{_datadir}/gdm/greeter/autostart/spice-vdagent.desktop
This page took 0.47312 seconds and 3 git commands to generate.