]> git.pld-linux.org Git - packages/speech_tools.git/blob - speech_tools.spec
- added pl descriptions and versions to Requires
[packages/speech_tools.git] / speech_tools.spec
1 Summary:        Edinburgh Speech Tools Library
2 Summary(pl):    Biblioteka narzêdzi mowy Edinburgh
3 Name:           speech_tools
4 Version:        1.2.2
5 Release:        1
6 License:        Distributable
7 Group:          Applications/Sound
8 Source0:        http://www.cstr.ed.ac.uk/download/festival/1.4.2/%{name}-%{version}-release.tar.gz
9 Patch0:         %{name}-termcap.patch
10 Patch1:         %{name}-shared.patch
11 URL:            http://www.cstr.ed.ac.uk/projects/speech_tools.html
12 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14 %description
15 The Edinburgh speech tools system is a library of C++ classes,
16 functions and utility programs that are frequently used in speech
17 software.
18
19 %description -l pl
20 Narzêdzia mowy Edinburgh s± bibliotek± klas C++, funkcji i programów
21 u¿ytkowych, które czêsto u¿ywa siê w syntezatorach mowy.
22
23 %package devel
24 Summary:        Developement files for speech tools
25 Summary(pl):    Pliki nag³ówkowe do narzêdzi mowy
26 Group:          Applications/Sound
27 Requires:       %{name} = %{version}
28
29 %description devel
30 Developement files for speech tools.
31
32 %description devel -l pl
33 Pliki nag³ówkowe do narzêdzi mowy.
34
35 %package static
36 Summary:        Static libraries for speech tools
37 Summary(pl):    Statyczne biblioteki narzêdzi mowy
38 Group:          Applications/Sound
39 Requires:       %{name}-devel = %{version}
40
41 %description static
42 Static libraries for speech tools.
43
44 %description static -l pl
45 Statyczne biblioteki narzêdzi mowy.
46
47 %package utils
48 Summary:        Speech tools utils
49 Summary(pl):    Programy u¿ytkowe narzêdzi mowy Edinburgh
50 Group:          Applications/Sound
51 Requires:       %{name} = %{version}
52
53 %description utils
54 Speech tools utils.
55
56 %description utils -l pl
57 Programy u¿ytkowe narzêdzi mowy Edinburgh.
58
59 %prep
60 %setup -q -n %{name}
61 %patch0 -p1
62 %patch1 -p1
63
64 %build
65 %configure2_13
66 %{__make} \
67         CC="%{__cc}" \
68         CXX="%{__cxx}" \
69         CFLAGS="%{rpmcflags}" \
70         LDFLAGS="%{rpmldlags}" \
71         OS_LIBS="-ldl -lncurses"
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir}/EST,%{_datadir}/%{name}/example_data}
76 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{scripts,siod,stats/wagon,grammar/{scfg,wfst}}
77
78 # includes
79 cp -r include/* $RPM_BUILD_ROOT%{_includedir}/EST
80 find $RPM_BUILD_ROOT%{_includedir}/EST -name Makefile -exec rm \{\} \;
81 for file in `find $RPM_BUILD_ROOT%{_includedir}/EST -type f`
82 do
83         sed 's/\"\(.*h\)\"/\<EST\/\1\>/g' $file > $file.tmp
84         mv $file.tmp $file
85 done
86
87 # libraries
88 install lib/lib* $RPM_BUILD_ROOT%{_libdir}
89 for i in $RPM_BUILD_ROOT%{_libdir}/*.so
90 do
91         rm $i
92         ln -s `basename $i*` $i
93 done
94
95 # binaries
96 install `find bin -type f -perm +1` $RPM_BUILD_ROOT%{_bindir}
97
98 # scripts
99 install scripts/{example_to_doc++.prl,make_wagon_desc.sh,resynth.sh,shared_script,shared_setup_prl,shared_setup_sh} \
100                 $RPM_BUILD_ROOT%{_libdir}/%{name}/scripts
101
102 # example data
103 install lib/example_data/* $RPM_BUILD_ROOT%{_datadir}/%{name}/example_data
104 rm $RPM_BUILD_ROOT%{_datadir}/%{name}/example_data/Makefile
105
106 # more shit
107 cp -r config $RPM_BUILD_ROOT%{_libdir}/%{name}
108 cp -r testsuite $RPM_BUILD_ROOT%{_libdir}/%{name}
109 rm $RPM_BUILD_ROOT%{_libdir}/%{name}/testsuite/*.o
110 install siod/siod.mak $RPM_BUILD_ROOT%{_libdir}/%{name}/siod
111 install stats/ols.mak $RPM_BUILD_ROOT%{_libdir}/%{name}/stats
112 install stats/wagon/wagon.mak $RPM_BUILD_ROOT%{_libdir}/%{name}/stats/wagon
113 install grammar/scfg/scfg.mak $RPM_BUILD_ROOT%{_libdir}/%{name}/grammar/scfg
114 install grammar/wfst/wfst.mak $RPM_BUILD_ROOT%{_libdir}/%{name}/grammar/wfst
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %post   -p /sbin/ldconfig
120 %postun -p /sbin/ldconfig
121
122 %files
123 %defattr(644,root,root,755)
124 %doc README
125 %attr(755,root,root) %{_libdir}/lib*.so.*.*
126 %{_datadir}/%{name}
127
128 %files devel
129 %defattr(644,root,root,755)
130 %{_libdir}/lib*.so
131 %{_includedir}/EST
132 %{_libdir}/%{name}
133
134 %files static
135 %defattr(644,root,root,755)
136 %{_libdir}/lib*.a
137
138 %files utils
139 %defattr(644,root,root,755)
140 %attr(755,root,root) %{_bindir}/*
This page took 0.05944 seconds and 3 git commands to generate.