]> git.pld-linux.org Git - packages/speech-dispatcher.git/blob - speech-dispatcher.spec
- add systemd tmpfiles config
[packages/speech-dispatcher.git] / speech-dispatcher.spec
1 #
2 # Conditional build:
3 %bcond_with     ibmtts          # commercial, proprietary IBM TTS synthesizer support
4 %bcond_without  flite           # flite synthetizer support
5 %bcond_without  espeak          # espeak synthetizer support
6 %bcond_without  nas             # NAS audio output support
7 %bcond_without  alsa            # ALSA audio output supprot
8 %bcond_without  pulseaudio      # pulse audio output support
9 %bcond_without  static_libs     # don't build static libraries
10 %bcond_without  ivona           # don't build ivona support
11 #
12 Summary:        A device independent layer for speech synthesis
13 Summary(pl.UTF-8):      Niezależna od urządzenia warstwa obsługująca syntezę mowy
14 Name:           speech-dispatcher
15 Version:        0.7.1
16 Release:        1
17 License:        GPL v2
18 Group:          Applications/Sound
19 Source0:        http://www.freebsoft.org/pub/projects/speechd/%{name}-%{version}.tar.gz
20 # Source0-md5:  ccfc30ac006673d36b4223eb760ed696
21 Source1:        %{name}.init
22 Source2:        %{name}.sysconfig
23 Patch0:         %{name}-info.patch
24 Patch1:         pulse.patch
25 URL:            http://www.freebsoft.org/
26 %{?with_alsa:BuildRequires:     alsa-lib-devel}
27 BuildRequires:  autoconf
28 BuildRequires:  automake
29 BuildRequires:  dotconf-devel
30 %{?with_espeak:BuildRequires:   espeak-devel}
31 %{?with_flite:BuildRequires:    flite-devel}
32 %{?with_ibmtts:BuildRequires:   ibmtts-devel}
33 BuildRequires:  libatomic_ops
34 %{?with_ivona:BuildRequires:    libdumbtts-devel}
35 BuildRequires:  libtool
36 %{?with_nas:BuildRequires:      nas-devel}
37 BuildRequires:  pkgconfig
38 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
39 BuildRequires:  python-devel >= 1:2.5
40 BuildRequires:  rpm-pythonprov
41 BuildRequires:  rpmbuild(macros) >= 1.527
42 BuildRequires:  texinfo
43 Requires(post,preun):   /sbin/chkconfig
44 Requires(postun):       /usr/sbin/groupdel
45 Requires(postun):       /usr/sbin/userdel
46 Requires(pre):  /bin/id
47 Requires(pre):  /usr/bin/getgid
48 Requires(pre):  /usr/sbin/groupadd
49 Requires(pre):  /usr/sbin/useradd
50 Requires:       %{name}-libs = %{version}-%{release}
51 Requires:       rc-scripts
52 Provides:       group(%{name})
53 Provides:       user(%{name})
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %description
57 Speech Dispatcher provides a device independent layer for speech
58 synthesis.
59
60 %description -l pl.UTF-8
61 Speech Dispatcher zapewnia niezależną od urządzenia warstwę
62 obsługującą syntezę mowy.
63
64 %package libs
65 Summary:        Speech Dispatcher client library
66 Summary(pl.UTF-8):      Biblioteka kliencka Speech Dispatchera
67 Group:          Libraries
68
69 %description libs
70 Speech Dispatcher provides a device independent layer for speech
71 synthesis. This package contains client library.
72
73 %description libs -l pl.UTF-8
74 Speech Dispatcher zapewnia niezależną od urządzenia warstwę
75 obsługującą syntezę mowy. Ten pakiet zawiera biblitotekę kliencką.
76
77 %package devel
78 Summary:        Header files for speech-dispatcher library
79 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki speech-dispatcher
80 Group:          Development/Libraries
81 Requires:       %{name}-libs = %{version}-%{release}
82
83 %description devel
84 Header files for speech-dispatcher library.
85
86 %description devel -l pl.UTF-8
87 Pliki nagłówkowe biblioteki speech-dispatcher.
88
89 %package static
90 Summary:        Static speech-dispatcher library
91 Summary(pl.UTF-8):      Statyczna biblioteka speech-dispatcher
92 Group:          Development/Libraries
93 Requires:       %{name}-devel = %{version}-%{release}
94
95 %description static
96 Static speech-dispatcher library.
97
98 %description static -l pl.UTF-8
99 Statyczna biblioteka speech-dispatcher.
100
101 %package -n python-%{name}
102 Summary:        Python library for communication with Speech Dispatcher
103 Summary(pl.UTF-8):      Biblioteka Pythona do komunikacji ze Speech Dispatcherem
104 Group:          Libraries/Python
105 %pyrequires_eq  python-modules
106
107 %description -n python-%{name}
108 Speech Dispatcher provides a device independent layer for speech
109 synthesis. This package contains a Python library for communication
110 with Speech Dispatcher.
111
112 %description -n python-%{name} -l pl.UTF-8
113 Speech Dispatcher zapewnia niezależną od urządzenia warstwę
114 obsługującą syntezę mowy. Ten pakiet zawiera bibliotekę Pythona do
115 komunikacji ze Speech Dispatcherem.
116
117 %prep
118 %setup -q
119 %patch0 -p1
120 %patch1 -p1
121
122 %build
123 %{__libtoolize}
124 %{__aclocal}
125 %{__autoconf}
126 %{__autoheader}
127 %{__automake}
128 %configure \
129         %{__with_without flite} \
130         %{__with_without ibmtts} \
131         %{__with_without espeak} \
132         %{__with_without nas} \
133         %{__with_without alsa} \
134         %{__with_without pulseaudio pulse} \
135         %{__with_without ivona} \
136         %{__enable_disable static_libs static}
137
138 %{__make}
139
140 %install
141 rm -rf $RPM_BUILD_ROOT
142
143 install -d $RPM_BUILD_ROOT/var/{log,run}/speech-dispatcher
144
145 %{__make} install \
146         DESTDIR=$RPM_BUILD_ROOT
147
148 install -D %{SOURCE1}   $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
149 install -D %{SOURCE2}   $RPM_BUILD_ROOT/etc/sysconfig/%{name}
150
151 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}/speechd
152 %py_postclean
153 # library for engines output, API not included in -devel
154 rm $RPM_BUILD_ROOT%{_libdir}/speech-dispatcher/libsdaudio.{so,la,a}
155
156 %clean
157 rm -rf $RPM_BUILD_ROOT
158
159 %pre
160 %groupadd -g 224 %{name}
161 %useradd -u 224 -g 224 -G audio -d /usr/share/empty -s /bin/false -c "%{name} user" %{name}
162
163 %post
164 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
165 /sbin/chkconfig --add %{name}
166 %service %{name} restart
167
168 %preun
169 if [ "$1" = "0" ]; then
170         %service %{name} stop
171         /sbin/chkconfig --del %{name}
172 fi
173
174 %postun
175 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
176 if [ "$1" = "0" ]; then
177         %userremove %{name}
178         %groupremove %{name}
179 fi
180
181 %post   libs -p /sbin/ldconfig
182 %postun libs -p /sbin/ldconfig
183
184 %files
185 %defattr(644,root,root,755)
186 %doc AUTHORS ChangeLog NEWS README TODO
187 %attr(754,root,root) /etc/rc.d/init.d/%{name}
188 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
189 %attr(755,root,root) %{_bindir}/clibrary
190 %attr(755,root,root) %{_bindir}/clibrary2
191 %attr(755,root,root) %{_bindir}/connection_recovery
192 %attr(755,root,root) %{_bindir}/long_message
193 %attr(755,root,root) %{_bindir}/run_test
194 %attr(755,root,root) %{_bindir}/spd-conf
195 %attr(755,root,root) %{_bindir}/spd-say
196 %attr(755,root,root) %{_bindir}/spdsend
197 %attr(755,root,root) %{_bindir}/speech-dispatcher
198 %dir %{_libdir}/speech-dispatcher
199 %attr(755,root,root) %{_libdir}/speech-dispatcher/libsdaudio.so.*
200 %dir %{_sysconfdir}/speech-dispatcher
201 %dir %{_sysconfdir}/speech-dispatcher/clients
202 %dir %{_sysconfdir}/speech-dispatcher/modules
203 %dir %{_libdir}/speech-dispatcher-modules
204 %attr(755,root,root) %{_libdir}/speech-dispatcher-modules/sd_cicero
205 %attr(755,root,root) %{_libdir}/speech-dispatcher-modules/sd_dummy
206 %attr(755,root,root) %{_libdir}/speech-dispatcher-modules/sd_espeak
207 %attr(755,root,root) %{_libdir}/speech-dispatcher-modules/sd_festival
208 %attr(755,root,root) %{_libdir}/speech-dispatcher-modules/sd_flite
209 %attr(755,root,root) %{_libdir}/speech-dispatcher-modules/sd_generic
210 %attr(755,root,root) %{_libdir}/speech-dispatcher-modules/sd_ivona
211 %{_datadir}/speech-dispatcher
212 %{_datadir}/sounds/speech-dispatcher
213 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/speech-dispatcher/speechd.conf
214 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/speech-dispatcher/clients/emacs.conf
215 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/speech-dispatcher/clients/gnome-speech.conf
216 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/speech-dispatcher/modules/cicero.conf
217 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/speech-dispatcher/modules/dtk-generic.conf
218 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/speech-dispatcher/modules/epos-generic.conf
219 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/speech-dispatcher/modules/espeak-generic.conf
220 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/speech-dispatcher/modules/espeak-mbrola-generic.conf
221 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/speech-dispatcher/modules/espeak.conf
222 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/speech-dispatcher/modules/festival.conf
223 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/speech-dispatcher/modules/flite.conf
224 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/speech-dispatcher/modules/ibmtts.conf
225 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/speech-dispatcher/modules/ivona.conf
226 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/speech-dispatcher/modules/llia_phon-generic.conf
227 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/speech-dispatcher/modules/swift-generic.conf
228 %dir %attr(755,%{name},%{name}) /var/run/speech-dispatcher
229 %dir %attr(755,%{name},%{name}) /var/log/speech-dispatcher
230 %{_infodir}/spd-say.info*
231 %{_infodir}/speech-dispatcher.info*
232 %{_infodir}/ssip.info*
233
234 %files libs
235 %defattr(644,root,root,755)
236 %attr(755,root,root) %{_libdir}/libspeechd.so.*.*.*
237 %attr(755,root,root) %ghost %{_libdir}/libspeechd.so.2
238
239 %files devel
240 %defattr(644,root,root,755)
241 %attr(755,root,root) %{_libdir}/libspeechd.so
242 %{_libdir}/libspeechd.la
243 %{_includedir}/libspeechd.h
244
245 %if %{with static_libs}
246 %files static
247 %defattr(644,root,root,755)
248 %{_libdir}/libspeechd.a
249 %endif
250
251 %files -n python-%{name}
252 %defattr(644,root,root,755)
253 %dir %{py_sitedir}/speechd
254 %dir %{py_sitedir}/speechd_config
255 %{py_sitedir}/speechd/*.py[co]
256 %{py_sitedir}/speechd_config/*.py[co]
This page took 0.21581 seconds and 3 git commands to generate.