]> git.pld-linux.org Git - packages/speech-dispatcher.git/blob - speech-dispatcher.spec
- release 3
[packages/speech-dispatcher.git] / speech-dispatcher.spec
1 #
2 # Conditional build:
3 %bcond_with     ibmtts          # commercial, proprietary IBM TTS synthesizer support
4 %bcond_without  flite           # flite synthetizer support
5 %bcond_without  espeak          # espeak synthetizer support
6 %bcond_without  nas             # NAS audio output support
7 %bcond_without  alsa            # ALSA audio output supprot
8 %bcond_without  pulse           # pulse audio output support
9 %bcond_without  static_libs     # don't build static libraries
10 %bcond_without  ivona   # don't build ivona support
11 #
12 Summary:        A device independent layer for speech synthesis
13 Summary(pl.UTF-8):      Niezależna od urządzenia warstwa obsługująca syntezę mowy
14 Name:           speech-dispatcher
15 Version:        0.6.7
16 Release:        3
17 License:        GPL v2
18 Group:          Applications/Sound
19 Source0:        http://www.freebsoft.org/pub/projects/speechd/%{name}-%{version}.tar.gz
20 # Source0-md5:  67432ad655b50fd7c1f1f79e012cfe3f
21 Source1:        %{name}.init
22 Source2:        %{name}.sysconfig
23 Patch0:         %{name}-python-install.patch
24 Patch1:         %{name}-info.patch
25 Patch2:         %{name}-gcc.patch
26 URL:            http://www.freebsoft.org/
27 %{?with_alsa:BuildRequires:     alsa-lib-devel}
28 BuildRequires:  autoconf
29 BuildRequires:  automake
30 BuildRequires:  dotconf-devel
31 %{?with_espeak:BuildRequires:   espeak-devel}
32 %{?with_flite:BuildRequires:    flite-devel}
33 %{?with_ibmtts:BuildRequires:   ibmtts-devel}
34 BuildRequires:  libatomic_ops
35 BuildRequires:  libtool
36 %{?with_ivona:BuildRequires:    libdumbtts-devel}
37 %{?with_nas:BuildRequires:      nas-devel}
38 BuildRequires:  pkgconfig
39 %{?with_pulse:BuildRequires:    pulseaudio-devel}
40 BuildRequires:  python-devel >= 1:2.5
41 BuildRequires:  rpm-pythonprov
42 BuildRequires:  rpmbuild(macros) >= 1.228
43 BuildRequires:  texinfo
44 Requires(pre):  /bin/id
45 Requires(pre):  /usr/bin/getgid
46 Requires(pre):  /usr/sbin/groupadd
47 Requires(pre):  /usr/sbin/useradd
48 Requires(post,preun):   /sbin/chkconfig
49 Requires(postun):       /usr/sbin/groupdel
50 Requires(postun):       /usr/sbin/userdel
51 Requires:       %{name}-libs = %{version}-%{release}
52 Requires:       rc-scripts
53 Provides:       group(%{name})
54 Provides:       user(%{name})
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 %description
58 Speech Dispatcher provides a device independent layer for speech
59 synthesis.
60
61 %description -l pl.UTF-8
62 Speech Dispatcher zapewnia niezależną od urządzenia warstwę
63 obsługującą syntezę mowy.
64
65 %package libs
66 Summary:        Speech Dispatcher client library
67 Summary(pl.UTF-8):      Biblioteka kliencka Speech Dispatchera
68 Group:          Libraries
69
70 %description libs
71 Speech Dispatcher provides a device independent layer for speech
72 synthesis. This package contains client library.
73
74 %description libs -l pl.UTF-8
75 Speech Dispatcher zapewnia niezależną od urządzenia warstwę
76 obsługującą syntezę mowy. Ten pakiet zawiera biblitotekę kliencką.
77
78 %package devel
79 Summary:        Header files for speech-dispatcher library
80 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki speech-dispatcher
81 Group:          Development/Libraries
82 Requires:       %{name}-libs = %{version}-%{release}
83
84 %description devel
85 Header files for speech-dispatcher library.
86
87 %description devel -l pl.UTF-8
88 Pliki nagłówkowe biblioteki speech-dispatcher.
89
90 %package static
91 Summary:        Static speech-dispatcher library
92 Summary(pl.UTF-8):      Statyczna biblioteka speech-dispatcher
93 Group:          Development/Libraries
94 Requires:       %{name}-devel = %{version}-%{release}
95
96 %description static
97 Static speech-dispatcher library.
98
99 %description static -l pl.UTF-8
100 Statyczna biblioteka speech-dispatcher.
101
102 %package -n python-%{name}
103 Summary:        Python library for communication with Speech Dispatcher
104 Summary(pl_PL.UTF-8):   Biblioteka Pythona do komunikacji ze Speech Dispatcherem
105 Group:          Libraries/Python
106 %pyrequires_eq  python-modules
107
108 %description -n python-%{name}
109 Speech Dispatcher provides a device independent layer for speech
110 synthesis. This package contains a Python library for communication
111 with Speech Dispatcher.
112
113 %description -n python-%{name} -l pl_PL.UTF-8
114 Speech Dispatcher zapewnia niezależną od urządzenia warstwę
115 obsługującą syntezę mowy. Ten pakiet zawiera bibliotekę Pythona do
116 komunikacji ze Speech Dispatcherem.
117
118 %prep
119 %setup -q
120 %patch0 -p1
121 %patch1 -p1
122 %patch2 -p0
123
124 %build
125 %{__libtoolize}
126 %{__aclocal}
127 %{__autoconf}
128 %{__autoheader}
129 %{__automake}
130 %configure \
131         %{?with_flite:--with-flite}%{!?with_flite:--without-flite} \
132         %{?with_ibmtts:--with-ibmtts}%{!?with_ibmtts:--without-ibmtts} \
133         %{?with_espeak:--with-espeak}%{!?with_espeak:--without-espeak} \
134         %{?with_nas:--with-nas}%{!?with_nas:--without-nas} \
135         %{?with_alsa:--with-alsa}%{!?with_alsa:--without-alsa} \
136         %{?with_pulse:--with-pulse}%{!?with_pulse:--without-pulse} \
137         %{?with_ivona:--with-ivona}%{!?with_ivona:--without-ivona} \
138         --enable-static=%{?with_static_libs:yes}%{!?with_static_libs:no}
139
140 %{__make}
141
142 %install
143 rm -rf $RPM_BUILD_ROOT
144
145 install -d $RPM_BUILD_ROOT/var/{log,run}/speech-dispatcher
146
147 %{__make} install \
148         DESTDIR=$RPM_BUILD_ROOT
149
150 install -D %{SOURCE1}   $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
151 install -D %{SOURCE2}   $RPM_BUILD_ROOT/etc/sysconfig/%{name}
152
153 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}/speechd
154 %py_postclean
155 # library for engines output, API not included in -devel
156 rm $RPM_BUILD_ROOT%{_libdir}/speech-dispatcher/libsdaudio.{so,la,a}
157
158 %clean
159 rm -rf $RPM_BUILD_ROOT
160
161 %pre
162 %groupadd -g 224 %{name}
163 %useradd -u 224 -g 224 -G audio -d /usr/share/empty -s /bin/false -c "%{name} user" %{name}
164
165 %post
166 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
167 /sbin/chkconfig --add %{name}
168 %service %{name} restart
169
170 %preun
171 if [ "$1" = "0" ]; then
172         %service %{name} stop
173         /sbin/chkconfig --del %{name}
174 fi
175
176 %postun
177 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
178 if [ "$1" = "0" ]; then
179         %userremove %{name}
180         %groupremove %{name}
181 fi
182
183 %post   libs -p /sbin/ldconfig
184 %postun libs -p /sbin/ldconfig
185
186 %files
187 %defattr(644,root,root,755)
188 %doc AUTHORS ChangeLog NEWS README TODO
189 %attr(754,root,root) /etc/rc.d/init.d/%{name}
190 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
191 %attr(755,root,root) %{_bindir}/*
192 %dir %{_libdir}/speech-dispatcher
193 %attr(755,root,root) %{_libdir}/speech-dispatcher/libsdaudio.so.*
194 %dir %{_sysconfdir}/speech-dispatcher
195 %dir %{_sysconfdir}/speech-dispatcher/clients
196 %dir %{_sysconfdir}/speech-dispatcher/modules
197 %dir %{_libdir}/speech-dispatcher-modules
198 %attr(755,root,root) %{_libdir}/speech-dispatcher-modules/sd_*
199 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/speech-dispatcher/*.conf
200 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/speech-dispatcher/clients/*.conf
201 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/speech-dispatcher/modules/*.conf
202 %dir %attr(755,%{name},%{name}) /var/run/speech-dispatcher
203 %dir %attr(755,%{name},%{name}) /var/log/speech-dispatcher
204 %{_infodir}/spd-say.info*
205 %lang(cs) %{_infodir}/speech-dispatcher-cs.info*
206 %{_infodir}/speech-dispatcher.info*
207 %{_infodir}/ssip.info*
208
209 %files libs
210 %defattr(644,root,root,755)
211 %attr(755,root,root) %{_libdir}/libspeechd.so.*.*.*
212 %attr(755,root,root) %ghost %{_libdir}/libspeechd.so.2
213
214 %files devel
215 %defattr(644,root,root,755)
216 %attr(755,root,root) %{_libdir}/libspeechd.so
217 %{_libdir}/libspeechd.la
218 %{_includedir}/libspeechd.h
219
220 %if %{with static_libs}
221 %files static
222 %defattr(644,root,root,755)
223 %{_libdir}/libspeechd.a
224 %endif
225
226 %files -n python-%{name}
227 %defattr(644,root,root,755)
228 %dir %{py_sitescriptdir}/speechd
229 %{py_sitescriptdir}/speechd/*.py[co]
230 %{py_sitescriptdir}/speechd-*.egg-info
This page took 0.052182 seconds and 3 git commands to generate.