]> git.pld-linux.org Git - packages/sleuthkit.git/blob - sleuthkit.spec
- updated to 4.6.7
[packages/sleuthkit.git] / sleuthkit.spec
1 #
2 # TODO:
3 #       - add libvhdi bcond and support
4 #       - add libvmdk bcond and support
5 #
6 # Conditional build:
7 %bcond_without  aff             # Without Advanced Forensic Format (aff) support
8 #
9 Summary:        The Sleuth Kit - an forensic toolkit for analyzing file systems and disks
10 Summary(pl.UTF-8):      The Sleuth Kit - zestaw narzędzi wspomagających analizę systemów plików
11 Name:           sleuthkit
12 Version:        4.6.7
13 Release:        1
14 License:        IBM Public License/Common Public License
15 Group:          Applications
16 Source0:        https://github.com/sleuthkit/sleuthkit/releases/download/%{name}-%{version}/%{name}-%{version}.tar.gz
17 # Source0-md5:  173216be56d73c89a04631607068af80
18 URL:            http://www.sleuthkit.org/sleuthkit/
19 %{?with_aff:BuildRequires:      afflib-devel}
20 #BuildRequires: autoconf
21 #BuildRequires: automake
22 BuildRequires:  libewf-devel
23 BuildRequires:  libstdc++-devel
24 #BuildRequires: libtool
25 BuildRequires:  openssl-devel
26 BuildRequires:  perl-base
27 BuildRequires:  sed >= 4.0
28 Requires:       coreutils
29 Requires:       file
30 # XXX: openssl library (should be autodetected) or openssl-tools or perl-OpenSSL-??? ?
31 Requires:       openssl
32 Requires:       perl-Date-Manip
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 The Sleuth Kit is an open source forensic toolkit for analyzing
37 Microsoft and UNIX file systems and disks. The Sleuth Kit enables
38 investigators to identify and recover evidence from images acquired
39 during incident response or from live systems. The Sleuth Kit is open
40 source, which allows investigators to verify the actions of the tool
41 or customize it to specific needs.
42
43 It is recommended that these command line tools can be used with the
44 Autopsy Forensic Browser. Autopsy,
45 (<http://www.sleuthkit.org/autopsy/>), is a graphical interface to the
46 tools of The Sleuth Kit and automates many of the procedures and
47 provides features such as image searching and MD5 image integrity
48 checks.
49
50 As with any investigation tool, any results found with The Sleuth Kit
51 should be be recreated with a second tool to verify the data.
52
53 %description -l pl.UTF-8
54 The Sleuth Kit to mający otwarte źródła zestaw narzędzi do analizy
55 systemów plików i dysków z systemami Microsoftu i uniksowymi. The
56 Sleuth Kit umożliwia badającym zidentyfikować i odtworzyć dowody
57 uzyskane podczas reakcji na incydent lub z żywych systemów. The Sleuth
58 Kit ma otwarte źródła, co pozwala badającym zweryfikować działania
59 narzędzia lub przystosować je do określonych potrzeb.
60
61 Zalecane jest używanie tych narzędzi działających z linii poleceń wraz
62 z przeglądarką Autopsy (<http://www.sleuthkit.org/autopsy/>), będącą
63 graficznym interfejsem do narzędzi z The Sleuth Kit i automatyzującą
64 wiele procedur oraz udostępniającą możliwości takie jak przeszukiwanie
65 obrazów i sprawdzanie integralności obrazów za pomocą sum MD5.
66
67 Podobnie jak przy dowolnym narzędziu badawczym wszelkie wyniki
68 uzyskane przy użyciu tego zestawu powinny być odtworzone przy użyciu
69 drugiego narzędzia dla zweryfikowania wiarygodności.
70
71 %package libs
72 Summary:        Sleuthkit shared library
73 Summary(pl.UTF-8):      Biblioteka współdzielona Sleuthkita
74 Group:          Libraries
75
76 %description libs
77 Sleuthkit shared library.
78
79 %description libs -l pl.UTF-8
80 Biblioteka współdzielona Sleuthkita.
81
82 %package devel
83 Summary:        Header files for %{name} library
84 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
85 Group:          Development/Libraries
86 Requires:       %{name} = %{version}-%{release}
87
88 %description devel
89 Header files for %{name} library.
90
91 %description devel -l pl.UTF-8
92 Pliki nagłówkowe biblioteki %{name}.
93
94 %package devel
95 Summary:        Header files for %{name} library
96 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
97 Group:          Development/Libraries
98 Requires:       %{name} = %{version}-%{release}
99
100 %description devel
101 Header files for %{name} library.
102
103 %description devel -l pl.UTF-8
104 Pliki nagłówkowe biblioteki %{name}.
105
106 %package static
107 Summary:        Static %{name} library
108 Summary(pl.UTF-8):      Statyczna biblioteka %{name}
109 Group:          Development/Libraries
110 Requires:       %{name}-devel = %{version}-%{release}
111
112 %description static
113 Static %{name} library.
114
115 %description static -l pl.UTF-8
116 Statyczna biblioteka %{name}.
117
118 %package java
119 Summary:        Java bindings for sleuthkit
120 Summary(pl.UTF-8):      Dowiązania Javy do sleuthkit
121 Group:          Development/Languages/Java
122 Requires:       %{name} = %{version}-%{release}
123
124 %description java
125 Java bindings for sleuthkit.
126
127 %description java -l pl.UTF-8
128 Dowiązania Javy do sleuthkit.
129
130 %prep
131 %setup -q
132 sed -i -e 's/-static//' {samples,tests,tools/*tools}/Makefile.in
133
134 %build
135 %configure \
136         %{!?with_aff:--without-afflib}
137
138 sed -i -e 's/^\(LIBS = -lewf\)/\1 -ldl -lpthread/' {tools/autotools,tsk}/Makefile
139 %{__make}
140
141 %install
142 rm -rf $RPM_BUILD_ROOT
143
144 %{__make} install \
145      DESTDIR=$RPM_BUILD_ROOT
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %files
151 %defattr(644,root,root,755)
152 %doc API-CHANGES.txt ChangeLog.txt NEWS.txt README.md licenses/*
153 %attr(755,root,root) %{_bindir}/*
154 %{_datadir}/tsk
155 %{_mandir}/man1/*
156
157 %files libs
158 %defattr(644,root,root,755)
159 %attr(755,root,root) %{_libdir}/libtsk.so.*.*.*
160 %attr(755,root,root) %{_libdir}/libtsk_jni.so.*.*.*
161 %attr(755,root,root) %ghost %{_libdir}/libtsk.so.13
162 %attr(755,root,root) %ghost %{_libdir}/libtsk_jni.so.0
163
164 %files devel
165 %defattr(644,root,root,755)
166 %attr(755,root,root) %{_libdir}/libtsk.so
167 %attr(755,root,root) %{_libdir}/libtsk_jni.so
168 %{_libdir}/libtsk.la
169 %{_libdir}/libtsk_jni.la
170 %{_includedir}/tsk
171
172 %files static
173 %defattr(644,root,root,755)
174 %{_libdir}/libtsk.a
175 %{_libdir}/libtsk_jni.a
176
177
178 %files java
179 %defattr(644,root,root,755)
180 %{_javadir}/%{name}-%{version}.jar
This page took 0.397514 seconds and 3 git commands to generate.