]> git.pld-linux.org Git - SPECS.git/blob - slack-desktop.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / slack-desktop.spec
1 # TODO
2 # - src.rpm specifies (is it correct? - link is 404):
3 #   URL - https://github.com/tinyspeck/slack-winssb.git
4 #   License - MIT
5 # - it's based on atom
6
7 Summary:        Desktop client for Slack
8 Name:           slack-desktop
9 Version:        2.9.0
10 Release:        1
11 # slack support response about redistributing it in pld linux:
12 # > In order to ensure we have the best experience for as many folks as possible,
13 # > we'd like our customers to obtain the client form us.
14 License:        not redistributable
15 Group:          X11/Applications
16 # Source0Download: https://slack.com/downloads/linux
17 Source0:        https://downloads.slack-edge.com/linux_releases/slack-%{version}-0.1.fc21.x86_64.rpm
18 # NoSource0-md5:        3458af62001d0af8afab44c850623133
19 NoSource:       0
20 Patch0:         desktop.patch
21 URL:            https://slack.com/
22 BuildRequires:  rpm-utils
23 BuildRequires:  rpmbuild(macros) >= 1.596
24 Requires:       desktop-file-utils
25 ExclusiveArch:  %{x8664}
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         _appdir         %{_prefix}/lib/%{name}
29
30 %description
31 Get full access to your messages and archives, upload files easily,
32 and receive notifications whether you're at your desk or on the go.
33
34 %prep
35 %setup -qcT
36 SOURCE=%{S:0}
37
38 version=$(rpm -qp --nodigest --nosignature --qf '%{V}' $SOURCE)
39 test version:${version} = version:%{version}
40 rpm2cpio $SOURCE | cpio -i -d
41
42 mv usr/lib/slack .
43 mv usr/share/pixmaps/* .
44 mv usr/share/applications/* .
45 mv slack/LICENSE* .
46
47 %ifarch linux
48 rm -v resources/*/*/lib/*.dll
49 %endif
50
51 %patch0 -p1
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 install -d $RPM_BUILD_ROOT{%{_bindir},%{_appdir},%{_desktopdir},%{_pixmapsdir}}
56
57 cp -a slack/* $RPM_BUILD_ROOT%{_appdir}
58 ln -s %{_appdir}/slack $RPM_BUILD_ROOT%{_bindir}
59
60 cp -p slack.desktop $RPM_BUILD_ROOT%{_desktopdir}
61 cp -p slack.png $RPM_BUILD_ROOT%{_pixmapsdir}
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %post
67 %update_desktop_database
68
69 %postun
70 %update_desktop_database
71
72 %files
73 %defattr(644,root,root,755)
74 %doc LICENSE
75 %attr(755,root,root) %{_bindir}/slack
76 %{_desktopdir}/slack.desktop
77 %{_pixmapsdir}/slack.png
78 %dir %{_appdir}
79 %{_appdir}/version
80 %{_appdir}/*.bin
81 %{_appdir}/*.pak
82 %{_appdir}/icudtl.dat
83 %attr(755,root,root) %{_appdir}/slack
84 %attr(755,root,root) %{_appdir}/libCallsCore.so
85 %attr(755,root,root) %{_appdir}/libffmpeg.so
86 %attr(755,root,root) %{_appdir}/libnode.so
87
88 %{_appdir}/locales
89
90 %dir %{_appdir}/resources
91 %{_appdir}/resources/app.asar
92 %{_appdir}/resources/electron.asar
93
94 # too many files to list, assume file permissions
95 %defattr(-,root,root,-)
96 %{_appdir}/resources/app.asar.unpacked
This page took 0.495352 seconds and 3 git commands to generate.