]> git.pld-linux.org Git - SPECS.git/blob - skype-tools.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / skype-tools.spec
1 # TODO
2 # - package: http://code.google.com/p/python-twitter/
3 # - package for old api
4 # - find_chat.py, show_edited_chats.py use old api (skype_api.py)
5 Summary:        Command-line tools for Skype
6 Name:           skype-tools
7 Version:        0.11
8 Release:        8
9 License:        GPL
10 Group:          Development/Languages/Python
11 Source0:        http://www.oberle.org/skype_tools-%{version}.tar.gz
12 # Source0-md5:  4204fa0441034c296d11b37e139e7660
13 URL:            http://www.oberle.org/skype_linux_tools
14 BuildRequires:  rpm-pythonprov
15 BuildRequires:  sed >= 4.0
16 Requires:       python-skype >= 1.0.31.0
17 Requires:       skype >= 1.4.0.64
18 Suggests:       python-twitter
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 The package provided here contains a set of command-line tools for
24 Skype Linux to do various things that cannot be done with the user
25 interface.
26
27 %prep
28 %setup -q -n skype_linux_tools
29
30 install -d apis
31 # use external deps
32 mv skype_api.py twitter.py apis
33
34 # for rpm autodeps
35 %{__sed} -i -e '1s,#!.*python,#!%{__python},' *.py
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39 install -d $RPM_BUILD_ROOT%{_bindir}
40 for a in *.py; do
41         p=$(basename $a .py)
42         install -p $a $RPM_BUILD_ROOT%{_bindir}/skype-$(echo $p | tr _ -)
43 done
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %files
49 %defattr(644,root,root,755)
50 %doc README Changelog
51 %attr(755,root,root) %{_bindir}/skype-*
This page took 0.392136 seconds and 3 git commands to generate.