]> git.pld-linux.org Git - SPECS.git/blob - skipfish.spec
SPECS updated Tue 30 Apr 15:13:02 CEST 2024
[SPECS.git] / skipfish.spec
1 %define         subver  b
2 %define         rel     2
3 Summary:        Web application security scanner
4 Name:           skipfish
5 Version:        2.10
6 Release:        0.%{subver}.%{rel}
7 License:        Apache v2.0
8 Group:          Applications/Networking
9 Source0:        http://skipfish.googlecode.com/files/%{name}-%{version}%{subver}.tgz
10 # Source0-md5:  8edf6092f3d1835cb4a381b7a723db8a
11 URL:            http://code.google.com/p/skipfish/
12 BuildRequires:  libidn-devel
13 BuildRequires:  openssl-devel
14 BuildRequires:  pcre-devel
15 BuildRequires:  sed >= 4.0
16 BuildRequires:  zlib-devel
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 A fully automated, active web application security reconnaissance
21 tool.
22
23 Key features:
24 - High speed: pure C code, highly optimized HTTP handling, minimal CPU
25   footprint - easily achieving 2000 requests per second with responsive
26   targets.
27 - Ease of use: heuristics to support a variety of quirky web
28   frameworks and mixed-technology sites, with automatic learning
29   capabilities, on-the-fly wordlist creation, and form autocompletion.
30 - Cutting-edge security logic: high quality, low false positive,
31   differential security checks, capable of spotting a range of subtle
32   flaws, including blind injection vectors.
33
34 %prep
35 %setup -q -n %{name}-%{version}%{subver}
36
37 %{__sed} -i -e 's,-O3,$(OPTCFLAGS),' Makefile
38 %{__sed} -i -e 's,-L/usr/local/lib/ -L/opt/local/lib,$(OPTLDFLAGS),' Makefile
39 %{__sed} -i -e 's,"assets","%{_datadir}/%{name}/assets",' src/config.h
40 %{__sed} -i -e 's,"signatures/,"%{_sysconfdir}/%{name}/,' src/config.h
41 %{__sed} -i -e 's,signatures/,%{_datadir}/%{name}/signatures/,' signatures/signatures.conf
42
43 %build
44 %{__make} \
45         CC="%{__cc}" \
46         OPTCFLAGS="%{rpmcflags} %{rpmcppflags}" \
47         OPTLDFLAGS="%{rpmldflags}"
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_datadir}/%{name}/{,signatures},%{_mandir}/man1}
52
53 install -p %{name} $RPM_BUILD_ROOT%{_bindir}
54 cp -a doc/%{name}.1 $RPM_BUILD_ROOT%{_mandir}/man1
55 cp -a signatures/signatures.conf $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
56 cp -ar assets dictionaries $RPM_BUILD_ROOT%{_datadir}/%{name}
57 cp -ar signatures/*.sigs $RPM_BUILD_ROOT%{_datadir}/%{name}/signatures
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc ChangeLog README config/example.conf doc/*.txt
65 %attr(755,root,root) %{_bindir}/skipfish
66 %dir %{_sysconfdir}/%{name}
67 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/signatures.conf
68 %dir %{_datadir}/%{name}
69 %{_datadir}/%{name}/assets
70 %{_datadir}/%{name}/dictionaries
71 %{_datadir}/%{name}/signatures
72 %{_mandir}/man1/%{name}.1*
This page took 0.096061 seconds and 3 git commands to generate.