]> git.pld-linux.org Git - packages/skipfish.git/blob - skipfish.spec
94d37ddacc154cd2d5ed7d08c5ffae0c0f51a3d6
[packages/skipfish.git] / skipfish.spec
1 %define         subver  b
2 %define         rel             1
3 Summary:        Web application security scanner
4 Name:           skipfish
5 Version:        1.70
6 Release:        0.%{subver}.%{rel}
7 License:        Apache v2.0
8 Group:          Applications/Networking
9 Source0:        http://skipfish.googlecode.com/files/%{name}-%{version}%{subver}.tgz
10 # Source0-md5:  94c946e51160e7ee24a0e2f2cbe599a4
11 URL:            http://code.google.com/p/skipfish/
12 BuildRequires:  libidn-devel
13 BuildRequires:  openssl-devel
14 BuildRequires:  sed >= 4.0
15 BuildRequires:  zlib-devel
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 A fully automated, active web application security reconnaissance
20 tool.
21
22 Key features:
23 - High speed: pure C code, highly optimized HTTP handling, minimal CPU
24   footprint - easily achieving 2000 requests per second with responsive
25   targets.
26 - Ease of use: heuristics to support a variety of quirky web
27   frameworks and mixed-technology sites, with automatic learning
28   capabilities, on-the-fly wordlist creation, and form autocompletion.
29 - Cutting-edge security logic: high quality, low false positive,
30   differential security checks, capable of spotting a range of subtle
31   flaws, including blind injection vectors.
32
33 %prep
34 %setup -q -n %{name}-%{version}%{subver}
35
36 %{__sed} -i -e 's,-O3,$(OPTCFLAGS),' Makefile
37 %{__sed} -i -e 's,-L/usr/local/lib/ -L/opt/local/lib,$(OPTLDFLAGS),' Makefile
38
39 %build
40 %{__make} \
41         CC="%{__cc}" \
42         OPTCFLAGS="%{rpmcflags}" \
43         OPTLDFLAGS="%{rpmldflags}"
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 install -d $RPM_BUILD_ROOT%{_bindir}
48 install -p %{name} $RPM_BUILD_ROOT%{_bindir}
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc ChangeLog README
56 %attr(755,root,root) %{_bindir}/skipfish
This page took 0.051021 seconds and 2 git commands to generate.