]> git.pld-linux.org Git - packages/sipp.git/blob - sipp.spec
- md5
[packages/sipp.git] / sipp.spec
1
2 %bcond_with     options_is_ping # make sipp treat OPTIONS same as PING
3                                 # changes sipp behaviour, but that is
4                                 # what everybody use for 'pinging'
5
6 Summary:        SIPp - a performance testing tool for the SIP protocol
7 Name:           sipp
8 Version:        3.5.1
9 Release:        1
10 License:        GPL v2+ except two files under BSD
11 Group:          Applications
12 Source0:        https://github.com/SIPp/sipp/releases/download/v%{version}/%{name}-%{version}.tar.gz
13 # Source0-md5:  c14e4c84975337ce952f03a38ddba7ec
14 Patch0:         %{name}-OPTIONS_is_ping.patch
15 URL:            http://sipp.sourceforge.net/
16 BuildRequires:  gsl-devel
17 BuildRequires:  libpcap-devel
18 BuildRequires:  libstdc++-devel
19 BuildRequires:  ncurses-devel
20 BuildRequires:  openssl-devel
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 SIPp is a performance testing tool for the SIP protocol. It includes a
25 few basic SipStone user agent scenarios (UAC and UAS) and establishes
26 and releases multiple calls with the INVITE and BYE methods. It can
27 also reads XML scenario files describing any performance testing
28 configuration. It features the dynamic display of statistics about
29 running tests (call rate, round trip delay, and message statistics),
30 periodic CSV statistics dumps, TCP and UDP over multiple sockets or
31 multiplexed with retransmission management, regular expressions and
32 variables in scenario files, and dynamically adjustable call rates.
33
34 SIPp can be used to test many real SIP equipements like SIP proxies,
35 B2BUAs, SIP media servers, SIP/x gateways, SIP PBX, ... It is also
36 very useful to emulate thousands of user agents calling your SIP
37 system.
38
39 %prep
40 %setup -q
41 %{?with_options_is_ping:%patch0 -p1}
42
43 %build
44 %configure \
45         --disable-silent-rules \
46         --enable-epoll \
47         --with-openssl \
48         --with-pcap \
49         --with-sctp \
50         --with-gsl
51 %{__make}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc CHANGES.md FAQ.md README.md THANKS
65 %attr(755,root,root) %{_bindir}/sipp
66 %{_mandir}/man1/sipp.1*
This page took 0.077927 seconds and 4 git commands to generate.