]> git.pld-linux.org Git - packages/sipp.git/blob - sipp.spec
- fix build
[packages/sipp.git] / sipp.spec
1 #
2 Summary:        SIPp - a performance testing tool for the SIP protocol
3 Name:           sipp
4 Version:        3.0
5 Release:        1
6 License:        GPL v2+ except two files under BSD
7 Group:          Applications
8 Source0:        http://dl.sourceforge.net/sipp/%{name}-%{version}.src.tar.gz
9 # Source0-md5:  31906c63eb5efa09e0b148c27435cdac
10 Patch0:         %{name}-headers.patch
11 URL:            http://sipp.sourceforge.net/
12 BuildRequires:  libpcap-devel
13 BuildRequires:  libstdc++-devel
14 BuildRequires:  ncurses-devel
15 BuildRequires:  openssl-devel
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 SIPp is a performance testing tool for the SIP protocol. It includes a
20 few basic SipStone user agent scenarios (UAC and UAS) and establishes
21 and releases multiple calls with the INVITE and BYE methods. It can
22 also reads XML scenario files describing any performance testing
23 configuration. It features the dynamic display of statistics about
24 running tests (call rate, round trip delay, and message statistics),
25 periodic CSV statistics dumps, TCP and UDP over multiple sockets or
26 multiplexed with retransmission management, regular expressions and
27 variables in scenario files, and dynamically adjustable call rates.
28
29 SIPp can be used to test many real SIP equipements like SIP proxies,
30 B2BUAs, SIP media servers, SIP/x gateways, SIP PBX, ... It is also
31 very useful to emulate thousands of user agents calling your SIP
32 system.
33
34 %prep
35 %setup -q -n %{name}-%{version}.src
36 %patch0 -p1
37
38 %build
39
40 %{__make} pcapplay_ossl \
41         CC="%{__cc}" \
42         CPP="%{__cxx}" \
43         CCLINK="%{__cxx}" \
44         EXTRACFLAGS="%{rpmcflags}" \
45         EXTRACPPFLAGS="%{rpmcxxflags}" \
46         EXTRALFLAGS="%{rpmldflags}" \
47         INCDIR="-I. -I/usr/include/ncurses"
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51 install -d $RPM_BUILD_ROOT%{_bindir}
52 install sipp $RPM_BUILD_ROOT%{_bindir}
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc LICENSE.txt MEDIA.txt README.txt pcap tools
60 %attr(755,root,root) %{_bindir}/*
This page took 0.182105 seconds and 4 git commands to generate.