]> git.pld-linux.org Git - packages/sipp.git/blob - sipp.spec
6e9f59f3fa5c3d377a97828793579743c70933cc
[packages/sipp.git] / sipp.spec
1
2 %bcond_with     options_is_ping # make sipp treat OPTIONS same as PING
3                                 # changes sipp behaviour, but that is
4                                 # what everybody use for 'pinging'
5
6 Summary:        SIPp - a performance testing tool for the SIP protocol
7 Name:           sipp
8 Version:        3.3
9 Release:        1
10 License:        GPL v2+ except two files under BSD
11 Group:          Applications
12 Source0:        http://dl.sourceforge.net/sipp/%{name}-%{version}.tar.xz
13 # Source0-md5:  f0c4f472fa86de8a528cb91616323617
14 Patch0:         %{name}-headers.patch
15 Patch1:         %{name}-sprintf.patch
16 Patch2:         %{name}-stats_crash.patch
17 Patch3:         %{name}-OPTIONS_is_ping.patch
18 URL:            http://sipp.sourceforge.net/
19 BuildRequires:  libpcap-devel
20 BuildRequires:  libstdc++-devel
21 BuildRequires:  ncurses-devel
22 BuildRequires:  openssl-devel
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 SIPp is a performance testing tool for the SIP protocol. It includes a
27 few basic SipStone user agent scenarios (UAC and UAS) and establishes
28 and releases multiple calls with the INVITE and BYE methods. It can
29 also reads XML scenario files describing any performance testing
30 configuration. It features the dynamic display of statistics about
31 running tests (call rate, round trip delay, and message statistics),
32 periodic CSV statistics dumps, TCP and UDP over multiple sockets or
33 multiplexed with retransmission management, regular expressions and
34 variables in scenario files, and dynamically adjustable call rates.
35
36 SIPp can be used to test many real SIP equipements like SIP proxies,
37 B2BUAs, SIP media servers, SIP/x gateways, SIP PBX, ... It is also
38 very useful to emulate thousands of user agents calling your SIP
39 system.
40
41 %prep
42 %setup -q
43 %patch0 -p1
44 %patch1 -p1
45 %patch2 -p1
46 %{?with_options_is_ping:%patch3 -p1}
47
48 %build
49
50 %{__make} pcapplay_ossl \
51         CC="%{__cc}" \
52         CPP="%{__cxx}" \
53         CCLINK="%{__cxx}" \
54         EXTRACFLAGS="%{rpmcflags}" \
55         EXTRACPPFLAGS="%{rpmcxxflags}" \
56         EXTRALFLAGS="%{rpmldflags}" \
57         INCDIR="-I. -I/usr/include/ncurses"
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61 install -d $RPM_BUILD_ROOT%{_bindir}
62 install sipp $RPM_BUILD_ROOT%{_bindir}
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc LICENSE.txt MEDIA.txt README.txt pcap tools
70 %attr(755,root,root) %{_bindir}/*
This page took 0.050349 seconds and 3 git commands to generate.