]> git.pld-linux.org Git - SPECS.git/blob - simplescreenrecorder.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / simplescreenrecorder.spec
1 %ifarch %{ix86} %{x8664} x32
2 %define         with_gl         1
3 %endif
4
5 %define         qtver   5.7
6 Summary:        Screen recorder for Linux
7 Summary(pl.UTF-8):      Nagrywarka ekranu dla Linuksa
8 Name:           simplescreenrecorder
9 Version:        0.4.3
10 Release:        1
11 License:        GPL v3
12 Group:          Applications
13 Source0:        https://github.com/MaartenBaert/ssr/archive/%{version}/ssr-%{version}.tar.gz
14 # Source0-md5:  3f8337db93f5a6a3f64525e7249815d6
15 Patch0:         build.patch
16 URL:            http://www.maartenbaert.be/simplescreenrecorder/
17 BuildRequires:  Mesa-libGL-devel
18 BuildRequires:  Mesa-libGLU-devel
19 BuildRequires:  Qt5Core-devel >= %{qtver}
20 BuildRequires:  Qt5Gui-devel >= %{qtver}
21 BuildRequires:  Qt5Widgets-devel >= %{qtver}
22 BuildRequires:  Qt5X11Extras-devel >= %{qtver}
23 BuildRequires:  alsa-lib-devel
24 BuildRequires:  cmake >= 3.1
25 BuildRequires:  ffmpeg-devel
26 BuildRequires:  jack-audio-connection-kit-devel
27 BuildRequires:  libv4l-devel
28 BuildRequires:  pulseaudio-devel
29 BuildRequires:  qt5-build >= %{qtver}
30 BuildRequires:  qt5-linguist >= %{qtver}
31 BuildRequires:  rpmbuild(macros) >= 1.742
32 BuildRequires:  xorg-lib-libX11-devel
33 BuildRequires:  xorg-lib-libXext-devel
34 BuildRequires:  xorg-lib-libXfixes-devel
35 BuildRequires:  xorg-lib-libXi-devel
36 Requires:       Qt5Core >= %{qtver}
37 Requires:       Qt5Gui >= %{qtver}
38 Requires:       Qt5Gui-platform-xcb
39 Requires:       Qt5Widgets >= %{qtver}
40 Requires:       Qt5X11Extras >= %{qtver}
41 %if %{with gl}
42 Suggests:       %{name}-glinject = %{version}-%{release}
43 %endif
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 SimpleScreenRecorder is a screen recorder for Linux. Despite the name,
48 this program is actually quite complex. It's 'simple' in the sense
49 that it's easier to use than ffmpeg/avconv or VLC :).
50
51 %package glinject
52 Summary:        SimpleScreenRecorder - wrapper library for recording OpenGL
53 Group:          Applications
54
55 %description glinject
56 A wrapper library and a script to inject screen recording calls into
57 OpenGL applications, for use with the SimpleScreenRecorder.
58
59 %prep
60 %setup -q -n ssr-%{version}
61 %patch0 -p1
62
63 %build
64 %cmake \
65         -DLRELEASE=/usr/bin/lrelease-qt5 \
66         %{cmake_on_off gl WITH_GLINJECT} \
67         %{cmake_on_off gl WITH_OPENGL_RECORDING} \
68         -DWITH_JACK=ON \
69         -DWITH_PULSEAUDIO=ON \
70         -DWITH_QT5=ON
71
72 %{__make}
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76
77 %{__make} install \
78         DESTDIR=$RPM_BUILD_ROOT
79
80 %find_lang %{name} --with-qm
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files -f %{name}.lang
86 %defattr(644,root,root,755)
87 %doc AUTHORS.md CHANGELOG.md README.md *.txt
88 %attr(755,root,root) %{_bindir}/simplescreenrecorder
89 %dir %{_datadir}/simplescreenrecorder
90 %{_datadir}/simplescreenrecorder/output-profiles
91 %dir %{_datadir}/simplescreenrecorder/translations
92 %{_mandir}/man1/simplescreenrecorder.1*
93 %{_iconsdir}/*/*/apps/simplescreenrecorder*.png
94 %{_iconsdir}/hicolor/scalable/apps/simplescreenrecorder*.svg
95 %{_desktopdir}/simplescreenrecorder.desktop
96 %{_datadir}/metainfo/simplescreenrecorder.metainfo.xml
97
98 %if %{with gl}
99 %files glinject
100 %defattr(644,root,root,755)
101 %attr(755,root,root) %{_bindir}/ssr-glinject
102 %attr(755,root,root) %{_libdir}/libssr-glinject.so
103 %{_mandir}/man1/ssr-glinject.1*
104 %endif
This page took 0.287718 seconds and 3 git commands to generate.