]> git.pld-linux.org Git - packages/shishi.git/blob - shishi.spec
- updated to 0.0.10
[packages/shishi.git] / shishi.spec
1 # TODO:
2 # - init scripts for shishid
3 Summary:        Shishi - an implementation of RFC 1510(bis) (Kerberos V5 authentication)
4 Summary(pl):    Shishi - implementacja RFC 1510(bis) (uwierzytelniania Kerberos V5)
5 Name:           shishi
6 Version:        0.0.10
7 Release:        0.1
8 Epoch:          0
9 License:        GPL
10 Group:          Libraries
11 Source0:        http://josefsson.org/shishi/releases/%{name}-%{version}.tar.gz
12 # Source0-md5:  ed33acbf9fdd1f76edf522afcaebb94f
13 Patch0:         %{name}-info.patch
14 URL:            http://josefsson.org/shishi/
15 BuildRequires:  autoconf >= 2.59
16 BuildRequires:  automake >= 1.8
17 BuildRequires:  gnutls-devel >= 0.8.8
18 BuildRequires:  gtk-doc >= 1.1
19 BuildRequires:  libgcrypt-devel >= 1.1.43
20 BuildRequires:  libidn-devel >= 0.1.0
21 BuildRequires:  libtasn1-devel >= 0.2.5
22 BuildRequires:  libtool >= 2:1.5
23 BuildRequires:  pam-devel
24 BuildRequires:  texinfo
25 Requires(post,postun):  /sbin/ldconfig
26 # should be moved to shishi-enabled inetutils-* if such packages would exist
27 Obsoletes:      shishi-telnet
28 Obsoletes:      shishi-telnetd
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         _libexecdir     %{_sbindir}
32 %define         _localstatedir  %{_var}/lib
33
34 %description
35 Shishi is a (still incomplete) implementation of the RFC 1510(bis)
36 network authentication system (known as Kerberos V5). Shishi can be
37 used to authenticate users in distributed systems.
38
39 Shishi contains a library ('libshishi') that can be used by
40 application developers to add support for RFC 1510 and a command line
41 utility ('shishi') that is used by users to interface with the
42 library, to acquire and manage tickets (and more). Included are also
43 a TELNET client and server (based on GNU InetUtils) for remote network
44 login, and a PAM module for host security. A rudimentary key
45 distribution center (KDC) daemon is included.
46
47 %description -l pl
48 Shishi to (nadal niekompletna) implementacja sieciowego systemu
49 uwierzytelniania RFC 1510(bis) (znanego jako Kerberos V5). Shishi mo¿e
50 byæ u¿ywane do uwierzytelniania u¿ytkowników w systemach
51 rozproszonych.
52
53 Shishi zawiera bibliotekê (libshishi), któr± programi¶ci mog±
54 wykorzystywaæ do dodawania obs³ugi RFC 1510 oraz narzêdzie dzia³aj±ce
55 z linii poleceñ (shishi), którym u¿ytkownicy mog± komunikowaæ siê z
56 bibliotek±, uzyskiwaæ i zarz±dzaæ biletami itp. Do³±czone s± tak¿e
57 klient i serwer TELNET (oparte na GNU InetUtils) do zdalnego logowania
58 oraz modu³ PAM do lokalnego modelu bezpieczeñstwa. Demon podstawowego
59 centrum dystrybucji kluczy (KDC) tak¿e jest za³±czony.
60
61 %package devel
62 Summary:        Header files for Shishi library
63 Summary(pl):    Pliki nag³ówkowe biblioteki Shishi
64 Group:          Development/Libraries
65 Requires:       %{name} = %{epoch}:%{version}
66 Requires:       gnutls-devel >= 0.8.8
67 Requires:       gtk-doc-common
68 Requires:       libgcrypt-devel >= 1.1.43
69 Requires:       libidn-devel >= 0.1.0
70 Requires:       libtasn1-devel >= 0.2.5
71
72 %description devel
73 Header files for Shishi library.
74
75 %description devel -l pl
76 Pliki nag³ówkowe biblioteki Shishi.
77
78 %package static
79 Summary:        Static Shishi library
80 Summary(pl):    Statyczna biblioteka Shishi
81 Group:          Development/Libraries
82 Requires:       %{name}-devel = %{epoch}:%{version}
83
84 %description static
85 Static Shishi library.
86
87 %description static -l pl
88 Statyczna biblioteka Shishi.
89
90 %package -n pam-pam_shishi
91 Summary:        PAM module for RFC 1510 (Kerberos V5) authentication
92 Summary(pl):    Modu³ PAM do uwierzytelniania RFC 1510 (Kerberos V5)
93 Group:          Libraries
94 Requires:       %{name} = %{epoch}:%{version}
95 Obsoletes:      pam_shishi
96
97 %description -n pam-pam_shishi
98 PAM module for RFC 1510 (Kerberos V5) authentication.
99
100 %description -n pam-pam_shishi -l pl
101 Modu³ PAM do uwierzytelniania RFC 1510 (Kerberos V5).
102
103 %prep
104 %setup -q
105 %patch0 -p1
106
107 # we don't have libtool 1.5a
108 %{__perl} -pi -e 's/AC_LIBTOOL_TAGS//' configure.ac
109 # incompatible with ksh
110 rm -f m4/libtool.m4
111
112 %build
113 # blegh, lt incompatible with ksh - must rebuild
114 %{__libtoolize}
115 %{__aclocal} -I gl/m4 -I m4
116 %{__autoconf}
117 %{__autoheader}
118 %{__automake}
119 %configure
120
121 %{__make}
122 %{__make} extra
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126
127 %{__make} install \
128         DESTDIR=$RPM_BUILD_ROOT
129
130 %{__make} -C extra install \
131         DESTDIR=$RPM_BUILD_ROOT
132
133 install -d $RPM_BUILD_ROOT/lib/security
134 mv -f $RPM_BUILD_ROOT%{_libdir}/pam_shishi.so* $RPM_BUILD_ROOT/lib/security
135 rm -f $RPM_BUILD_ROOT%{_libdir}/pam_shishi.{la,a}
136
137 %find_lang %{name}
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
141
142 %post
143 /sbin/ldconfig
144 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
145
146 %postun
147 /sbin/ldconfig
148 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
149
150 %files -f %{name}.lang
151 %defattr(644,root,root,755)
152 %doc AUTHORS ChangeLog NEWS README* THANKS
153 %attr(755,root,root) %{_bindir}/shisa
154 %attr(755,root,root) %{_bindir}/shishi
155 %attr(755,root,root) %{_sbindir}/shishid
156 %attr(755,root,root) %{_libdir}/libshis*.so.*.*.*
157 %dir %{_sysconfdir}/shishi
158 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/shishi/shisa.conf
159 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/shishi/shishi.conf
160 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/shishi/shishi.keys
161 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/shishi/shishi.skel
162 %attr(700,root,root) %dir %{_localstatedir}/%{name}
163 %{_mandir}/man1/shisa.1*
164 %{_mandir}/man1/shishi.1*
165 %{_mandir}/man1/shishid.1*
166 %{_infodir}/shishi.info*
167
168 %files devel
169 %defattr(644,root,root,755)
170 %attr(755,root,root) %{_libdir}/libshis*.so
171 %{_libdir}/libshis*.la
172 %{_includedir}/shis*.h
173 %{_pkgconfigdir}/shishi.pc
174 %{_mandir}/man3/*
175
176 %files static
177 %defattr(644,root,root,755)
178 %{_libdir}/libshis*.a
179
180 %files -n pam-pam_shishi
181 %defattr(644,root,root,755)
182 %attr(755,root,root) /lib/security/pam_shishi.so*
This page took 0.081954 seconds and 4 git commands to generate.