]> git.pld-linux.org Git - packages/shishi.git/blob - shishi.spec
- pkgconfig no longer used by configure
[packages/shishi.git] / shishi.spec
1 # TODO:
2 # - init scripts for shishid and shishi-telnetd
3 Summary:        Shishi - an implementation of RFC 1510(bis) (Kerberos V5 authentication)
4 Summary(pl):    Shishi - implementacja RFC 1510(bis) (uwierzytelniania Kerberos V5)
5 Name:           shishi
6 Version:        0.0.8
7 Release:        0.1
8 Epoch:          0
9 License:        GPL
10 Group:          Libraries
11 Source0:        http://josefsson.org/shishi/releases/%{name}-%{version}.tar.gz
12 # Source0-md5:  49d854d20e9ebe7d85688eeb6e63859e
13 Patch0:         %{name}-info.patch
14 URL:            http://josefsson.org/shishi/
15 BuildRequires:  gnutls-devel >= 0.8.8
16 BuildRequires:  gtk-doc >= 0.6
17 BuildRequires:  libgcrypt-devel >= 1.1.43
18 BuildRequires:  libidn-devel >= 0.1.0
19 BuildRequires:  libtasn1-devel >= 0.2.5
20 BuildRequires:  pam-devel
21 BuildRequires:  texinfo
22 Requires(post,postun):  /sbin/ldconfig
23 # should be moved to shishi-enabled inetutils-* if such packages would exist
24 Obsoletes:      shishi-telnet
25 Obsoletes:      shishi-telnetd
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         _libexecdir     %{_sbindir}
29
30 %description
31 Shishi is a (still incomplete) implementation of the RFC 1510(bis)
32 network authentication system (known as Kerberos V5). Shishi can be
33 used to authenticate users in distributed systems.
34
35 Shishi contains a library ('libshishi') that can be used by
36 application developers to add support for RFC 1510 and a command line
37 utility ('shishi') that is used by users to interface with the
38 library, to acquire and manage tickets (and more). Included are also
39 a TELNET client and server (based on GNU InetUtils) for remote network
40 login, and a PAM module for host security. A rudimentary key
41 distribution center (KDC) daemon is included.
42
43 %description -l pl
44 Shishi to (nadal niekompletna) implementacja sieciowego systemu
45 uwierzytelniania RFC 1510(bis) (znanego jako Kerberos V5). Shishi mo¿e
46 byæ u¿ywane do uwierzytelniania u¿ytkowników w systemach
47 rozproszonych.
48
49 Shishi zawiera bibliotekê (libshishi), któr± programi¶ci mog±
50 wykorzystywaæ do dodawania obs³ugi RFC 1510 oraz narzêdzie dzia³aj±ce
51 z linii poleceñ (shishi), którym u¿ytkownicy mog± komunikowaæ siê z
52 bibliotek±, uzyskiwaæ i zarz±dzaæ biletami itp. Do³±czone s± tak¿e
53 klient i serwer TELNET (oparte na GNU InetUtils) do zdalnego logowania
54 oraz modu³ PAM do lokalnego modelu bezpieczeñstwa. Demon podstawowego
55 centrum dystrybucji kluczy (KDC) tak¿e jest za³±czony.
56
57 %package devel
58 Summary:        Header files for Shishi library
59 Summary(pl):    Pliki nag³ówkowe biblioteki Shishi
60 Group:          Development/Libraries
61 Requires:       %{name} = %{epoch}:%{version}
62 Requires:       gnutls-devel >= 0.8.8
63 Requires:       gtk-doc-common
64 Requires:       libgcrypt-devel >= 1.1.43
65 Requires:       libidn-devel >= 0.1.0
66 Requires:       libtasn1-devel >= 0.2.5
67
68 %description devel
69 Header files for Shishi library.
70
71 %description devel -l pl
72 Pliki nag³ówkowe biblioteki Shishi.
73
74 %package static
75 Summary:        Static Shishi library
76 Summary(pl):    Statyczna biblioteka Shishi
77 Group:          Development/Libraries
78 Requires:       %{name}-devel = %{epoch}:%{version}
79
80 %description static
81 Static Shishi library.
82
83 %description static -l pl
84 Statyczna biblioteka Shishi.
85
86 %package -n pam-pam_shishi
87 Summary:        PAM module for RFC 1510 (Kerberos V5) authentication
88 Summary(pl):    Modu³ PAM do uwierzytelniania RFC 1510 (Kerberos V5)
89 Group:          Libraries
90 Requires:       %{name} = %{epoch}:%{version}
91 Obsoletes:      pam_shishi
92
93 %description -n pam-pam_shishi
94 PAM module for RFC 1510 (Kerberos V5) authentication.
95
96 %description -n pam-pam_shishi -l pl
97 Modu³ PAM do uwierzytelniania RFC 1510 (Kerberos V5).
98
99 %prep
100 %setup -q
101 %patch0 -p1
102
103 %build
104 %configure \
105         --with-html-dir=%{_gtkdocdir}
106
107 %{__make}
108 %{__make} extra
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112
113 %{__make} install \
114         DESTDIR=$RPM_BUILD_ROOT
115
116 %{__make} -C extra install \
117         DESTDIR=$RPM_BUILD_ROOT
118
119 install -d $RPM_BUILD_ROOT/lib/security
120 mv -f $RPM_BUILD_ROOT%{_libdir}/pam_shishi.so* $RPM_BUILD_ROOT/lib/security
121 rm -f $RPM_BUILD_ROOT%{_libdir}/pam_shishi.{la,a}
122
123 %find_lang %{name}
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %post
129 /sbin/ldconfig
130 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
131
132 %postun
133 /sbin/ldconfig
134 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
135
136 %files -f %{name}.lang
137 %defattr(644,root,root,755)
138 %doc ANNOUNCE AUTHORS ChangeLog NEWS README* THANKS
139 %attr(755,root,root) %{_bindir}/shishi
140 %attr(755,root,root) %{_sbindir}/shishid
141 %attr(755,root,root) %{_libdir}/libshishi.so.*.*.*
142 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/shishi.conf
143 %{_datadir}/%{name}
144 %{_mandir}/man1/shishi.1*
145 %{_infodir}/shishi.info*
146
147 %files devel
148 %defattr(644,root,root,755)
149 %attr(755,root,root) %{_libdir}/libshishi.so
150 %{_libdir}/libshishi.la
151 %{_includedir}/shishi*.h
152 %{_pkgconfigdir}/shishi.pc
153 %{_mandir}/man3/*
154 %{_gtkdocdir}/shishi
155
156 %files static
157 %defattr(644,root,root,755)
158 %{_libdir}/libshishi.a
159
160 %files -n pam-pam_shishi
161 %defattr(644,root,root,755)
162 %attr(755,root,root) /lib/security/pam_shishi.so*
This page took 0.07495 seconds and 4 git commands to generate.