]> git.pld-linux.org Git - packages/shadow.git/blob - shadow.spec
- added default empty /etc/security/{chfn,chsh}.allow files
[packages/shadow.git] / shadow.spec
1 Summary:        Shadow password file utilities for Linux
2 Summary(de):    Shadow-Paßwortdatei-Dienstprogramme für Linux
3 Summary(fr):    Fichiers utilitaires pour Shadow password pour Linux
4 Summary(pl):    Narzêdzia do obs³ugi shadow passwords
5 Summary(tr):    Gölge parola dosyasý araçlarý
6 Name:           shadow
7 Version:        20001016
8 Release:        3
9 License:        BSD
10 Group:          Applications/System
11 Group(de):      Applikationen/System
12 Group(pl):      Aplikacje/System
13 Source0:        ftp://ftp.pld.org.pl/software/shadow/%{name}-%{version}.tar.gz
14 Source1:        %{name}-login.defs
15 Source2:        %{name}.useradd
16 Source3:        chage.pamd
17 Source4:        userdb.pamd
18 Source5:        chsh.pamd
19 Source6:        chfn.pamd
20 Source7:        passwd.pamd
21 Patch1:         %{name}-pld.patch
22 Patch2:         %{name}-utmpx.patch
23 BuildRequires:  pam-devel
24 BuildRequires:  autoconf
25 BuildRequires:  automake
26 BuildRequires:  gettext-devel
27 Provides:       shadow-utils
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29 Obsoletes:      shadow-utils
30 Obsoletes:      passwd
31
32 %description
33 This package includes the programs necessary to convert standard UNIX
34 password files to the shadow password format, as well as programs for
35 command-line management of the user's accounts.
36  - 'pwconv' converts everything to the shadow password format.
37  - 'pwunconv' unconverts from shadow passwords, generating a file in
38    the current directory called npasswd that is a standard UNIX password
39    file.
40  - 'pwck' checks the integrity of the password and shadow files.
41  - 'lastlog' prints out the last login times of all users.
42  - 'useradd', 'userdel' and 'usermod' for accounts management.
43  - 'groupadd', 'groupdel' and 'groupmod' for group management.
44
45 A number of man pages are also included that relate to these
46 utilities, and shadow passwords in general.
47
48 %description -l pl
49 Pakiet zawiera programy do obs³ugi shadow password. Zanjduj± siê w nim
50 programy do konwersji standardowego pliku hase³ do wersji shadow
51 password a tak¿e programy do zarz±danie kontami u¿ytkowników w
52 systemie
53  - 'pwconv' konwertuje do formatu shadow passwords
54  - 'pwunconv' konwertuje z shadow passwords do formatu standardowego
55    pliku hase³. W bierz±cym katalogu tworzy plik npasswd bêd±cy
56    standardowym plikiem z has³ami.
57  - 'lastlog' wy¶wietla czas logowanie u¿ytkowników
58  - 'userdel' i 'usermod' do zarz±dzania kontami u¿ytkowników.
59  - 'groupadd', 'groupdel' and 'groupmod' do zarz±dzania grupami
60
61 Ostrze¿enie:
62
63 Programy znajduj±ce siê w tym pakiecie s± niezbêdne do prawid³owej
64 pracy twojego systemu i podobnie jak pakiet z bibliotekami systemowymi
65 - glibc nigdy nie powinien zostaæ odinstalowany !
66
67 %prep
68 %setup -q 
69 %patch1 -p1 
70 %patch2 -p1 
71
72 %build
73 gettextize --copy --force
74 libtoolize --copy --force
75 aclocal
76 autoheader
77 autoconf
78 automake -a -c --foreign
79 %configure \
80         --disable-desrpc \
81         --with-libcrypt \
82         %{!?_without_static:--enable-static} \
83         %{!?_without_static:--disable-shared} \
84         %{?_without_static:--disable-static} \
85         %{?_without_static:--enable-shared} \
86         --with-libpam \
87         --with-md5crypt \
88         --with-nls \
89         --without-included-gettext 
90 %{__make}  
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94
95 %{__make} install DESTDIR=$RPM_BUILD_ROOT
96
97 install -d $RPM_BUILD_ROOT%{_sysconfdir}/{default,pam.d,security,skel}
98
99 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/login.defs
100 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/default/useradd
101 install %{SOURCE3} $RPM_BUILD_ROOT/etc/pam.d/chage
102 install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/shadow
103 install %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/chsh
104 install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/chfn
105 install %{SOURCE7} $RPM_BUILD_ROOT/etc/pam.d/passwd
106
107 :> $RPM_BUILD_ROOT%{_sysconfdir}/shadow
108 touch $RPM_BUILD_ROOT%{_sysconfdir}/security/{chfn,chsh}.allow
109
110 echo .so pwconv.8 > $RPM_BUILD_ROOT%{_mandir}/man8/pwunconv.8
111 echo .so pwconv.8 > $RPM_BUILD_ROOT%{_mandir}/man8/grpconv.8
112 echo .so pwconv.8 > $RPM_BUILD_ROOT%{_mandir}/man8/grpunconv.8
113
114 gzip -9nf doc/ANNOUNCE NEWS doc/README doc/README.linux doc/HOWTO
115
116 %find_lang %{name}
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %post
122 %{!?_without_static:#}/sbin/ldconfig
123 if [ ! -f /etc/shadow ]; then
124         %{_sbindir}/pwconv
125 fi
126
127 %{!?_without_static:#}%postun -p /sbin/ldconfig
128
129 %files -f %{name}.lang
130 %defattr(644,root,root,755)
131 %doc doc/*.gz
132
133 %attr(750,root,root) %dir %{_sysconfdir}/default
134 %attr(640,root,root) %config %verify(not size mtime md5) %{_sysconfdir}/default/*
135 %attr(640,root,root) %config %verify(not size mtime md5) /etc/pam.d/*
136 %attr(640,root,root) %config %verify(not size mtime md5) /etc/security/*
137
138 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/login.defs
139 %attr(400,root,root) %ghost %{_sysconfdir}/shadow
140
141 %dir /etc/skel
142
143 %{!?_without_static:#}%attr(755,root,root) /lib/lib*.so.*.*.*
144 %attr(755,root,root) %{_sbindir}/user*
145 %attr(755,root,root) %{_sbindir}/group*
146 %attr(755,root,root) %{_sbindir}/grpck
147 %attr(755,root,root) %{_sbindir}/pwck
148 %attr(755,root,root) %{_sbindir}/*conv
149 %attr(755,root,root) %{_sbindir}/chpasswd
150 %attr(755,root,root) %{_sbindir}/newusers
151 %attr(755,root,root) %{_sbindir}/mkpasswd
152 %attr(755,root,root) %{_bindir}/chage
153 %attr(4755,root,root) %{_bindir}/chfn
154 %attr(4755,root,root) %{_bindir}/chsh
155 %attr(4755,root,root) %{_bindir}/expiry
156 %attr(4755,root,root) %{_bindir}/passwd
157 %attr(4755,root,root) %{_bindir}/gpasswd
158 %attr(755,root,root) %{_bindir}/lastlog
159 %attr(755,root,root) %{_bindir}/faillog
160 %attr(755,root,root) %{_bindir}/sg
161
162 %{_mandir}/man1/gpasswd.*
163 %{_mandir}/man1/chage.*
164 %{_mandir}/man1/chfn.*
165 %{_mandir}/man1/chsh.*
166 %{_mandir}/man1/passwd.*
167 %{_mandir}/man5/login.defs.*
168 %{_mandir}/man5/passwd.*
169 %{_mandir}/man5/shadow.*
170 %{_mandir}/man5/porttime.*
171 %{_mandir}/man5/faillog.*
172 %{_mandir}/man8/faillog.*
173 %{_mandir}/man8/groupdel.*
174 %{_mandir}/man8/groupmod.*
175 %{_mandir}/man8/grpck.*
176 %{_mandir}/man8/grpconv.*
177 %{_mandir}/man8/logoutd.*
178 %{_mandir}/man8/mkpasswd.*
179 %{_mandir}/man8/newusers.*
180 %{_mandir}/man8/pwck.*
181 %{_mandir}/man8/pwunconv.*
182 %{_mandir}/man8/useradd.*
183 %{_mandir}/man8/userdel.*
184 %{_mandir}/man8/usermod.*
185 %{_mandir}/man8/lastlog.*
186 %{_mandir}/man8/pwconv.*
187 %{_mandir}/man8/chpasswd.*
188 %{_mandir}/man8/groupadd.*
189 %{_mandir}/man8/grpunconv.*
190 %{_mandir}/man8/shadowconfig.*
191
192 %lang(pl) %{_mandir}/pl/man1/chage.*
193 %lang(pl) %{_mandir}/pl/man1/gpasswd.*
194 %lang(pl) %{_mandir}/pl/man1/chfn.*
195 %lang(pl) %{_mandir}/pl/man1/chsh.*
196 %lang(pl) %{_mandir}/pl/man1/passwd.*
197 %lang(pl) %{_mandir}/pl/man5/faillog.*
198 %lang(pl) %{_mandir}/pl/man5/login.defs.*
199 %lang(pl) %{_mandir}/pl/man5/passwd.*
200 %lang(pl) %{_mandir}/pl/man5/porttime.*
201 %lang(pl) %{_mandir}/pl/man5/shadow.*
202 %lang(pl) %{_mandir}/pl/man8/chpasswd.*
203 %lang(pl) %{_mandir}/pl/man8/faillog.*
204 %lang(pl) %{_mandir}/pl/man8/groupadd.*
205 %lang(pl) %{_mandir}/pl/man8/groupdel.*
206 %lang(pl) %{_mandir}/pl/man8/groupmod.*
207 %lang(pl) %{_mandir}/pl/man8/grpck.*
208 %lang(pl) %{_mandir}/pl/man8/lastlog.*
209 %lang(pl) %{_mandir}/pl/man8/logoutd.*
210 %lang(pl) %{_mandir}/pl/man8/mkpasswd.*
211 %lang(pl) %{_mandir}/pl/man8/newusers.*
212 %lang(pl) %{_mandir}/pl/man8/pwck.*
213 %lang(pl) %{_mandir}/pl/man8/pwconv.*
214 %lang(pl) %{_mandir}/pl/man8/shadowconfig.*
215 %lang(pl) %{_mandir}/pl/man8/useradd.*
216 %lang(pl) %{_mandir}/pl/man8/userdel.*
217 %lang(pl) %{_mandir}/pl/man8/usermod.*
This page took 0.843116 seconds and 4 git commands to generate.