]> git.pld-linux.org Git - packages/serf.git/blob - serf.spec
- pl
[packages/serf.git] / serf.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # don't perform "make check"
4 #
5 Summary:        A high-performance asynchronous HTTP client library
6 Summary(pl.UTF-8):      Wysokowydajna biblioteka asynchronicznego klienta HTTP
7 Name:           serf
8 Version:        0.2.0
9 Release:        1
10 License:        Apache
11 Group:          Libraries
12 Source0:        http://serf.googlecode.com/files/%{name}-%{version}.tar.bz2
13 # Source0-md5:  cda4d1f871fbbad1b32ed8fd6a8149cc
14 URL:            http://code.google.com/p/serf/
15 BuildRequires:  apr-devel
16 BuildRequires:  apr-util-devel
17 BuildRequires:  openssl-devel >= 0.9.7d
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 The serf library is a C-based HTTP client library built upon the
22 Apache Portable Runtime (APR) library. It multiplexes connections,
23 running the read/write communication asynchronously. Memory copies and
24 transformations are kept to a minimum to provide high performance
25 operation.
26
27 %description -l pl.UTF-8
28 Biblioteka serf to napisana w C biblioteka klienta HTTP stworzona w
29 oparciu o bibliotekę Apache Portable Runtime (APR). Obsługuje
30 połączenia naprzemiennie, wywołując asynchronicznie komunikację
31 odczyt-zapis. Kopiowanie i transformacje w pamięci są ograniczone do
32 minimum w celu zapewnienia wydajnego działania.
33
34 %package devel
35 Summary:        Header files for serf
36 Summary(pl.UTF-8):      Pliki nagłówkowe serf
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}-%{release}
39 Requires:       apr-devel
40
41 %description devel
42 C header files for the serf library.
43
44 %description devel -l pl.UTF-8
45 Pliki nagłówkowe dla biblioteki serf.
46
47 %package static
48 Summary:        Static libraries for serf
49 Summary(pl.UTF-8):      Biblioteki statyczne serf
50 Group:          Development/Libraries
51 Requires:       %{name}-devel = %{version}-%{release}
52
53 %description static
54 Static serf libraries.
55
56 %description static -l pl.UTF-8
57 Statyczne biblioteki serf.
58
59 %prep
60 %setup -q
61
62 %build
63 %configure \
64         --with-apr=%{_prefix} \
65         --with-apr-util=%{_prefix} \
66         --with-openssl=%{_prefix}
67 %{__make}
68
69 %{?with_tests:%{__make} check}
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 %{__make} install \
75         DESTDIR=$RPM_BUILD_ROOT
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %post   -p /sbin/ldconfig
81 %postun -p /sbin/ldconfig
82
83 %files
84 %defattr(644,root,root,755)
85 %doc CHANGES NOTICE README
86 %attr(755,root,root) %{_libdir}/libserf-*.so.*.*
87 %attr(755,root,root) %ghost %{_libdir}/libserf-*.so.[0-9]
88
89 %files devel
90 %defattr(644,root,root,755)
91 %attr(755,root,root) %{_libdir}/libserf-*.so
92 %{_libdir}/libserf-*.la
93 %{_includedir}/serf*.h
94
95 %files static
96 %defattr(644,root,root,755)
97 %{_libdir}/libserf-*.a
This page took 0.06193 seconds and 4 git commands to generate.