]> git.pld-linux.org Git - packages/serf.git/blob - serf.spec
- chmod 755 to allow rpm to find library deps
[packages/serf.git] / serf.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # don't perform "make check"
4 #
5 Summary:        A high-performance asynchronous HTTP client library
6 Summary(pl.UTF-8):      Wysokowydajna biblioteka asynchronicznego klienta HTTP
7 Name:           serf
8 Version:        0.7.0
9 Release:        1
10 License:        Apache v2.0
11 Group:          Libraries
12 #Source0Download: http://code.google.com/p/serf/downloads/list
13 Source0:        http://serf.googlecode.com/files/%{name}-%{version}.tar.bz2
14 # Source0-md5:  5c4b6d8b44135abbde289b49122bb7af
15 Patch0:         %{name}-sh.patch
16 URL:            http://code.google.com/p/serf/
17 BuildRequires:  apr-devel
18 BuildRequires:  apr-util-devel
19 BuildRequires:  autoconf >= 2.50
20 BuildRequires:  automake
21 BuildRequires:  openssl-devel >= 0.9.7d
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 The serf library is a C-based HTTP client library built upon the
26 Apache Portable Runtime (APR) library. It multiplexes connections,
27 running the read/write communication asynchronously. Memory copies and
28 transformations are kept to a minimum to provide high performance
29 operation.
30
31 %description -l pl.UTF-8
32 Biblioteka serf to napisana w C biblioteka klienta HTTP stworzona w
33 oparciu o bibliotekę Apache Portable Runtime (APR). Obsługuje
34 połączenia naprzemiennie, wywołując asynchronicznie komunikację
35 odczyt-zapis. Kopiowanie i transformacje w pamięci są ograniczone do
36 minimum w celu zapewnienia wydajnego działania.
37
38 %package devel
39 Summary:        Header files for serf
40 Summary(pl.UTF-8):      Pliki nagłówkowe serf
41 Group:          Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43 Requires:       apr-devel
44 Requires:       apr-util-devel
45
46 %description devel
47 C header files for the serf library.
48
49 %description devel -l pl.UTF-8
50 Pliki nagłówkowe dla biblioteki serf.
51
52 %package static
53 Summary:        Static libraries for serf
54 Summary(pl.UTF-8):      Biblioteki statyczne serf
55 Group:          Development/Libraries
56 Requires:       %{name}-devel = %{version}-%{release}
57
58 %description static
59 Static serf libraries.
60
61 %description static -l pl.UTF-8
62 Statyczne biblioteki serf.
63
64 %prep
65 %setup -q
66 %patch0 -p1
67
68 %build
69 %{__aclocal} -I build
70 %{__autoconf}
71 %configure \
72         --with-apr=%{_prefix} \
73         --with-apr-util=%{_prefix} \
74         --with-openssl=%{_prefix}
75 %{__make}
76
77 %{?with_tests:%{__make} check}
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81
82 %{__make} install \
83         DESTDIR=$RPM_BUILD_ROOT
84
85 chmod 755 $RPM_BUILD_ROOT%{_libdir}/lib*.so*
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %post   -p /sbin/ldconfig
91 %postun -p /sbin/ldconfig
92
93 %files
94 %defattr(644,root,root,755)
95 %doc CHANGES NOTICE README
96 %attr(755,root,root) %{_libdir}/libserf-0.so.*.*.*
97 %attr(755,root,root) %ghost %{_libdir}/libserf-0.so.0
98
99 %files devel
100 %defattr(644,root,root,755)
101 %attr(755,root,root) %{_libdir}/libserf-0.so
102 %{_libdir}/libserf-0.la
103 %{_includedir}/serf*.h
104
105 %files static
106 %defattr(644,root,root,755)
107 %{_libdir}/libserf-0.a
This page took 0.030614 seconds and 4 git commands to generate.