]> git.pld-linux.org Git - packages/serf.git/blob - serf.spec
- rel 2; build fix
[packages/serf.git] / serf.spec
1 #
2 # Conditional build:
3 %bcond_without  kerberos5       # GSSAPI support
4 %bcond_with     tests           # perform "make check" (uses localhost network, fails on apr side when IPV6 is enabled and localhost resolves only to IPV4 addresses)
5 #
6 Summary:        A high-performance asynchronous HTTP client library
7 Summary(pl.UTF-8):      Wysokowydajna biblioteka asynchronicznego klienta HTTP
8 Name:           serf
9 Version:        1.2.1
10 Release:        2
11 License:        Apache v2.0
12 Group:          Libraries
13 #Source0Download: http://code.google.com/p/serf/downloads/list
14 Source0:        http://serf.googlecode.com/files/%{name}-%{version}.tar.bz2
15 # Source0-md5:  4f8e76c9c6567aee1d66aba49f76a58b
16 Patch0:         %{name}-sh.patch
17 Patch1:         %{name}-link.patch
18 URL:            http://code.google.com/p/serf/
19 BuildRequires:  apr-devel
20 BuildRequires:  apr-util-devel
21 BuildRequires:  autoconf >= 2.50
22 BuildRequires:  automake
23 %{?with_kerberos5:BuildRequires:        heimdal-devel}
24 BuildRequires:  openssl-devel >= 0.9.7d
25 BuildRequires:  zlib-devel
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 The serf library is a C-based HTTP client library built upon the
30 Apache Portable Runtime (APR) library. It multiplexes connections,
31 running the read/write communication asynchronously. Memory copies and
32 transformations are kept to a minimum to provide high performance
33 operation.
34
35 %description -l pl.UTF-8
36 Biblioteka serf to napisana w C biblioteka klienta HTTP stworzona w
37 oparciu o bibliotekę Apache Portable Runtime (APR). Obsługuje
38 połączenia naprzemiennie, wywołując asynchronicznie komunikację
39 odczyt-zapis. Kopiowanie i transformacje w pamięci są ograniczone do
40 minimum w celu zapewnienia wydajnego działania.
41
42 %package devel
43 Summary:        Header files for serf
44 Summary(pl.UTF-8):      Pliki nagłówkowe serf
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47 Requires:       apr-devel
48 Requires:       apr-util-devel
49 %{?with_kerberos5:Requires:     heimdal-devel}
50
51 %description devel
52 C header files for the serf library.
53
54 %description devel -l pl.UTF-8
55 Pliki nagłówkowe dla biblioteki serf.
56
57 %package static
58 Summary:        Static libraries for serf
59 Summary(pl.UTF-8):      Biblioteki statyczne serf
60 Group:          Development/Libraries
61 Requires:       %{name}-devel = %{version}-%{release}
62
63 %description static
64 Static serf libraries.
65
66 %description static -l pl.UTF-8
67 Statyczne biblioteki serf.
68
69 %prep
70 %setup -q
71 %patch0 -p1
72 %patch1 -p1
73
74 %build
75 %{__aclocal} -I build
76 %{__autoconf}
77 %configure \
78         --with-apr=%{_prefix} \
79         --with-apr-util=%{_prefix} \
80         %{?with_kerberos5:--with-gssapi=%{_prefix}} \
81         --with-openssl=%{_prefix}
82 %{__make}
83
84 %{?with_tests:%{__make} check}
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88
89 %{__make} install \
90         DESTDIR=$RPM_BUILD_ROOT
91
92 chmod 755 $RPM_BUILD_ROOT%{_libdir}/lib*.so*
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %post   -p /sbin/ldconfig
98 %postun -p /sbin/ldconfig
99
100 %files
101 %defattr(644,root,root,755)
102 %doc CHANGES NOTICE README
103 %attr(755,root,root) %{_libdir}/libserf-1.so.*.*.*
104 %attr(755,root,root) %ghost %{_libdir}/libserf-1.so.0
105
106 %files devel
107 %defattr(644,root,root,755)
108 %attr(755,root,root) %{_libdir}/libserf-1.so
109 %{_libdir}/libserf-1.la
110 %{_includedir}/serf*.h
111 %{_pkgconfigdir}/serf-1.pc
112
113 %files static
114 %defattr(644,root,root,755)
115 %{_libdir}/libserf-1.a
This page took 0.068596 seconds and 4 git commands to generate.