]> git.pld-linux.org Git - packages/serf.git/blob - serf.spec
- updated to 1.0.1
[packages/serf.git] / serf.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make check" (uses localhost network, fails on apr side when IPV6 is enabled and localhost resolves only to IPV4 addresses)
4 #
5 Summary:        A high-performance asynchronous HTTP client library
6 Summary(pl.UTF-8):      Wysokowydajna biblioteka asynchronicznego klienta HTTP
7 Name:           serf
8 Version:        1.0.1
9 Release:        1
10 License:        Apache v2.0
11 Group:          Libraries
12 #Source0Download: http://code.google.com/p/serf/downloads/list
13 Source0:        http://serf.googlecode.com/files/%{name}-%{version}.tar.bz2
14 # Source0-md5:  01ade77ba0502687aa42551db31316f1
15 Patch0:         %{name}-sh.patch
16 URL:            http://code.google.com/p/serf/
17 BuildRequires:  apr-devel
18 BuildRequires:  apr-util-devel
19 BuildRequires:  autoconf >= 2.50
20 BuildRequires:  automake
21 BuildRequires:  openssl-devel >= 0.9.7d
22 BuildRequires:  zlib-devel
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 The serf library is a C-based HTTP client library built upon the
27 Apache Portable Runtime (APR) library. It multiplexes connections,
28 running the read/write communication asynchronously. Memory copies and
29 transformations are kept to a minimum to provide high performance
30 operation.
31
32 %description -l pl.UTF-8
33 Biblioteka serf to napisana w C biblioteka klienta HTTP stworzona w
34 oparciu o bibliotekę Apache Portable Runtime (APR). Obsługuje
35 połączenia naprzemiennie, wywołując asynchronicznie komunikację
36 odczyt-zapis. Kopiowanie i transformacje w pamięci są ograniczone do
37 minimum w celu zapewnienia wydajnego działania.
38
39 %package devel
40 Summary:        Header files for serf
41 Summary(pl.UTF-8):      Pliki nagłówkowe serf
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44 Requires:       apr-devel
45 Requires:       apr-util-devel
46
47 %description devel
48 C header files for the serf library.
49
50 %description devel -l pl.UTF-8
51 Pliki nagłówkowe dla biblioteki serf.
52
53 %package static
54 Summary:        Static libraries for serf
55 Summary(pl.UTF-8):      Biblioteki statyczne serf
56 Group:          Development/Libraries
57 Requires:       %{name}-devel = %{version}-%{release}
58
59 %description static
60 Static serf libraries.
61
62 %description static -l pl.UTF-8
63 Statyczne biblioteki serf.
64
65 %prep
66 %setup -q
67 %patch0 -p1
68
69 %build
70 %{__aclocal} -I build
71 %{__autoconf}
72 %configure \
73         --with-apr=%{_prefix} \
74         --with-apr-util=%{_prefix} \
75         --with-openssl=%{_prefix}
76 %{__make}
77
78 %{?with_tests:%{__make} check}
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82
83 %{__make} install \
84         DESTDIR=$RPM_BUILD_ROOT
85
86 chmod 755 $RPM_BUILD_ROOT%{_libdir}/lib*.so*
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %post   -p /sbin/ldconfig
92 %postun -p /sbin/ldconfig
93
94 %files
95 %defattr(644,root,root,755)
96 %doc CHANGES NOTICE README
97 %attr(755,root,root) %{_libdir}/libserf-1.so.*.*.*
98 %attr(755,root,root) %ghost %{_libdir}/libserf-1.so.0
99
100 %files devel
101 %defattr(644,root,root,755)
102 %attr(755,root,root) %{_libdir}/libserf-1.so
103 %{_libdir}/libserf-1.la
104 %{_includedir}/serf*.h
105 %{_pkgconfigdir}/serf-1.pc
106
107 %files static
108 %defattr(644,root,root,755)
109 %{_libdir}/libserf-1.a
This page took 0.033335 seconds and 4 git commands to generate.