]> git.pld-linux.org Git - packages/serf.git/blob - serf.spec
- rebuild with openssl 3.0.0, rel 3
[packages/serf.git] / serf.spec
1 #
2 # Conditional build:
3 %bcond_without  kerberos5       # GSSAPI support
4 %bcond_with     tests           # perform "scons check" (uses localhost network, fails on apr side when IPV6 is enabled and localhost resolves only to IPV4 addresses)
5 #
6 Summary:        A high-performance asynchronous HTTP client library
7 Summary(pl.UTF-8):      Wysokowydajna biblioteka asynchronicznego klienta HTTP
8 Name:           serf
9 Version:        1.3.9
10 Release:        3
11 License:        Apache v2.0
12 Group:          Libraries
13 Source0:        https://www.apache.org/dist/serf/%{name}-%{version}.tar.bz2
14 # Source0-md5:  370a6340ff20366ab088012cd13f2b57
15 Patch0:         %{name}-scons.patch
16 Patch1:         openssl3.patch
17 URL:            https://serf.apache.org/
18 BuildRequires:  apr-devel
19 BuildRequires:  apr-util-devel
20 %{?with_kerberos5:BuildRequires:        heimdal-devel}
21 BuildRequires:  openssl-devel >= 0.9.7d
22 BuildRequires:  scons >= 2.3.0
23 BuildRequires:  zlib-devel
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 The serf library is a C-based HTTP client library built upon the
28 Apache Portable Runtime (APR) library. It multiplexes connections,
29 running the read/write communication asynchronously. Memory copies and
30 transformations are kept to a minimum to provide high performance
31 operation.
32
33 %description -l pl.UTF-8
34 Biblioteka serf to napisana w C biblioteka klienta HTTP stworzona w
35 oparciu o bibliotekę Apache Portable Runtime (APR). Obsługuje
36 połączenia naprzemiennie, wywołując asynchronicznie komunikację
37 odczyt-zapis. Kopiowanie i transformacje w pamięci są ograniczone do
38 minimum w celu zapewnienia wydajnego działania.
39
40 %package devel
41 Summary:        Header files for serf
42 Summary(pl.UTF-8):      Pliki nagłówkowe serf
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45 Requires:       apr-devel
46 Requires:       apr-util-devel
47 %{?with_kerberos5:Requires:     heimdal-devel}
48 Requires:       openssl-devel >= 0.9.7d
49
50 %description devel
51 C header files for the serf library.
52
53 %description devel -l pl.UTF-8
54 Pliki nagłówkowe dla biblioteki serf.
55
56 %package static
57 Summary:        Static libraries for serf
58 Summary(pl.UTF-8):      Biblioteki statyczne serf
59 Group:          Development/Libraries
60 Requires:       %{name}-devel = %{version}-%{release}
61
62 %description static
63 Static serf libraries.
64
65 %description static -l pl.UTF-8
66 Statyczne biblioteki serf.
67
68 %prep
69 %setup -q
70 %patch0 -p1
71 %patch1 -p1
72
73 %build
74 %scons \
75         PREFIX=%{_prefix} \
76         LIBDIR=%{_libdir} \
77         GSSAPI=/usr
78
79 %if %{with tests}
80 %scons check
81 %endif
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85
86 %scons install \
87         PREFIX=%{_prefix} \
88         LIBDIR=%{_libdir} \
89         --install-sandbox=$RPM_BUILD_ROOT
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %post   -p /sbin/ldconfig
95 %postun -p /sbin/ldconfig
96
97 %files
98 %defattr(644,root,root,755)
99 %doc CHANGES NOTICE README
100 %attr(755,root,root) %{_libdir}/libserf-1.so.*.*.*
101 %attr(755,root,root) %ghost %{_libdir}/libserf-1.so.1
102
103 %files devel
104 %defattr(644,root,root,755)
105 %attr(755,root,root) %{_libdir}/libserf-1.so
106 %{_includedir}/serf-1
107 %{_pkgconfigdir}/serf-1.pc
108
109 %files static
110 %defattr(644,root,root,755)
111 %{_libdir}/libserf-1.a
This page took 0.056735 seconds and 3 git commands to generate.