]> git.pld-linux.org Git - SPECS.git/blob - selinux-python2.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / selinux-python2.spec
1 # DEPRECATED (python2)
2 Summary:        SELinux Python 2 policy utilities
3 Summary(pl.UTF-8):      Narzędzia do polityk SELinuksa napisane w Pythonie 2
4 Name:           selinux-python2
5 Version:        2.9
6 Release:        0.1
7 License:        GPL v2 (sepolgen), GPL v2+ (sepolicy)
8 Group:          Applications/System
9 #Source0Download: https://github.com/SELinuxProject/selinux/wiki/Releases
10 Source0:        https://github.com/SELinuxProject/selinux/releases/download/20190315/selinux-python-%{version}.tar.gz
11 # Source0-md5:  e9dfedd1139dd9998f5a09abfb670454
12 URL:            https://github.com/SELinuxProject/selinux/wiki
13 BuildRequires:  libsepol-static >= 2.9
14 BuildRequires:  python-modules >= 1:2.7
15 BuildRequires:  rpm-pythonprov
16 BuildRequires:  rpm-build >= 4.6
17 BuildRequires:  rpmbuild(macros) >= 1.714
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Security-enhanced Linux is a patch of the Linux kernel and a number of
22 utilities with enhanced security functionality designed to add
23 mandatory access controls to Linux. The Security-enhanced Linux kernel
24 contains new architectural components originally developed to improve
25 the security of the Flask operating system. These architectural
26 components provide general support for the enforcement of many kinds
27 of mandatory access control policies, including those based on the
28 concepts of Type Enforcement, Role-based Access Control, and
29 Multi-level Security.
30
31 %description -l pl.UTF-8
32 Security-enhanced Linux jest prototypem jądra Linuksa i wielu
33 aplikacji użytkowych o funkcjach podwyższonego bezpieczeństwa.
34 Zaprojektowany jest tak, aby w prosty sposób ukazać znaczenie
35 obowiązkowej kontroli dostępu dla społeczności linuksowej. Ukazuje
36 również jak taką kontrolę można dodać do istniejącego systemu typu
37 Linux. Jądro SELinux zawiera nowe składniki architektury pierwotnie
38 opracowane w celu ulepszenia bezpieczeństwa systemu operacyjnego
39 Flask. Te elementy zapewniają ogólne wsparcie we wdrażaniu wielu typów
40 polityk obowiązkowej kontroli dostępu, włączając te wzorowane na: Type
41 Enforcement (TE), kontroli dostępu opartej na rolach (RBAC) i
42 zabezpieczeniach wielopoziomowych.
43
44 %package -n python-sepolgen
45 Summary:        sepolgen - Python 2 module for policy generation
46 Summary(pl.UTF-8):      Moduł Pythona 2 sepolgen do generowania polityki
47 License:        GPL v2
48 Group:          Libraries/Python
49 Requires:       python-selinux >= 2.9
50 Suggests:       python-setools
51 BuildArch:      noarch
52
53 %description -n python-sepolgen
54 Python sepolgen module for policy generation.
55
56 This package contains an old version of module, with Python 2 support.
57
58 %description -n python-sepolgen -l pl.UTF-8
59 Moduł Pythona sepolgen do generowania polityki.
60
61 Ten pakiet zawiera starą wersję modułu, obsługującą Pythona 2.
62
63 %package -n python-sepolicy
64 Summary:        Python modules for SELinux policy manipulation
65 Summary(pl.UTF-8):      Moduły Pythona do operowania na politykach SELinuksa
66 Group:          Libraries/Python
67 # seobject uses selinux,semanage,sepolicy,setools +IPy modules and "policycoreutils" translations domain
68 # seobject and sepolicy use translations from policycoreutils domain
69 Requires:       policycoreutils >= 2.9
70 Requires:       python-IPy
71 Requires:       python-dbus
72 Requires:       python-semanage >= 2.9
73 Requires:       python-sepolgen = %{version}-%{release}
74 Requires:       python-setools
75 Requires:       python-slip-dbus
76 # for sepolicy.gui additionally:
77 Requires:       gtk+3 >= 3
78 Requires:       python3-pygobject3 >= 3
79 Conflicts:      policycoreutils-sepolicy < 2.7
80
81 %description -n python-sepolicy
82 Python modules for SELinux policy manipulation.
83
84 This package contains an old version of modules, with Python 2
85 support.
86
87 %description -n python-sepolicy -l pl.UTF-8
88 Moduły Pythona do operowania na politykach SELinuksa.
89
90 Ten pakiet zawiera starą wersję modułów, obsługującą Pythona 2.
91
92 %prep
93 %setup -q -n selinux-python-%{version}
94
95 %build
96 %{__make} \
97         PYTHON=%{__python} \
98         SUBDIRS="sepolicy semanage sepolgen"
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 %{__make} install \
104         DESTDIR=$RPM_BUILD_ROOT \
105         PYTHON=%{__python} \
106         PYTHONLIBDIR=%{py_sitescriptdir} \
107         LIBSEPOLA=%{_libdir}/libsepol.a
108
109 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
110 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
111 %py_postclean
112
113 %{__rm} -r $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_datadir}/bash-completion} \
114         $RPM_BUILD_ROOT%{_mandir}/{man1,man8,ru/man1,ru/man8} \
115         $RPM_BUILD_ROOT/var/lib/sepolgen
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %files -n python-sepolgen
121 %defattr(644,root,root,755)
122 %{py_sitescriptdir}/sepolgen
123
124 %files -n python-sepolicy
125 %defattr(644,root,root,755)
126 %{py_sitescriptdir}/seobject.py[co]
127 %dir %{py_sitedir}/sepolicy
128 %{py_sitedir}/sepolicy/*.py[co]
129 %{py_sitedir}/sepolicy/sepolicy.glade
130 %dir %{py_sitedir}/sepolicy/help
131 %{py_sitedir}/sepolicy/help/__init__.py[co]
132 %{py_sitedir}/sepolicy/help/*.png
133 %{py_sitedir}/sepolicy/help/*.txt
134 %dir %{py_sitedir}/sepolicy/templates
135 %{py_sitedir}/sepolicy/templates/*.py[co]
136 %{py_sitedir}/sepolicy-1.1-py*.egg-info
This page took 0.463057 seconds and 3 git commands to generate.