]> git.pld-linux.org Git - SPECS.git/blob - sddm.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / sddm.spec
1 %define         qtver   5.8.0
2
3 Summary:        QML based X11 desktop manager
4 Name:           sddm
5 Version:        0.19.0
6 Release:        3
7 License:        GPLv2+ and CC-BY-SA
8 Group:          X11/Applications
9 Source0:        https://github.com/sddm/sddm/archive/v%{version}.tar.gz
10 # Source0-md5:  2e3268a30531d6ae98f02cbf3772fea1
11 Source1:        wayland-session
12 Source10:       %{name}.pam
13 Source11:       %{name}-autologin.pam
14 Source12:       tmpfiles-%{name}.conf
15 # sample sddm.conf generated with sddm --example-config, and entries commented-out
16 Source13:       %{name}.conf
17 Source14:       Xsession
18 URL:            https://github.com/sddm/sddm
19 BuildRequires:  Qt5Core-devel >= %{qtver}
20 BuildRequires:  Qt5DBus-devel >= %{qtver}
21 BuildRequires:  Qt5Gui-devel >= %{qtver}
22 BuildRequires:  Qt5Network-devel >= %{qtver}
23 BuildRequires:  Qt5Qml-devel >= %{qtver}
24 BuildRequires:  Qt5Quick-devel >= %{qtver}
25 BuildRequires:  Qt5Test-devel >= %{qtver}
26 BuildRequires:  cmake >= 2.8.8
27 BuildRequires:  docutils
28 BuildRequires:  kf5-extra-cmake-modules
29 BuildRequires:  libstdc++-devel
30 BuildRequires:  libxcb-devel
31 BuildRequires:  pam-devel
32 BuildRequires:  pkgconfig
33 BuildRequires:  python-docutils
34 BuildRequires:  qt5-build >= %{qtver}
35 BuildRequires:  qt5-linguist >= %{qtver}
36 BuildRequires:  qt5-qmake >= %{qtver}
37 BuildRequires:  rpmbuild(macros) >= 1.202
38 BuildRequires:  systemd-devel >= 209
39 BuildRequires:  systemd-units
40 Provides:       XDM
41 Provides:       group(sddm)
42 Provides:       service(graphical-login) = sddm
43 Provides:       user(sddm)
44 Requires(post,preun,postun):    systemd-units >= 38
45 Requires(postun):       /usr/sbin/groupdel
46 Requires(postun):       /usr/sbin/userdel
47 Requires(pre):  /bin/id
48 Requires(pre):  /usr/sbin/groupadd
49 Requires(pre):  /usr/sbin/useradd
50 Requires:       Qt5Core >= %{qtver}
51 Requires:       Qt5DBus >= %{qtver}
52 Requires:       Qt5Network >= %{qtver}
53 Requires:       Qt5Qml >= %{qtver}
54 Requires:       Qt5Quick >= %{qtver}
55 Requires:       systemd-units >= 38
56 Requires:       xinitrc-ng >= 1.0
57 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59 %description
60 SDDM is a modern display manager for X11 aiming to be fast, simple and
61 beautiful. It uses modern technologies like QtQuick, which in turn
62 gives the designer the ability to create smooth, animated user
63 interfaces.
64
65 %prep
66 %setup -q
67
68 %build
69 install -d build
70 cd build
71 %cmake \
72         -DBUILD_MAN_PAGES:BOOL=ON \
73         -DENABLE_JOURNALD:BOOL=ON \
74         -DUSE_QT5:BOOL=ON \
75         ..
76 %{__make}
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80 install -d $RPM_BUILD_ROOT%{_localstatedir}/{lib,run}/sddm
81 %{__make} -C build install/fast \
82         DESTDIR=$RPM_BUILD_ROOT
83
84 install -Dpm 644 %{SOURCE10} $RPM_BUILD_ROOT/etc/pam.d/sddm
85 install -Dpm 644 %{SOURCE11} $RPM_BUILD_ROOT/etc/pam.d/sddm-autologin
86 install -Dpm 644 %{SOURCE12} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/sddm.conf
87 install -Dpm 644 %{SOURCE13} $RPM_BUILD_ROOT%{_sysconfdir}/sddm.conf
88 install -Dpm 644 %{SOURCE14} $RPM_BUILD_ROOT%{_datadir}/sddm/scripts/Xsession
89 install -Dpm 644 %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/sddm/scripts/wayland-session
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %pre
95 %groupadd -g 323 -r -f sddm
96 %useradd -u 323 -r -d %{_localstatedir}/lib/sddm -s /bin/false -c "Simple Desktop Display Manager" -g sddm sddm
97
98 %preun
99 %systemd_preun sddm.service
100
101 %post
102 #skip restarting as it would otherise terminate all sessions opened from sddm!
103 NORESTART=1
104 %systemd_post sddm.service
105
106 %postun
107 if [ "$1" = "0" ]; then
108         %userremove sddm
109         %groupremove sddm
110 fi
111 %systemd_reload
112
113 %files
114 %defattr(644,root,root,755)
115 %doc README.md CONTRIBUTORS
116 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sddm.conf
117 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sddm
118 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sddm-autologin
119 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sddm-greeter
120 # it's under %{_sysconfdir}, sure, but it's not a config file
121 /etc/dbus-1/system.d/org.freedesktop.DisplayManager.conf
122 %attr(755,root,root) %{_bindir}/sddm
123 %attr(755,root,root) %{_bindir}/sddm-greeter
124 %attr(755,root,root) %{_libexecdir}/sddm-helper
125 %{systemdtmpfilesdir}/sddm.conf
126 %attr(711, root, sddm) %dir %{_localstatedir}/run/sddm
127 %attr(1770, sddm, sddm) %dir %{_localstatedir}/lib/sddm
128 %{systemdunitdir}/sddm.service
129 %{_libdir}/qt5/qml/SddmComponents/
130 %dir %{_datadir}/sddm
131 %{_datadir}/sddm/faces
132 %{_datadir}/sddm/flags
133 %dir %{_datadir}/sddm/scripts
134 %attr(755,root,root) %{_datadir}/sddm/scripts/*
135 %{_datadir}/sddm/themes
136 %{_datadir}/sddm/translations
137 %{_mandir}/man1/sddm.1*
138 %{_mandir}/man1/sddm-greeter.1*
139 %{_mandir}/man5/sddm.conf.5*
140 %{_mandir}/man5/sddm-state.conf.5*
This page took 0.477588 seconds and 3 git commands to generate.