]> git.pld-linux.org Git - packages/scummvm.git/blob - scummvm.spec
- added flac-1.1.3 patch
[packages/scummvm.git] / scummvm.spec
1 # TODO:
2 #  - include gui/themes/modern* and teach scummvm to search
3 #    for it in some system paths, not current dir
4 #
5 %define         version_tools   0.9.0
6 Summary:        SCUMM graphic adventure game interpreter
7 Summary(pl):    Interpreter przygodówek opartych na SCUMM
8 Name:           scummvm
9 Version:        0.9.1
10 Release:        2
11 License:        GPL
12 Group:          X11/Applications/Games
13 Source0:        http://dl.sourceforge.net/scummvm/%{name}-%{version}.tar.bz2
14 # Source0-md5:  30a82ad466bae223875e66ee14b94904
15 Source1:        http://dl.sourceforge.net/scummvm/%{name}-tools-%{version_tools}.tar.bz2
16 # Source1-md5:  c8164fa1cca90b1c3bff1c8949d875a3
17 Source2:        %{name}.desktop
18 Source3:        %{name}.png
19 Patch0:         %{name}-flac.patch
20 URL:            http://scummvm.sourceforge.net/
21 BuildRequires:  SDL-devel >= 1.2.2
22 %ifarch %{ix86} %{x8664}
23 BuildRequires:  fluidsynth-devel
24 %endif
25 BuildRequires:  libmad-devel
26 BuildRequires:  libvorbis-devel
27 BuildRequires:  mpeg2dec-devel
28 %ifarch %{ix86}
29 BuildRequires:  nasm
30 %endif
31 BuildRequires:  sed >= 4.0
32 BuildRequires:  zlib-devel
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 ScummVM is a collection of interpreters, capable of emulating several
37 adventure game engines. ScummVM mainly supports games created using
38 SCUMM (Script Creation Utility for Maniac Mansion), used in various
39 LucasArts games such as Monkey Island, Day of the Tentacle, and
40 others.
41
42 ScummVM also contains interpreters for several non-SCUMM games.
43 Currently these are Beneath a Steel Sky, Broken Sword 1 & 2, Flight of
44 the Amazon Queen and Simon the Sorcerer 1 & 2.
45
46 At this time ScummVM should be considered beta software, and is still
47 under heavy development. Be aware that whilst we attempt to make sure
48 that many games can be completed with few major bugs, crashes can
49 happen.
50
51 %description -l pl
52 ScummVM jest zbiorem interpreterów zdolnych do emulacji kilku silników
53 gier przygodowych. ScummVM g³ównie wspiera gry stworzone z u¿yciem
54 silnika SCUMM (Script Creation Utility for Maniac Mansion), u¿ywanego
55 przez takie tytu³y stworzone przez Lucas Arts jak Monkey Island, Day
56 of the Tentacle.
57
58 ScummVM potrafi równie¿ interpretowaæ kilka gier nie opartych na
59 SCUMM. W chwili obecnej s± to Beneath a Steel Sky, Broken Sword 1 i 2,
60 Flight of the Amazon Queen oraz Simon the Sorcerer 1 i 2.
61
62 ScummVM jest ca³y czas intensywnie rozwijany i powinien byæ traktowany
63 jako program w stanie beta. Wiele gier powinno daæ siê skoñczyæ bez
64 wiêkszych b³êdów, nale¿y byæ jednak ¶wiadomym, ¿e program mo¿e siê
65 czasem wysypaæ.
66
67 %package tools
68 Summary:        ScummVM tools
69 Summary(pl):    Narzêdzia zwi±zane ze ScummVM
70 Group:          X11/Applications/Games
71
72 %description tools
73 Collection of various tools that may be useful to use in conjunction
74 with ScummVM.
75
76 %description tools -l pl
77 Zestaw narzêdzi mog±cych byæ u¿ytecznymi w po³±czeniu ze ScummVM.
78
79 %prep
80 %setup -q -a 1
81 %patch0 -p1
82
83 sed -i -e 's:"plugins/":"%{_libdir}/scummvm/":' base/plugins.cpp
84
85 %build
86 ./configure \
87         --disable-debug \
88 %ifnarch %{ix86}
89         --disable-nasm \
90 %endif
91         --enable-lure \
92         --enable-cine \
93         --enable-plugins
94
95 %{__make} \
96         CXX="%{__cxx}" \
97 %ifnarch sparc sparc64
98         CXXFLAGS="%{rpmcflags} -DDYNAMIC_MODULES" \
99 %else
100         CXXFLAGS="%{rpmcflags} -DDYNAMIC_MODULES -fpic" \
101 %endif
102         LDFLAGS="%{rpmldflags}"
103
104 cd tools-%{version_tools}
105 %{__make} \
106         CC="%{__cc}" \
107         CFLAGS="%{rpmcflags}" \
108         LDFLAGS="%{rpmldflags}"
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man6,%{_pixmapsdir},%{_desktopdir},%{_libdir}/scummvm}
113
114 install scummvm $RPM_BUILD_ROOT%{_bindir}
115 #install scummvm.6 $RPM_BUILD_ROOT%{_mandir}/man6
116
117 install plugins/lib*.so $RPM_BUILD_ROOT%{_libdir}/scummvm
118
119 cd tools-%{version_tools}
120 install compress_kyra           $RPM_BUILD_ROOT%{_bindir}
121 install compress_queen          $RPM_BUILD_ROOT%{_bindir}
122 install compress_saga           $RPM_BUILD_ROOT%{_bindir}
123 install compress_scumm_bun      $RPM_BUILD_ROOT%{_bindir}
124 install compress_scumm_san      $RPM_BUILD_ROOT%{_bindir}
125 install compress_scumm_sou      $RPM_BUILD_ROOT%{_bindir}
126 install compress_simon          $RPM_BUILD_ROOT%{_bindir}
127 install compress_sword1         $RPM_BUILD_ROOT%{_bindir}
128 install compress_sword2         $RPM_BUILD_ROOT%{_bindir}
129 install dekyra                  $RPM_BUILD_ROOT%{_bindir}
130 install descumm                 $RPM_BUILD_ROOT%{_bindir}
131 install desword2                $RPM_BUILD_ROOT%{_bindir}
132 install encode_dxa              $RPM_BUILD_ROOT%{_bindir}
133 install extract_kyra            $RPM_BUILD_ROOT%{_bindir}
134 install extract_loom_tg16       $RPM_BUILD_ROOT%{_bindir}
135 install extract_mm_c64          $RPM_BUILD_ROOT%{_bindir}
136 install extract_mm_nes          $RPM_BUILD_ROOT%{_bindir}
137 install extract_scumm_mac       $RPM_BUILD_ROOT%{_bindir}
138 install extract_simon1_amiga    $RPM_BUILD_ROOT%{_bindir}
139 install extract_zak_c64         $RPM_BUILD_ROOT%{_bindir}
140 cd -
141
142 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
143 install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
144
145 %clean
146 rm -rf $RPM_BUILD_ROOT
147
148 %files
149 %defattr(644,root,root,755)
150 %doc AUTHORS NEWS README TODO
151 %attr(755,root,root) %{_bindir}/scummvm
152 %{_libdir}/scummvm
153 #%{_mandir}/man6/*
154 %{_pixmapsdir}/*
155 %{_desktopdir}/*.desktop
156
157 %files tools
158 %defattr(644,root,root,755)
159 %doc tools-%{version_tools}/README
160 %attr(755,root,root) %{_bindir}/*
161 %exclude %{_bindir}/scummvm
This page took 0.060825 seconds and 3 git commands to generate.