]> git.pld-linux.org Git - SPECS.git/blob - s3ql.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / s3ql.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 Summary:        Filesystem that stores data in Google Storage, Amazon S3 etc
6 Name:           s3ql
7 Version:        2.28
8 Release:        5
9 License:        GPL v3
10 Group:          Applications/System
11 Source0:        https://bitbucket.org/nikratio/s3ql/downloads/%{name}-%{version}.tar.bz2
12 # Source0-md5:  3533a5608ce009a6b834853c7fc4cae4
13 URL:            https://bitbucket.org/nikratio/s3ql/
14 BuildRequires:  python3-Crypto
15 BuildRequires:  python3-Cython
16 BuildRequires:  python3-apsw >= 3.7.0
17 BuildRequires:  python3-defusedxml
18 BuildRequires:  python3-devel
19 BuildRequires:  python3-distribute
20 BuildRequires:  python3-dugong >= 3.2
21 BuildRequires:  python3-llfuse >= 0.39
22 BuildRequires:  python3-modules >= 1:3.3
23 BuildRequires:  rpm-pythonprov
24 %{?with_tests:BuildRequires:    python3-requests}
25 Requires:       python3-Crypto
26 Requires:       python3-apsw >= 3.7.0
27 Requires:       python3-defusedxml
28 Requires:       python3-dugong >= 3.2
29 Requires:       python3-llfuse >= 0.39
30 Requires:       python3-modules >= 1:3.3
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 S3QL is a file system that stores all its data online using storage
35 services like Google Storage, Amazon S3, or OpenStack. S3QL
36 effectively provides a hard disk of dynamic, infinite capacity that
37 can be accessed from any computer with internet access running Linux,
38 FreeBSD or OS-X.
39
40 %prep
41 %setup -q
42
43 %build
44 cython3 src/s3ql/deltadump.pyx
45
46 %{py3_build} \
47         %{?with_tests:test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{py3_install}
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes.txt README.rst
60 %attr(755,root,root) %{_bindir}/fsck.s3ql
61 %attr(755,root,root) %{_bindir}/mkfs.s3ql
62 %attr(755,root,root) %{_bindir}/mount.s3ql
63 %attr(755,root,root) %{_bindir}/s3ql*
64 %attr(755,root,root) %{_bindir}/umount.s3ql
65 %{py3_sitedir}/s3ql
66 %{py3_sitedir}/s3ql-%{version}-py*.egg-info
67 %{_mandir}/man1/*.1*
This page took 0.205611 seconds and 3 git commands to generate.