]> git.pld-linux.org Git - SPECS.git/blob - ruby-rb-inotify.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / ruby-rb-inotify.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 %define pkgname rb-inotify
6 Summary:        A Ruby wrapper for Linux's inotify, using FFI
7 Name:           ruby-%{pkgname}
8 Version:        0.9.5
9 Release:        2
10 License:        MIT
11 Group:          Development/Languages
12 Source0:        http://rubygems.org/downloads/%{pkgname}-%{version}.gem
13 # Source0-md5:  865ed70ff9f90d5d23dc4ab906358650
14 URL:            http://github.com/nex3/rb-inotify
15 BuildRequires:  rpm-rubyprov
16 BuildRequires:  rpmbuild(macros) >= 1.656
17 %if %{with tests}
18 BuildRequires:  ruby-yard >= 0.4.0
19 %endif
20 Requires:       ruby-ffi >= 0.5.0
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 A Ruby wrapper for Linux's inotify, using FFI
26
27 %prep
28 %setup -q -n %{pkgname}-%{version}
29
30 %build
31 # write .gemspec
32 %__gem_helper spec
33
34 %install
35 rm -rf $RPM_BUILD_ROOT
36 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir}}
37 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
38 cp -p %{pkgname}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
39
40 %clean
41 rm -rf $RPM_BUILD_ROOT
42
43 %files
44 %defattr(644,root,root,755)
45 %doc README.md MIT-LICENSE VERSION
46 %{ruby_vendorlibdir}/rb-inotify.rb
47 %{ruby_vendorlibdir}/rb-inotify
48 %{ruby_specdir}/%{pkgname}-%{version}.gemspec
This page took 0.693103 seconds and 3 git commands to generate.