]> git.pld-linux.org Git - SPECS.git/blob - ruby-rake-compiler.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / ruby-rake-compiler.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 %define gemname rake-compiler
6 Summary:        Rake-based Ruby C Extension task generator
7 Summary(pl.UTF-8):      Generator zadań Rake'a do budowania rozszerzeń języka Ruby napisanych w C
8 Name:           ruby-%{gemname}
9 Version:        1.0.7
10 Release:        2
11 License:        MIT
12 Group:          Development/Languages
13 Source0:        https://rubygems.org/downloads/%{gemname}-%{version}.gem
14 # Source0-md5:  ec3acc332e3c86760b3f4dbdc5351192
15 URL:            https://rubygems.org/gems/rake-compiler/
16 BuildRequires:  rpm-rubyprov
17 BuildRequires:  rpmbuild(macros) >= 1.656
18 %if %{with tests}
19 #BuildRequires: ruby-cucumber
20 #BuildRequires: ruby-isolate
21 #BuildRequires: ruby-rake
22 #BuildRequires: ruby-rcov
23 BuildRequires:  ruby-rspec
24 BuildRequires:  ruby-rubygems >= 1.3.5
25 %endif
26 Requires:       ruby-rake >= 0.8.3
27 Requires:       ruby-rubygems >= 1.3.5
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 rake-compiler aims to help Gem developers while dealing with Ruby C
33 extensions, simplifiying the code and reducing the duplication.
34
35 It follows *convention over configuration* and set an standarized
36 structure to build and package C extensions in your gems.
37
38 This is the result of experiences dealing with several Gems that
39 required native extensions across platforms and different user
40 configurations where details like portability and clarity of code were
41 lacking.
42
43 %description -l pl.UTF-8
44 rake-compiler ma na celu pomoc twórcom rozszerzeń Gem przy obsłudze
45 rozszerzeń języka Ruby napisanych w C, upraszczając kod i zmniejszając
46 duplikację.
47
48 Jest zgodny z paradygmatem "konwencja ponad konfiguracją" i tworzy
49 ustandaryzowaną strukturę do budowania i pakietowania rozszerzeń w C
50 do plików gem.
51
52 Moduł jest wynikiem doświadczeń przy różnych Gemach, wymagających
53 natywnych rozszerzeń na różnych platformach, z różną konfiguracją
54 użytkownika, gdzie zabrakło przenośności i czytelności kodu.
55
56 %package doc
57 Summary:        Documentation for Ruby rake-compiler module
58 Summary(pl.UTF-8):      Dokumentacja modułu języka Ruby rake-compiler
59 Group:          Documentation
60 Requires:       %{name} = %{version}-%{release}
61
62 %description doc
63 This package contains documentation for Ruby rake-compiler module.
64
65 %description doc -l pl.UTF-8
66 Ten pakiet zawiera dokumentację do modułu języka Ruby rake-compiler.
67
68 %prep
69 %setup -q -n %{gemname}-%{version}
70
71 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+ruby(\s|$),#!%{__ruby}\1,' bin/rake-compiler
72
73 %build
74 %if %{with tests}
75 # Modify Isolate file
76 cp -p Isolate{,.orig}
77 sed -i -e 's|gem |# gem|' Isolate
78
79 # cucumber 0.10.0 needs fixing for newer rake (0.9.0 beta5)
80 # rake aborted!
81 # undefined method `desc' for #<Cucumber::Rake::Task:0xb742ebb0>
82 # rake spec
83 ruby -Ilib -S rspec spec/
84
85 # back to the original
86 %{__mv} Isolate{.orig,}
87 %endif
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{_bindir}}
92 cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
93 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %files
99 %defattr(644,root,root,755)
100 %doc README.rdoc History.txt LICENSE.txt
101 %attr(755,root,root) %{_bindir}/rake-compiler
102 %dir %{ruby_vendorlibdir}/rake
103 %{ruby_vendorlibdir}/rake/baseextensiontask.rb
104 %{ruby_vendorlibdir}/rake/extensioncompiler.rb
105 %{ruby_vendorlibdir}/rake/extensiontask.rb
106 %{ruby_vendorlibdir}/rake/javaextensiontask.rb
This page took 0.367237 seconds and 3 git commands to generate.