]> git.pld-linux.org Git - SPECS.git/blob - ruby-rack.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / ruby-rack.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 %define pkgname rack
6 Summary:        Modular interface to webservers
7 Summary(pl.UTF-8):      Modularny interfejs do serwerów WWW
8 Name:           ruby-%{pkgname}
9 Version:        1.4.5
10 Release:        3
11 License:        MIT
12 Group:          Development/Libraries
13 Source0:        http://rubygems.org/downloads/%{pkgname}-%{version}.gem
14 # Source0-md5:  6661d225210f6b48f83fb279aba0a149
15 URL:            http://rubyforge.org/projects/rack
16 BuildRequires:  rpm-rubyprov
17 BuildRequires:  rpmbuild(macros) >= 1.665
18 BuildRequires:  sed >= 4.0
19 %if %{with tests}
20 BuildRequires:  ruby-bacon
21 BuildRequires:  ruby-fcgi
22 BuildRequires:  ruby-memcache-client
23 BuildRequires:  ruby-mongrel
24 BuildRequires:  ruby-rake
25 BuildRequires:  ruby-thin
26 %endif
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Rack provides a minimal, modular and adaptable interface for
32 developing web applications in Ruby. By wrapping HTTP requests and
33 responses in the simplest way possible, it unifies and distills the
34 API for web servers, web frameworks, and software in between (the
35 so-called middleware) into a single method call.
36
37 %description -l pl.UTF-8
38 Rack dostarcza minimalny, modularny i adaptowalny interfejs do
39 tworzenia aplikacji WWW w języku Ruby. Opakowując zapytania i
40 odpowiedzi HTTP w sposób najprostszy z możliwych, unifikuje oraz
41 przekształca API dla serwerów WWW, szkieletów aplikacji WWW i
42 oprogramowania znajdującego się między nimi (tzw. middleware) w jedno
43 wywołanie metody.
44
45 %package rdoc
46 Summary:        HTML documentation for %{pkgname}
47 Summary(pl.UTF-8):      Dokumentacja w formacie HTML dla %{pkgname}
48 Group:          Documentation
49 Requires:       ruby >= 1:1.8.7-4
50
51 %description rdoc
52 HTML documentation for %{pkgname}.
53
54 %description rdoc -l pl.UTF-8
55 Dokumentacja w formacie HTML dla %{pkgname}.
56
57 %package ri
58 Summary:        ri documentation for %{pkgname}
59 Summary(pl.UTF-8):      Dokumentacja w formacie ri dla %{pkgname}
60 Group:          Documentation
61 Requires:       ruby
62
63 %description ri
64 ri documentation for %{pkgname}.
65
66 %description ri -l pl.UTF-8
67 Dokumentacji w formacie ri dla %{pkgname}.
68
69 %prep
70 %setup -q -n %{pkgname}-%{version}
71 %{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
72
73 %build
74 # write .gemspec
75 %__gem_helper spec
76
77 rdoc --ri --op ri lib
78 rdoc --op rdoc lib
79 %{__rm} -r ri/{FCGI,created.rid,cache.ri}
80 %{__rm} ri/URI/cdesc-URI.ri
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84 install -d $RPM_BUILD_ROOT{%{_bindir},%{ruby_vendorlibdir},%{ruby_specdir},%{ruby_ridir},%{ruby_rdocdir}}
85
86 cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
87 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
88 cp -a ri/* $RPM_BUILD_ROOT%{ruby_ridir}
89 cp -a rdoc $RPM_BUILD_ROOT%{ruby_rdocdir}/%{name}-%{version}
90 cp -p %{pkgname}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
91
92 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
93 cp -a example/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %files
99 %defattr(644,root,root,755)
100 %doc README.rdoc
101 %attr(755,root,root) %{_bindir}/rackup
102 %{ruby_vendorlibdir}/rack.rb
103 %{ruby_vendorlibdir}/rack
104 %{ruby_specdir}/%{pkgname}-%{version}.gemspec
105 %{_examplesdir}/%{name}-%{version}
106
107 %files rdoc
108 %defattr(644,root,root,755)
109 %{ruby_rdocdir}/%{name}-%{version}
110
111 %files ri
112 %defattr(644,root,root,755)
113 %{ruby_ridir}/Rack
This page took 0.171731 seconds and 3 git commands to generate.