]> git.pld-linux.org Git - SPECS.git/blob - ruby-pusher-client.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / ruby-pusher-client.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 %define pkgname pusher-client
6 Summary:        Client for consuming WebSockets from pusher.com
7 Name:           ruby-%{pkgname}
8 Version:        0.6.2
9 Release:        1
10 License:        MIT
11 Group:          Development/Languages
12 Source0:        http://rubygems.org/downloads/%{pkgname}-%{version}.gem
13 # Source0-md5:  a1bdd906062e16b0b43c57eca897c407
14 URL:            http://github.com/pusher/pusher-ruby-client
15 BuildRequires:  rpm-rubyprov
16 BuildRequires:  rpmbuild(macros) >= 1.656
17 %if %{with tests}
18 BuildRequires:  ruby-bundler
19 BuildRequires:  ruby-rake
20 BuildRequires:  ruby-rspec
21 %endif
22 Requires:       ruby-json
23 Requires:       ruby-websocket < 2
24 Requires:       ruby-websocket >= 1.0
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Client for consuming WebSockets from <http://pusher.com>.
30
31 %prep
32 %setup -q -n %{pkgname}-%{version}
33
34 %build
35 # write .gemspec
36 %__gem_helper spec
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir}}
41 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
42 cp -p %{pkgname}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %files
48 %defattr(644,root,root,755)
49 %{ruby_vendorlibdir}/%{pkgname}.rb
50 %{ruby_vendorlibdir}/%{pkgname}
51 %{ruby_specdir}/%{pkgname}-%{version}.gemspec
This page took 0.034423 seconds and 3 git commands to generate.