]> git.pld-linux.org Git - SPECS.git/blob - ruby-proxifier.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / ruby-proxifier.spec
1 %define pkgname proxifier
2 Summary:        Proxifier is a gem to force ruby to use a proxy
3 Name:           ruby-%{pkgname}
4 Version:        1.0.3
5 Release:        1
6 License:        BSD-like
7 Group:          Development/Languages
8 Source0:        http://rubygems.org/downloads/%{pkgname}-%{version}.gem
9 # Source0-md5:  abfb31d36a2ea4feac73cd2f0363feaa
10 URL:            https://github.com/samuelkadolph/ruby-proxifier
11 BuildRequires:  rpm-rubyprov
12 BuildRequires:  rpmbuild(macros) >= 1.656
13 BuildRequires:  sed >= 4.0
14 BuildArch:      noarch
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 Proxifier adds support for HTTP or SOCKS proxies and lets you force
19 TCPSocket to use proxies.
20
21 %prep
22 %setup -q -n %{pkgname}-%{version}
23 %{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
24
25 %build
26 # write .gemspec
27 %__gem_helper spec
28
29 %install
30 rm -rf $RPM_BUILD_ROOT
31 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir},%{_bindir}}
32 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
33 cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
34 cp -p %{pkgname}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
35
36 %clean
37 rm -rf $RPM_BUILD_ROOT
38
39 %files
40 %defattr(644,root,root,755)
41 %attr(755,root,root) %{_bindir}/pirb
42 %attr(755,root,root) %{_bindir}/pruby
43 %{ruby_vendorlibdir}/proxifier.rb
44 %{ruby_vendorlibdir}/proxifier
45 %dir %{ruby_vendorlibdir}/uri
46 %{ruby_vendorlibdir}/uri/socks.rb
47 %{ruby_specdir}/%{pkgname}-%{version}.gemspec
This page took 1.374203 seconds and 3 git commands to generate.