]> git.pld-linux.org Git - packages/ruby-net-scp.git/blob - ruby-net-scp.spec
2a5a79dc090c4622e24ff15238eaa6c65f58f6ce
[packages/ruby-net-scp.git] / ruby-net-scp.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 %define pkgname net-scp
6 Summary:        A pure Ruby implementation of the SCP client protocol
7 Name:           ruby-%{pkgname}
8 Version:        1.2.1
9 Release:        2
10 License:        MIT
11 Group:          Development/Languages
12 Source0:        http://rubygems.org/gems/%{pkgname}-%{version}.gem
13 # Source0-md5:  abeec1cab9696e02069e74bd3eac8a1b
14 URL:            http://rubygems.org/gems/net-scp
15 BuildRequires:  rpm-rubyprov
16 BuildRequires:  rpmbuild(macros) >= 1.665
17 %if %{with tests}
18 BuildRequires:  ruby-mocha
19 BuildRequires:  ruby-net-ssh >= 2.6.5
20 BuildRequires:  ruby-test-unit
21 %endif
22 Requires:       ruby-net-ssh >= 2.6.5
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 A pure Ruby implementation of the SCP client protocol
28
29 %package doc
30 Summary:        Documentation for %{name}
31 Group:          Documentation
32 Requires:       %{name} = %{version}-%{release}
33
34 %description doc
35 Documentation for %{name}
36
37 %prep
38 %setup -q -n %{pkgname}-%{version}
39
40 %build
41 # write .gemspec
42 %__gem_helper spec
43
44 %if %{with tests}
45 ruby -Itest test/test_all.rb
46 %endif
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir}}
51 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
52 cp -p %{pkgname}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc README.rdoc CHANGES.txt LICENSE.txt
60 %{ruby_vendorlibdir}/net/scp.rb
61 %{ruby_vendorlibdir}/net/scp
62 %dir %{ruby_vendorlibdir}/uri
63 %{ruby_vendorlibdir}/uri/open-scp.rb
64 %{ruby_vendorlibdir}/uri/scp.rb
65 %{ruby_specdir}/net-scp-%{version}.gemspec
66
67 %if 0
68 %files doc
69 %defattr(644,root,root,755)
70 %endif
This page took 0.085503 seconds and 3 git commands to generate.