]> git.pld-linux.org Git - SPECS.git/blob - ruby-net-http-pipeline.spec
SPECS updated Mon 29 Apr 22:05:02 CEST 2024
[SPECS.git] / ruby-net-http-pipeline.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 %define pkgname net-http-pipeline
6 Summary:        An HTTP/1.1 pipelining implementation atop Net::HTTP
7 Name:           ruby-%{pkgname}
8 Version:        1.0.1
9 Release:        1
10 License:        GPL v2+ or Ruby
11 Group:          Development/Languages
12 Source0:        http://rubygems.org/downloads/%{pkgname}-%{version}.gem
13 # Source0-md5:  50f3b868dab4ef1359d0777cdacda2e1
14 URL:            http://docs.seattlerb.org/net-http-pipeline
15 BuildRequires:  rpm-rubyprov
16 BuildRequires:  rpmbuild(macros) >= 1.656
17 %if %{with tests}
18 BuildRequires:  ruby-hoe < 3
19 BuildRequires:  ruby-hoe >= 2.16
20 BuildRequires:  ruby-minitest < 3
21 BuildRequires:  ruby-minitest >= 2.11
22 BuildRequires:  ruby-rdoc < 4
23 BuildRequires:  ruby-rdoc >= 3.10
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 An HTTP/1.1 pipelining implementation atop Net::HTTP. A pipelined
30 connection sends multiple requests to the HTTP server without waiting
31 for the responses. The server will respond in-order.
32
33 %prep
34 %setup -q -n %{pkgname}-%{version}
35
36 %build
37 # write .gemspec
38 %__gem_helper spec
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir}}
43 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
44 cp -p %{pkgname}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 %defattr(644,root,root,755)
51 %{ruby_vendorlibdir}/net/http/pipeline.rb
52 %{ruby_specdir}/%{pkgname}-%{version}.gemspec
This page took 0.302002 seconds and 3 git commands to generate.