]> git.pld-linux.org Git - packages/ruby-ncurses.git/blob - ruby-ncurses.spec
- rel 2
[packages/ruby-ncurses.git] / ruby-ncurses.spec
1 %define ruby_rubylibdir %(ruby -r rbconfig -e 'print Config::CONFIG["rubylibdir"]')
2 %define ruby_archdir    %(ruby -r rbconfig -e 'print Config::CONFIG["archdir"]')
3 %define ruby_ridir      %(ruby -r rbconfig -e 'include Config; print File.join(CONFIG["datadir"], "ri", CONFIG["ruby_version"], "system")')
4 Summary:        Ruby interface to Ncurses
5 Summary(pl):    Interfejs Ncurses dla Ruby
6 Name:           ruby-Ncurses
7 %define tarname ncurses-ruby
8 Version:        0.9.1
9 Release:        2
10 License:        Ruby-alike
11 Group:          Development/Languages
12 Source0:        http://download.berlios.de/%{tarname}/%{tarname}-%{version}.tar.bz2
13 # Source0-md5:  cb99721b492995bb3548b700b6e86fe2
14 URL:            http://ncurses-ruby.berlios.de/
15 BuildRequires:  ruby
16 Requires:       ruby
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 This ruby extension makes most functions, constants, and external variables of
21 the C library ncurses accessible from the Ruby programming language.
22
23 All C functions are wrapped by module functions of a the module "Ncurses", with
24 exactly the same name. Additionally, C functions expecting a WINDOW* as their
25 first argument can also be called as methods of the "Ncurses::WINDOW" class. 
26
27 %description -l pl
28 Rozszerzenie do ruby, które umo¿liwia dostêp do wiêkszo¶æ fukcji, sta³ych i
29 zewnêtrznych zmiennych biblioteki ncurses z poziomu jêzyka Ruby.
30
31 Wszystkie fukcje C s± dostêpne poprzez funkcje modu³u "Ncurses" pod dok³adnie
32 tymi samymi nazwami. Dodatkowo funkcje, które spodziewaj± sie mieæ WINDOW* jako
33 ich pierwszy argument mog± byæ tak¿e wywo³ywane jako metody klasy
34 "Ncurses::WINDOW".
35
36 %prep
37 %setup -q -n %{tarname}-%{version}
38
39 %build
40 ruby extconf.rb
41
42 %{__make} \
43         CC="%{__cc}" \
44         CFLAGS="%{rpmcflags} -fPIC"
45
46 rdoc --ri --op ri lib
47 rdoc --op rdoc lib
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51 install -d $RPM_BUILD_ROOT{%{ruby_rubylibdir},%{ruby_ridir},%{ruby_archdir}}
52
53 cp -a lib/* $RPM_BUILD_ROOT%{ruby_rubylibdir}
54 cp -a ri/ri/* $RPM_BUILD_ROOT%{ruby_ridir}
55 install ncurses.so $RPM_BUILD_ROOT%{ruby_archdir}
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc README rdoc
63 %{ruby_rubylibdir}/*.rb
64 %{ruby_archdir}/*.so
65 %{ruby_ridir}/Ncurses
This page took 0.159658 seconds and 4 git commands to generate.