]> git.pld-linux.org Git - packages/ruby-ncurses.git/blob - ruby-ncurses.spec
- BR: ncurses-devel
[packages/ruby-ncurses.git] / ruby-ncurses.spec
1 %define pkgname ncurses
2 Summary:        Ruby interface to Ncurses
3 Summary(pl.UTF-8):      Interfejs Ncurses dla Ruby
4 Name:           ruby-%{pkgname}
5 Version:        1.2.4
6 Release:        1
7 License:        Ruby-alike
8 Group:          Development/Languages
9 Source0:        http://download.berlios.de/ncurses-ruby/%{pkgname}-ruby-%{version}.tar.bz2
10 # Source0-md5:  8a3e0ed33ac245241b6afd911520c205
11 Patch0:         %{name}-utf8.patch
12 URL:            http://ncurses-ruby.berlios.de/
13 BuildRequires:  ncurses-devel
14 BuildRequires:  rpmbuild(macros) >= 1.277
15 BuildRequires:  ruby-devel >= 1:1.8.4-5
16 %{?ruby_mod_ver_requires_eq}
17 Provides:       ruby-Ncurses
18 Obsoletes:      ruby-Ncurses
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 This ruby extension makes most functions, constants, and external
23 variables of the C library ncurses accessible from the Ruby
24 programming language.
25
26 All C functions are wrapped by module functions of a the module
27 "Ncurses", with exactly the same name. Additionally, C functions
28 expecting a WINDOW* as their first argument can also be called as
29 methods of the "Ncurses::WINDOW" class.
30
31 %description -l pl.UTF-8
32 Rozszerzenie do ruby, które umożliwia dostęp do większość funkcji,
33 stałych i zewnętrznych zmiennych biblioteki ncurses z poziomu języka
34 Ruby.
35
36 Wszystkie funkcje C są dostępne poprzez funkcje modułu "Ncurses" pod
37 dokładnie tymi samymi nazwami. Dodatkowo funkcje, które spodziewają
38 się mieć WINDOW* jako ich pierwszy argument mogą być także wywoływane
39 jako metody klasy "Ncurses::WINDOW".
40
41 %prep
42 %setup -q -n %{pkgname}-ruby-%{version}
43 %patch0 -p1
44
45 %build
46 ruby extconf.rb
47
48 %{__make} \
49         CC="%{__cc}" \
50         CFLAGS="%{rpmcflags} -I/usr/include/ncursesw -fPIC"
51
52 rdoc --ri --op ri lib
53 rdoc --op rdoc lib
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 install -d $RPM_BUILD_ROOT%{ruby_ridir}
58
59 %{__make} -j1 install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 cp -a ri/* $RPM_BUILD_ROOT%{ruby_ridir}
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc README rdoc
70 %{ruby_sitelibdir}/*.rb
71 %attr(755,root,root) %{ruby_sitearchdir}/*.so
72 %{ruby_ridir}/Ncurses
This page took 0.037125 seconds and 4 git commands to generate.