]> git.pld-linux.org Git - packages/ruby-ncurses.git/blob - ruby-ncurses.spec
- (B)R: s/ruby/ruby-modules/, rel. 3 (mass commit through script)
[packages/ruby-ncurses.git] / ruby-ncurses.spec
1 %define tarname ncurses-ruby
2 Summary:        Ruby interface to Ncurses
3 Summary(pl):    Interfejs Ncurses dla Ruby
4 Name:           ruby-Ncurses
5 Version:        0.9.1
6 Release:        3
7 License:        Ruby-alike
8 Group:          Development/Languages
9 Source0:        http://download.berlios.de/%{tarname}/%{tarname}-%{version}.tar.bz2
10 # Source0-md5:  cb99721b492995bb3548b700b6e86fe2
11 URL:            http://ncurses-ruby.berlios.de/
12 BuildRequires:  rpmbuild(macros) >= 1.263
13 BuildRequires:  ruby-modules
14 Requires:       ruby-modules
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 This ruby extension makes most functions, constants, and external
19 variables of the C library ncurses accessible from the Ruby
20 programming language.
21
22 All C functions are wrapped by module functions of a the module
23 "Ncurses", with exactly the same name. Additionally, C functions
24 expecting a WINDOW* as their first argument can also be called as
25 methods of the "Ncurses::WINDOW" class.
26
27 %description -l pl
28 Rozszerzenie do ruby, które umo¿liwia dostêp do wiêkszo¶æ funkcji,
29 sta³ych i zewnêtrznych zmiennych biblioteki ncurses z poziomu jêzyka
30 Ruby.
31
32 Wszystkie funkcje C s± dostêpne poprzez funkcje modu³u "Ncurses" pod
33 dok³adnie tymi samymi nazwami. Dodatkowo funkcje, które spodziewaj±
34 siê mieæ WINDOW* jako ich pierwszy argument mog± byæ tak¿e wywo³ywane
35 jako metody klasy "Ncurses::WINDOW".
36
37 %prep
38 %setup -q -n %{tarname}-%{version}
39
40 %build
41 ruby extconf.rb
42
43 %{__make} \
44         CC="%{__cc}" \
45         CFLAGS="%{rpmcflags} -fPIC"
46
47 rdoc --ri --op ri lib
48 rdoc --op rdoc lib
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 install -d $RPM_BUILD_ROOT{%{ruby_rubylibdir},%{ruby_ridir},%{ruby_archdir}}
53
54 cp -a lib/* $RPM_BUILD_ROOT%{ruby_rubylibdir}
55 cp -a ri/ri/* $RPM_BUILD_ROOT%{ruby_ridir}
56 install ncurses.so $RPM_BUILD_ROOT%{ruby_archdir}
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc README rdoc
64 %{ruby_rubylibdir}/*.rb
65 %attr(755,root,root) %{ruby_archdir}/*.so
66 %{ruby_ridir}/Ncurses
This page took 0.062724 seconds and 4 git commands to generate.