]> git.pld-linux.org Git - packages/ruby-ncurses.git/blob - ruby-ncurses.spec
- P:ruby-Ncurses
[packages/ruby-ncurses.git] / ruby-ncurses.spec
1 %define pkgname ncurses
2 Summary:        Ruby interface to Ncurses
3 Summary(pl.UTF-8):      Interfejs Ncurses dla Ruby
4 Name:           ruby-%{pkgname}
5 Version:        1.2.4
6 Release:        1
7 License:        Ruby-alike
8 Group:          Development/Languages
9 Source0:        http://download.berlios.de/ncurses-ruby/%{pkgname}-ruby-%{version}.tar.bz2
10 # Source0-md5:  8a3e0ed33ac245241b6afd911520c205
11 Patch0:         %{name}-utf8.patch
12 URL:            http://ncurses-ruby.berlios.de/
13 BuildRequires:  rpmbuild(macros) >= 1.277
14 BuildRequires:  ruby-devel >= 1:1.8.4-5
15 %{?ruby_mod_ver_requires_eq}
16 Obsoletes:      ruby-Ncurses
17 Provides:       ruby-Ncurses
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 This ruby extension makes most functions, constants, and external
22 variables of the C library ncurses accessible from the Ruby
23 programming language.
24
25 All C functions are wrapped by module functions of a the module
26 "Ncurses", with exactly the same name. Additionally, C functions
27 expecting a WINDOW* as their first argument can also be called as
28 methods of the "Ncurses::WINDOW" class.
29
30 %description -l pl.UTF-8
31 Rozszerzenie do ruby, które umożliwia dostęp do większość funkcji,
32 stałych i zewnętrznych zmiennych biblioteki ncurses z poziomu języka
33 Ruby.
34
35 Wszystkie funkcje C są dostępne poprzez funkcje modułu "Ncurses" pod
36 dokładnie tymi samymi nazwami. Dodatkowo funkcje, które spodziewają
37 się mieć WINDOW* jako ich pierwszy argument mogą być także wywoływane
38 jako metody klasy "Ncurses::WINDOW".
39
40 %prep
41 %setup -q -n %{pkgname}-ruby-%{version}
42 %patch0 -p1
43
44 %build
45 ruby extconf.rb
46
47 %{__make} \
48         CC="%{__cc}" \
49         CFLAGS="%{rpmcflags} -I/usr/include/ncursesw -fPIC"
50
51 rdoc --ri --op ri lib
52 rdoc --op rdoc lib
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 install -d $RPM_BUILD_ROOT%{ruby_ridir}
57
58 %{__make} -j1 install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 cp -a ri/* $RPM_BUILD_ROOT%{ruby_ridir}
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc README rdoc
69 %{ruby_sitelibdir}/*.rb
70 %attr(755,root,root) %{ruby_sitearchdir}/*.so
71 %{ruby_ridir}/Ncurses
This page took 0.036979 seconds and 4 git commands to generate.