]> git.pld-linux.org Git - packages/ruby-ncurses.git/blob - ruby-ncurses.spec
- unparallelize make install
[packages/ruby-ncurses.git] / ruby-ncurses.spec
1 %define tarname ncurses-ruby
2 Summary:        Ruby interface to Ncurses
3 Summary(pl.UTF-8):      Interfejs Ncurses dla Ruby
4 Name:           ruby-Ncurses
5 Version:        1.2.4
6 Release:        1
7 License:        Ruby-alike
8 Group:          Development/Languages
9 Source0:        http://download.berlios.de/%{tarname}/%{tarname}-%{version}.tar.bz2
10 # Source0-md5:  8a3e0ed33ac245241b6afd911520c205
11 Patch0:         %{name}-utf8.patch
12 URL:            http://ncurses-ruby.berlios.de/
13 BuildRequires:  rpmbuild(macros) >= 1.277
14 BuildRequires:  ruby-devel >= 1:1.8.4-5
15 %{?ruby_mod_ver_requires_eq}
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 This ruby extension makes most functions, constants, and external
20 variables of the C library ncurses accessible from the Ruby
21 programming language.
22
23 All C functions are wrapped by module functions of a the module
24 "Ncurses", with exactly the same name. Additionally, C functions
25 expecting a WINDOW* as their first argument can also be called as
26 methods of the "Ncurses::WINDOW" class.
27
28 %description -l pl.UTF-8
29 Rozszerzenie do ruby, które umożliwia dostęp do większość funkcji,
30 stałych i zewnętrznych zmiennych biblioteki ncurses z poziomu języka
31 Ruby.
32
33 Wszystkie funkcje C są dostępne poprzez funkcje modułu "Ncurses" pod
34 dokładnie tymi samymi nazwami. Dodatkowo funkcje, które spodziewają
35 się mieć WINDOW* jako ich pierwszy argument mogą być także wywoływane
36 jako metody klasy "Ncurses::WINDOW".
37
38 %prep
39 %setup -q -n %{tarname}-%{version}
40 %patch0 -p1
41
42 %build
43 ruby extconf.rb
44
45 %{__make} \
46         CC="%{__cc}" \
47         CFLAGS="%{rpmcflags} -I/usr/include/ncursesw -fPIC"
48
49 rdoc --ri --op ri lib
50 rdoc --op rdoc lib
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 install -d $RPM_BUILD_ROOT%{ruby_ridir}
55
56 %{__make} -j1 install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 cp -a ri/* $RPM_BUILD_ROOT%{ruby_ridir}
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc README rdoc
67 %{ruby_sitelibdir}/*.rb
68 %attr(755,root,root) %{ruby_sitearchdir}/*.so
69 %{ruby_ridir}/Ncurses
This page took 0.030238 seconds and 4 git commands to generate.