]> git.pld-linux.org Git - packages/ruby-ncurses.git/blob - ruby-ncurses.spec
- added rdoc and ri packages
[packages/ruby-ncurses.git] / ruby-ncurses.spec
1 %define pkgname ncurses
2 Summary:        Ruby interface to Ncurses
3 Summary(pl.UTF-8):      Interfejs Ncurses dla Ruby
4 Name:           ruby-%{pkgname}
5 Version:        1.2.4
6 Release:        1
7 License:        Ruby-alike
8 Group:          Development/Languages
9 Source0:        http://download.berlios.de/ncurses-ruby/%{pkgname}-ruby-%{version}.tar.bz2
10 # Source0-md5:  8a3e0ed33ac245241b6afd911520c205
11 Patch0:         %{name}-utf8.patch
12 URL:            http://ncurses-ruby.berlios.de/
13 BuildRequires:  ncurses-devel
14 BuildRequires:  rpmbuild(macros) >= 1.277
15 BuildRequires:  ruby-devel >= 1:1.8.4-5
16 %{?ruby_mod_ver_requires_eq}
17 Provides:       ruby-Ncurses
18 Obsoletes:      ruby-Ncurses
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 This ruby extension makes most functions, constants, and external
23 variables of the C library ncurses accessible from the Ruby
24 programming language.
25
26 All C functions are wrapped by module functions of a the module
27 "Ncurses", with exactly the same name. Additionally, C functions
28 expecting a WINDOW* as their first argument can also be called as
29 methods of the "Ncurses::WINDOW" class.
30
31 %description -l pl.UTF-8
32 Rozszerzenie do ruby, które umożliwia dostęp do większość funkcji,
33 stałych i zewnętrznych zmiennych biblioteki ncurses z poziomu języka
34 Ruby.
35
36 Wszystkie funkcje C są dostępne poprzez funkcje modułu "Ncurses" pod
37 dokładnie tymi samymi nazwami. Dodatkowo funkcje, które spodziewają
38 się mieć WINDOW* jako ich pierwszy argument mogą być także wywoływane
39 jako metody klasy "Ncurses::WINDOW".
40
41 %package rdoc
42 Summary:        HTML documentation for %{pkgname}
43 Summary(pl.UTF-8):      Dokumentacja w formacie HTML dla %{pkgname}
44 Group:          Documentation
45 Requires:       ruby >= 1:1.8.7-4
46
47 %description rdoc
48 HTML documentation for %{pkgname}.
49
50 %description rdoc -l pl.UTF-8
51 Dokumentacja w formacie HTML dla %{pkgname}.
52
53 %package ri
54 Summary:        ri documentation for %{pkgname}
55 Summary(pl.UTF-8):      Dokumentacja w formacie ri dla %{pkgname}
56 Group:          Documentation
57 Requires:       ruby
58
59 %description ri
60 ri documentation for %{pkgname}.
61
62 %description ri -l pl.UTF-8
63 Dokumentacji w formacie ri dla %{pkgname}.
64
65 %prep
66 %setup -q -n %{pkgname}-ruby-%{version}
67 %patch0 -p1
68
69 %build
70 ruby extconf.rb
71
72 %{__make} \
73         CC="%{__cc}" \
74         CFLAGS="%{rpmcflags} -I/usr/include/ncursesw -fPIC"
75
76 rdoc --ri --op ri lib
77 rdoc --op rdoc lib
78 rm -f ri/created.rid
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82 install -d $RPM_BUILD_ROOT{%{ruby_ridir},%{ruby_rdocdir}}
83
84 %{__make} -j1 install \
85         DESTDIR=$RPM_BUILD_ROOT
86
87 cp -a ri/* $RPM_BUILD_ROOT%{ruby_ridir}
88 cp -a rdoc $RPM_BUILD_ROOT%{ruby_rdocdir}/%{name}-%{version}
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %files
94 %defattr(644,root,root,755)
95 %doc README
96 %{ruby_sitelibdir}/*.rb
97 %attr(755,root,root) %{ruby_sitearchdir}/*.so
98
99 %files rdoc
100 %defattr(644,root,root,755)
101 %{ruby_rdocdir}/%{name}-%{version}
102
103 %files ri
104 %defattr(644,root,root,755)
105 %{ruby_ridir}/Ncurses
This page took 0.03654 seconds and 4 git commands to generate.