]> git.pld-linux.org Git - packages/ruby-ncurses.git/blob - ruby-ncurses.spec
- added. g'day, havner!
[packages/ruby-ncurses.git] / ruby-ncurses.spec
1 %define ruby_rubylibdir %(ruby -r rbconfig -e 'print Config::CONFIG["rubylibdir"]')
2 %define ruby_archdir    %(ruby -r rbconfig -e 'print Config::CONFIG["archdir"]')
3 %define ruby_ridir      %(ruby -r rbconfig -e 'include Config; print File.join(CONFIG["datadir"], "ri", CONFIG["ruby_version"], "system")')
4 Summary:        Ruby interface to Ncurses
5 Name:           ruby-Ncurses
6 %define tarname ncurses-ruby
7 Version:        0.9.1
8 Release:        1
9 License:        Ruby-alike
10 Group:          Development/Languages
11 Source0:        http://download.berlios.de/%{tarname}/%{tarname}-%{version}.tar.bz2
12 # Source0-md5:  cb99721b492995bb3548b700b6e86fe2
13 URL:            http://ncurses-ruby.berlios.de/
14 BuildRequires:  ruby
15 Requires:       ruby
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 This ruby extension makes most functions, constants, and external variables of
20 the C library ncurses  accessible from the Ruby programming language.
21
22 All C functions are wrapped by module functions of a the module "Ncurses", with
23 exactly the same name. Additionally, C functions expecting a WINDOW* as their
24 first argument can also be called as methods of the "Ncurses::WINDOW" class. 
25
26 %prep
27 %setup -q -n %{tarname}-%{version}
28
29 %build
30 ruby extconf.rb
31
32 %{__make} \
33         CC="%{__cc}" \
34         CFLAGS="%{rpmcflags} -fPIC"
35
36 rdoc --ri --op ri lib
37 rdoc --op rdoc lib
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41 install -d $RPM_BUILD_ROOT{%{ruby_rubylibdir},%{ruby_ridir},%{ruby_archdir}}
42
43 cp -a lib/* $RPM_BUILD_ROOT%{ruby_rubylibdir}
44 cp -a ri/ri/* $RPM_BUILD_ROOT%{ruby_ridir}
45 install ncurses.so $RPM_BUILD_ROOT%{ruby_archdir}
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(644,root,root,755)
52 %doc README rdoc
53 %{ruby_rubylibdir}/*.rb
54 %{ruby_archdir}/*.so
55 %{ruby_ridir}/Ncurses
This page took 0.05189 seconds and 4 git commands to generate.