]> git.pld-linux.org Git - packages/ruby-ncurses.git/blob - ruby-ncurses.spec
1ab976410fd8efedf7247100155051af1a088745
[packages/ruby-ncurses.git] / ruby-ncurses.spec
1 %define pkgname ncurses
2 Summary:        Ruby interface to Ncurses
3 Summary(pl.UTF-8):      Interfejs Ncurses dla Ruby
4 Name:           ruby-%{pkgname}
5 Version:        1.3.1
6 Release:        1
7 License:        Ruby-alike
8 Group:          Development/Languages
9 Source0:        http://download.berlios.de/ncurses-ruby/%{pkgname}-ruby-%{version}.tar.bz2
10 # Source0-md5:  63fd3d09a51cdd745e1ed37f85621ea2
11 Patch0:         %{name}-utf8.patch
12 Patch1:         format-security.patch
13 URL:            http://ncurses-ruby.berlios.de/
14 BuildRequires:  ncurses-devel
15 BuildRequires:  rpm-rubyprov
16 BuildRequires:  rpmbuild(macros) >= 1.665
17 BuildRequires:  ruby-devel
18 Provides:       ruby-Ncurses
19 Obsoletes:      ruby-Ncurses
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 This ruby extension makes most functions, constants, and external
24 variables of the C library ncurses accessible from the Ruby
25 programming language.
26
27 All C functions are wrapped by module functions of a the module
28 "Ncurses", with exactly the same name. Additionally, C functions
29 expecting a WINDOW* as their first argument can also be called as
30 methods of the "Ncurses::WINDOW" class.
31
32 %description -l pl.UTF-8
33 Rozszerzenie do ruby, które umożliwia dostęp do większość funkcji,
34 stałych i zewnętrznych zmiennych biblioteki ncurses z poziomu języka
35 Ruby.
36
37 Wszystkie funkcje C są dostępne poprzez funkcje modułu "Ncurses" pod
38 dokładnie tymi samymi nazwami. Dodatkowo funkcje, które spodziewają
39 się mieć WINDOW* jako ich pierwszy argument mogą być także wywoływane
40 jako metody klasy "Ncurses::WINDOW".
41
42 %package rdoc
43 Summary:        HTML documentation for %{pkgname}
44 Summary(pl.UTF-8):      Dokumentacja w formacie HTML dla %{pkgname}
45 Group:          Documentation
46 Requires:       ruby >= 1:1.8.7-4
47
48 %description rdoc
49 HTML documentation for %{pkgname}.
50
51 %description rdoc -l pl.UTF-8
52 Dokumentacja w formacie HTML dla %{pkgname}.
53
54 %package ri
55 Summary:        ri documentation for %{pkgname}
56 Summary(pl.UTF-8):      Dokumentacja w formacie ri dla %{pkgname}
57 Group:          Documentation
58 Requires:       ruby
59
60 %description ri
61 ri documentation for %{pkgname}.
62
63 %description ri -l pl.UTF-8
64 Dokumentacji w formacie ri dla %{pkgname}.
65
66 %prep
67 %setup -q -n %{pkgname}-ruby-%{version}
68 %patch0 -p1
69 %patch1 -p1
70
71 %build
72 ruby extconf.rb \
73         --vendor
74
75 %{__make} \
76         CC="%{__cc}" \
77         CFLAGS="%{rpmcflags} -I/usr/include/ncursesw -fPIC"
78
79 rdoc --ri --op ri lib
80 rdoc --op rdoc lib
81 rm ri/created.rid
82 rm ri/cache.ri
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86 install -d $RPM_BUILD_ROOT{%{ruby_ridir},%{ruby_rdocdir}}
87
88 %{__make} -j1 install \
89         DESTDIR=$RPM_BUILD_ROOT
90
91 cp -a ri/* $RPM_BUILD_ROOT%{ruby_ridir}
92 cp -a rdoc $RPM_BUILD_ROOT%{ruby_rdocdir}/%{name}-%{version}
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %files
98 %defattr(644,root,root,755)
99 %doc README
100 %{ruby_vendorlibdir}/ncurses.rb
101 %{ruby_vendorlibdir}/ncurses_sugar.rb
102 %attr(755,root,root) %{ruby_vendorarchdir}/ncurses_bin.so
103
104 %files rdoc
105 %defattr(644,root,root,755)
106 %{ruby_rdocdir}/%{name}-%{version}
107
108 %files ri
109 %defattr(644,root,root,755)
110 %{ruby_ridir}/Ncurses
This page took 0.028745 seconds and 2 git commands to generate.