]> git.pld-linux.org Git - SPECS.git/blob - ruby-mixlib-cli.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / ruby-mixlib-cli.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 %define         pkgname mixlib-cli
6 Summary:        Simple Ruby mix-in for CLI interfaces
7 Name:           ruby-%{pkgname}
8 Version:        1.7.0
9 Release:        2
10 License:        Apache v2.0
11 Group:          Development/Languages
12 Source0:        http://gems.rubyforge.org/gems/%{pkgname}-%{version}.gem
13 # Source0-md5:  d025beeb0f66c64633f9c27888aa42f3
14 # Patch to silence mixlib-cli tests;
15 # see http://tickets.opscode.com/browse/MIXLIB-8
16 Patch0:         mixlib-cli-silence-tests.patch
17 URL:            http://github.com/opscode/mixlib-cli
18 BuildRequires:  rpm-rubyprov
19 BuildRequires:  rpmbuild(macros) >= 1.665
20 %if %{with tests}
21 BuildRequires:  ruby-rake
22 BuildRequires:  ruby-rdoc
23 BuildRequires:  ruby-rspec
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 A simple mix-in for CLI interfaces, including option parsing.
30
31 %package doc
32 Summary:        Documentation for %{name}
33 Group:          Documentation
34 Requires:       %{name} = %{version}-%{release}
35
36 %description doc
37 This package contains documentation for %{name}.
38
39 %prep
40 %setup -q
41 %patch0 -p1
42
43 %build
44 # write .gemspec
45 %__gem_helper spec
46
47 %if %{with tests}
48 rspec
49 %endif
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir}}
54 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
55 cp -p %{pkgname}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc README.md NOTICE
63 %{ruby_vendorlibdir}/mixlib/cli.rb
64 %{ruby_vendorlibdir}/mixlib/cli
65 %{ruby_specdir}/%{pkgname}-%{version}.gemspec
66
67 # FIXME, who owns the dir?
68 %dir %{ruby_vendorlibdir}/mixlib
69
70 %if 0
71 %files doc
72 %defattr(644,root,root,755)
73 %endif
This page took 0.228989 seconds and 3 git commands to generate.