]> git.pld-linux.org Git - SPECS.git/blob - ruby-listen.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / ruby-listen.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 %define pkgname listen
6 Summary:        Listen to file modifications
7 Name:           ruby-%{pkgname}
8 Version:        2.7.11
9 Release:        2
10 License:        MIT
11 Group:          Development/Languages
12 Source0:        https://github.com/guard/listen/archive/v%{version}/%{pkgname}-%{version}.tar.gz
13 # Source0-md5:  2b1378df84cd0e5ab94d172c3a92d70d
14 Patch0:         deps.patch
15 URL:            https://github.com/guard/listen
16 BuildRequires:  rpm-rubyprov
17 BuildRequires:  rpmbuild(macros) >= 1.656
18 %if %{with tests}
19 BuildRequires:  ruby-bundler >= 1.3.5
20 BuildRequires:  ruby-rake
21 BuildRequires:  ruby-rspec >= 2.14
22 BuildRequires:  ruby-rspec-retry
23 %endif
24 Requires:       ruby-celluloid >= 0.15.2
25 Requires:       ruby-celluloid-io >= 0.15.0
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 The Listen gem listens to file modifications and notifies you about
31 the changes. Works everywhere!
32
33 %prep
34 %setup -q -n %{pkgname}-%{version}
35 %patch0 -p1
36
37 %build
38 # make gemspec self-contained
39 ruby -r rubygems -e 'spec = eval(File.read("%{pkgname}.gemspec"))
40         File.open("%{pkgname}-%{version}.gemspec", "w") do |file|
41         file.puts spec.to_ruby_for_cache
42 end'
43
44 %if %{with tests}
45 rspec spec
46 %endif
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir}}
51 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
52 cp -p %{pkgname}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc README.md CHANGELOG.md
60 %{ruby_vendorlibdir}/%{pkgname}.rb
61 %{ruby_vendorlibdir}/%{pkgname}
62 %{ruby_specdir}/%{pkgname}-%{version}.gemspec
This page took 0.0399969999999999 seconds and 3 git commands to generate.